aboutsummaryrefslogtreecommitdiff
path: root/security/squidclam/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/squidclam/Makefile')
-rw-r--r--security/squidclam/Makefile59
1 files changed, 0 insertions, 59 deletions
diff --git a/security/squidclam/Makefile b/security/squidclam/Makefile
deleted file mode 100644
index 9a2d90eeae16..000000000000
--- a/security/squidclam/Makefile
+++ /dev/null
@@ -1,59 +0,0 @@
-# New ports collection makefile for: squidclam
-# Date created: 2005-06-26
-# Whom: Alexander Novitsky <alecn2002@yandex.ru>
-#
-# $FreeBSD$
-#
-
-PORTNAME= squidclam
-PORTVERSION= 0.11
-PORTREVISION= 5
-CATEGORIES= security
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
-MAINTAINER= alecn2002@yandex.ru
-COMMENT= Bridge betwean ClamAV antivirus software and Squid caching proxy
-
-BUILD_DEPENDS= ${LOCALBASE}/bin/clamscan:${PORTSDIR}/security/clamav \
- ${LOCALBASE}/bin/curl:${PORTSDIR}/ftp/curl
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-NO_INSTALL_MANPAGES= yes
-CFLAGS+= ${PTHREAD_LIBS}
-
-PORTDOCS= README Changelog
-
-SUB_FILES= pkg-message
-
-PLIST_FILES= bin/squidclam %%EXAMPLESDIR%%/squidclam.conf
-PLIST_DIRS= %%EXAMPLESDIR%%
-
-BROKEN= Doesn't build with clamav-0.93 or higher
-DEPRECATED= has been broken for more than 6 months
-EXPIRATION_DATE=2009-01-19
-
-post-patch:
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
- -e 's|%%PREFIX%%|${PREFIX}|g' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|cl_perror|cl_strerror|g' \
- ${WRKSRC}/squidclam.c
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}/$f
-.endfor
-.endif
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/sample.conf ${EXAMPLESDIR}/${PORTNAME}.conf
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>