aboutsummaryrefslogtreecommitdiff
path: root/security/trousers/files/patch-configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'security/trousers/files/patch-configure.in')
-rw-r--r--security/trousers/files/patch-configure.in19
1 files changed, 14 insertions, 5 deletions
diff --git a/security/trousers/files/patch-configure.in b/security/trousers/files/patch-configure.in
index e1b82658d938..489a28fb5fea 100644
--- a/security/trousers/files/patch-configure.in
+++ b/security/trousers/files/patch-configure.in
@@ -1,6 +1,15 @@
---- configure.in.orig 2014-04-24 18:05:43 UTC
-+++ configure.in
-@@ -72,6 +72,21 @@ AC_ARG_ENABLE(gcov,
+--- configure.in.orig 2014-04-25 03:05:43.000000000 +0900
++++ configure.in 2016-05-19 02:57:32.524179000 +0900
+@@ -52,7 +52,7 @@
+ AC_MSG_ERROR([$OPENSSL_INCLUDE_DIR or $OPENSSL_LIB_DIR doen't exist!])
+ else
+ AC_MSG_RESULT([yes])
+- CFLAGS="$CFLAGS -L$OPENSSL_LIB_DIR -I$OPENSSL_INCLUDE_DIR"
++ AC_SUBST([OPENSSL_INCLUDE_DIR])
+ AC_SUBST([OPENSSL_LIB_DIR])
+ fi],
+ [AC_MSG_RESULT([no])
+@@ -72,6 +72,21 @@
[CFLAGS="$CFLAGS -ftest-coverage -fprofile-arcs"
AC_MSG_RESULT([*** Enabling gcov at user request ***])],)
@@ -22,7 +31,7 @@
# profiling support
AC_ARG_ENABLE(gprof,
[AC_HELP_STRING([--enable-gprof], [enable profiling with gprof [default=off]])],
-@@ -356,6 +371,8 @@ AC_PROG_LIBTOOL
+@@ -356,6 +371,8 @@
AC_C_BIGENDIAN([AC_DEFINE(_BIG_ENDIAN, 1, [big-endian host])])
AC_CHECK_DECL(htole32, [AC_DEFINE(HTOLE_DEFINED, 1, [htole32 function is available])])
AC_CHECK_HEADER(sys/byteorder.h, [AC_DEFINE(HAVE_BYTEORDER_H, 1, [sys/byteorder.h header])])
@@ -31,7 +40,7 @@
AC_CHECK_FUNC(daemon, [ AC_DEFINE(HAVE_DAEMON, 1, [daemon function is available]) ])
if test "x${GCC}" = "xyes"; then
-@@ -363,6 +380,7 @@ if test "x${GCC}" = "xyes"; then
+@@ -363,6 +380,7 @@
fi
CFLAGS="$CFLAGS -I../include \