aboutsummaryrefslogtreecommitdiff
path: root/shells/fd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'shells/fd/Makefile')
-rw-r--r--shells/fd/Makefile23
1 files changed, 17 insertions, 6 deletions
diff --git a/shells/fd/Makefile b/shells/fd/Makefile
index 0252ccaa9076..6083687b3d97 100644
--- a/shells/fd/Makefile
+++ b/shells/fd/Makefile
@@ -1,24 +1,35 @@
# New ports collection makefile for: FD
-# Version required: 1.01
+# Version required: 1.01h
# Date created: 20 Feb 1996
# Whom: Nobuhiro Yasutomi <nobu@psrc.isac.co.jp>
#
-# $Id: Makefile,v 1.3 1996/11/17 09:05:43 obrien Exp $
+# $Id: $
#
-DISTNAME= FD-1.01
-PKGNAME= fd-1.01
+DISTNAME= FD-1.01
+PKGNAME= fd-1.01h
CATEGORIES= misc
-MASTER_SITES= ftp://ftp.mei.co.jp/free/others/Utilities/
+# The original distribution (NetNews articles) can be found at following site.
+# site= ftp://skylark.ics.es.osaka-u.ac.jp/pub/FDclone/
+# files= FD-1.01 FD-1.01g FD-1.01h
+# Here ,we use already decoded archive for convenience.
+MASTER_SITES= ftp://ftp.hipecs.hokudai.ac.jp/pub/unix/FD/ \
+ ftp://ftp.cc.saga-u.ac.jp/pub/fj.sources/FD/
+
+PATCHFILES= FD-1.01g.patch.gz FD-1.01h.patch.gz
+PATCH_SITES= ${MASTER_SITES}
MAINTAINER= nobu@psrc.isac.co.jp
ALL_TARGET= goal
-PATCH_STRIP= -p0 -o fdrc
+INSTALL_TARGET= install
MANLANG= ja_JP.EUC
MAN1= fd.1
do-configure:
cd ${WRKSRC} ; make config
+post-install:
+ @strip ${PREFIX}/bin/fd
+
.include <bsd.port.mk>