aboutsummaryrefslogtreecommitdiff
path: root/sysutils/busybox/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/busybox/Makefile')
-rw-r--r--sysutils/busybox/Makefile20
1 files changed, 18 insertions, 2 deletions
diff --git a/sysutils/busybox/Makefile b/sysutils/busybox/Makefile
index 5e83f5c90ede..ba4fbdee0452 100644
--- a/sysutils/busybox/Makefile
+++ b/sysutils/busybox/Makefile
@@ -7,20 +7,32 @@
PORTNAME= busybox
PORTVERSION= 1.18.5
+PORTREVISION= 1
CATEGORIES= sysutils misc shells
MASTER_SITES= http://www.busybox.net/downloads/
MAINTAINER= mandree@FreeBSD.org
COMMENT= Busybox for FreeBSD
+LICENSE= GPLv2
+
BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
-MAKE_ARGS= SKIP_STRIP=y
+MAKE_JOBS_SAFE= yes
+MAKE_ARGS+= SKIP_STRIP=y
USE_BZIP2= yes
USE_GMAKE= yes
+CPPFLAGS+= -include libgen.h
+# avoid clang, breaks in findutils/find.c l. 752+:
+USE_GCC= 4.2+
PLIST_FILES= bin/busybox
+.if !defined(NOPORTDOCS)
+USE_PERL5_BUILD= yes
+PORTDOCS= *
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's/sed/gsed/' ${WRKSRC}/scripts/gen_build_files.sh
@${REINPLACE_CMD} -e 's/<malloc.h>/<stdlib.h>/' \
@@ -29,9 +41,13 @@ post-patch:
do-configure:
${CP} ${FILESDIR}/data-.config ${WRKSRC}/.config
- cd ${WRKSRC} && ${GMAKE} oldconfig
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} oldconfig
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR}
+ ${RM} -f ${DOCSDIR}/.gitignore
+.endif
.include <bsd.port.mk>