aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cfengine/files
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/cfengine/files')
-rw-r--r--sysutils/cfengine/files/patch-ac6
-rw-r--r--sysutils/cfengine/files/patch-af13
-rw-r--r--sysutils/cfengine/files/patch-ag13
3 files changed, 29 insertions, 3 deletions
diff --git a/sysutils/cfengine/files/patch-ac b/sysutils/cfengine/files/patch-ac
index 402872a89106..673d7d0c722d 100644
--- a/sysutils/cfengine/files/patch-ac
+++ b/sysutils/cfengine/files/patch-ac
@@ -18,11 +18,11 @@
$PATH:$prefix/bin:/usr/bin:/usr/local/bin)
-@@ -262,6 +262,7 @@
+@@ -262,7 +262,7 @@
freebsd*)
AC_DEFINE(FREEBSD)
- CFLAGS="$CFLAGS -pthread"
-+ LIBS="$LIBS -ldes"
+- CFLAGS="$CFLAGS -pthread"
++ LIBS="$LIBS -ldes"
AC_CHECK_HEADERS(pthread.h)
;;
netbsd*)
diff --git a/sysutils/cfengine/files/patch-af b/sysutils/cfengine/files/patch-af
new file mode 100644
index 000000000000..c7a33e7b209e
--- /dev/null
+++ b/sysutils/cfengine/files/patch-af
@@ -0,0 +1,13 @@
+Fix the linking so only cfd is linked with pthreads. This keeps cfengine
+from trying to use thread-unsafe resolver functions.
+
+--- src/Makefile.am.orig Fri Aug 10 23:58:47 2001
++++ src/Makefile.am Fri Aug 10 23:59:07 2001
+@@ -95,6 +95,7 @@
+ patches.c
+
+ cfd_LDADD = -L../pub -lpub $(LEXLIB)
++cfd_LDFLAGS = -pthread $(LDFLAGS)
+
+ cfrun_SOURCES = \
+ cfrun.c \
diff --git a/sysutils/cfengine/files/patch-ag b/sysutils/cfengine/files/patch-ag
new file mode 100644
index 000000000000..1a8101cb3542
--- /dev/null
+++ b/sysutils/cfengine/files/patch-ag
@@ -0,0 +1,13 @@
+This fixes the problem with cfd not finding the correct interfaces.
+
+--- src/misc.c.orig Wed Jan 24 07:28:01 2001
++++ src/misc.c Fri Aug 10 23:34:45 2001
+@@ -284,7 +284,7 @@
+ list.ifc_len = sizeof(ifbuf);
+ list.ifc_req = ifbuf;
+
+-if (ioctl(fd, SIOCGIFCONF, &list) == -1 || (list.ifc_len < (sizeof(struct ifreq))))
++if (ioctl(fd, OSIOCGIFCONF, &list) == -1 || (list.ifc_len < (sizeof(struct ifreq))))
+ {
+ CfLog(cferror,"Couldn't get interfaces","ioctl");
+ exit(1);