aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cog/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/cog/Makefile')
-rw-r--r--sysutils/cog/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/sysutils/cog/Makefile b/sysutils/cog/Makefile
index e210d2da9322..eb469aa9aef3 100644
--- a/sysutils/cog/Makefile
+++ b/sysutils/cog/Makefile
@@ -15,9 +15,18 @@ COMMENT= A program for editing advanced GNOME settings in an easy way
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+post-patch:
+ @${REINPLACE_CMD} -e 's|Icon=|Icon=cog-icon-2-48x48.png|g' \
+ ${WRKSRC}/cog.desktop
+
+post-install:
+ @${LN} -sf ${PREFIX}/share/gnome/cog/pixmaps/cog-icon-2-48x48.png \
+ ${PREFIX}/share/gnome/pixmaps/cog-icon-2-48x48.png
+
.include <bsd.port.mk>