aboutsummaryrefslogtreecommitdiff
path: root/sysutils/djmount
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/djmount')
-rw-r--r--sysutils/djmount/Makefile42
-rw-r--r--sysutils/djmount/distinfo3
-rw-r--r--sysutils/djmount/files/patch-djmount63
-rw-r--r--sysutils/djmount/pkg-descr12
4 files changed, 120 insertions, 0 deletions
diff --git a/sysutils/djmount/Makefile b/sysutils/djmount/Makefile
new file mode 100644
index 000000000000..5bd801c3afd4
--- /dev/null
+++ b/sysutils/djmount/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: djmount
+# Date created: 15 October 2008
+# Whom: Eric L. Chen <d9364104@mail.nchu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= djmount
+PORTVERSION= 0.71
+CATEGORIES= sysutils
+MASTER_SITES= SF
+
+MAINTAINER= d9364104@mail.nchu.edu.tw
+COMMENT= Mount UPnP A/V Media
+
+LIB_DEPENDS= fuse.2:${PORTSDIR}/sysutils/fusefs-libs \
+ upnp.3:${PORTSDIR}/devel/upnp
+BUILD_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+
+PLIST_FILES= bin/${PORTNAME}
+GNU_CONFIGURE= yes
+USE_GNOME= pkgconfig
+CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
+ --with-fuse-prefix=${LOCALBASE} \
+ --with-external-libupnp --with-libupnp-prefix=${LOCALBASE}
+
+PORTDOCS= AUTHORS ChangeLog NEWS README TODO
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+IGNORE= depends on kernel module that requires FreeBSD 6 or later
+.endif
+
+post-install:
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/djmount/distinfo b/sysutils/djmount/distinfo
new file mode 100644
index 000000000000..b81ae4966015
--- /dev/null
+++ b/sysutils/djmount/distinfo
@@ -0,0 +1,3 @@
+MD5 (djmount-0.71.tar.gz) = c922753e706c194bf82a8b6ca77e6a9a
+SHA256 (djmount-0.71.tar.gz) = aa5bb482af4cbd42695a7e396043d47b53d075ac2f6aa18a8f8e11383c030e4f
+SIZE (djmount-0.71.tar.gz) = 1159653
diff --git a/sysutils/djmount/files/patch-djmount b/sysutils/djmount/files/patch-djmount
new file mode 100644
index 000000000000..fdaf6bd72e1f
--- /dev/null
+++ b/sysutils/djmount/files/patch-djmount
@@ -0,0 +1,63 @@
+--- configure.ac 2006-08-28 04:12:33.000000000 +0800
++++ configure.ac 2008-10-15 10:46:23.000000000 +0800
+@@ -240,7 +240,7 @@ RT_PACKAGE_FIND([fuse], [-D_FILE_OFFSET_
+ ** $FUSE_MSG_ERRORS
+ ])])
+
+-FUSE_CFLAGS="$FUSE_CFLAGS -DFUSE_USE_VERSION=22"
++FUSE_CFLAGS="$FUSE_CFLAGS -DFUSE_USE_VERSION=25"
+
+
+ #
+--- configure 2006-08-28 04:13:13.000000000 +0800
++++ configure 2008-10-15 10:46:23.000000000 +0800
+@@ -26489,7 +26489,7 @@ fi
+
+
+
+-FUSE_CFLAGS="$FUSE_CFLAGS -DFUSE_USE_VERSION=22"
++FUSE_CFLAGS="$FUSE_CFLAGS -DFUSE_USE_VERSION=25"
+
+
+ #
+diff -purN djmount/cache.h djmount/cache.h
+--- djmount/cache.h 2006-08-28 04:12:20.000000000 +0800
++++ djmount/cache.h 2008-10-15 11:12:35.000000000 +0800
+@@ -25,6 +25,9 @@
+
+ #include <stdlib.h>
+ #include <stdbool.h>
++#ifdef __FreeBSD__
++#include <time.h>
++#endif
+
+
+ /******************************************************************************
+diff -purN djmount/fuse_main.c djmount/fuse_main.c
+--- djmount/fuse_main.c 2006-08-28 04:12:20.000000000 +0800
++++ djmount/fuse_main.c 2008-10-15 11:12:21.000000000 +0800
+@@ -32,7 +32,9 @@
+ #include <fcntl.h>
+ #include <dirent.h>
+ #include <errno.h>
++#ifdef __linux__
+ #include <sys/statfs.h>
++#endif
+ #ifdef HAVE_SETXATTR
+ # include <sys/xattr.h>
+ #endif
+diff -purN djmount/string_util.c djmount/string_util.c
+--- djmount/string_util.c 2006-08-28 04:12:20.000000000 +0800
++++ djmount/string_util.c 2008-10-15 11:12:03.000000000 +0800
+@@ -251,7 +251,11 @@ StringStream_GetSnapshot (StringStream*
+ if (res && slen)
+ *slen = ss->size;
+ #else
++#ifdef __linux__
+ off_t const size = ftello (ss->file);
++#else
++ size_t const size = ftello (ss->file);
++#endif
+ res = talloc_size (result_context, size+1);
+ if (res) {
+ rewind (ss->file);
diff --git a/sysutils/djmount/pkg-descr b/sysutils/djmount/pkg-descr
new file mode 100644
index 000000000000..a2002b726330
--- /dev/null
+++ b/sysutils/djmount/pkg-descr
@@ -0,0 +1,12 @@
+djmount is a UPnP AV client. It mounts as a Linux filesystem the media
+content of compatible UPnP AV devices.
+Djmount discovers automatically all UPnP AV Media Servers on the network,
+and make the content available in a directory tree. All shared files
+(e.g. Audio or Video files) are directly visible and can be played using
+your favorite media player.
+
+djmount is written in C for the Linux operating system.
+It is free software, licensed under the terms of the GNU General Public
+License (GNU GPL).
+
+WWW: http://djmount.sourceforge.net/