aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fastresolve/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/fastresolve/Makefile')
-rw-r--r--sysutils/fastresolve/Makefile32
1 files changed, 23 insertions, 9 deletions
diff --git a/sysutils/fastresolve/Makefile b/sysutils/fastresolve/Makefile
index 6830858cbd10..f374c39a69b2 100644
--- a/sysutils/fastresolve/Makefile
+++ b/sysutils/fastresolve/Makefile
@@ -7,20 +7,39 @@
PORTNAME= fastresolve
PORTVERSION= 2.10
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.djmnet.org/sw/dist/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= martin@tradex.sk
COMMENT= Programs that process web logs to get DNS and domain ownership info
-LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3 \
- adns.1:${PORTSDIR}/dns/adns
+LIB_DEPENDS= adns.1:${PORTSDIR}/dns/adns
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/BerkeleyDB.pm:${PORTSDIR}/databases/p5-BerkeleyDB
USE_BZIP2= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
- CXXFLAGS="-I${LOCALBASE}/include/db3 -I${LOCALBASE}/include"
+ CXXFLAGS="-I${LOCALBASE}/include" \
+ PERL=${PERL}
+USE_AUTOMAKE_VER= 14
+
+# Default to db3
+WITH_BDB_VER?= 3
+
+.if ${WITH_BDB_VER} == 3
+LIB_DEPENDS+= db3.3:${PORTSDIR}/databases/db3
+CONFIGURE_ARGS= --with-bdb-lib=-ldb3_cxx --with-bdb-incdir=${LOCALBASE}/include/db3
+.elif ${WITH_BDB_VER} == 4
+LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
+CONFIGURE_ARGS= --with-bdb-lib=-ldb4_cxx --with-bdb-incdir=${LOCALBASE}/include/db4
+.elif ${WITH_BDB_VER} == 41
+LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
+CONFIGURE_ARGS= --with-bdb-lib=-ldb41_cxx --with-bdb-incdir=${LOCALBASE}/include/db41
+.else
+.error WITH_BDB_VER must be one between 3, 4 and 41
+.endif
MAN1= dns-terror.1 btree-dump.1 convert-dom-db.1 convert-ip-db.1 \
expire-ip-db.1 getdominfo.1 rebuild-dom-db.1 rebuild-ip-db.1 \
@@ -36,9 +55,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/doc/timings ${DOCSDIR}
.endif
- @${ECHO_MSG} ""
- @${ECHO_MSG} "If you want to use the convert-ip-db script you must"
- @${ECHO_MSG} "install the databases/p5-BerkeleyDB port"
- @${ECHO_MSG} ""
-
.include <bsd.port.mk>