aboutsummaryrefslogtreecommitdiff
path: root/sysutils/rsyncmanager/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/rsyncmanager/Makefile')
-rw-r--r--sysutils/rsyncmanager/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/sysutils/rsyncmanager/Makefile b/sysutils/rsyncmanager/Makefile
index 0fa648cca55c..b1e1f2e146a2 100644
--- a/sysutils/rsyncmanager/Makefile
+++ b/sysutils/rsyncmanager/Makefile
@@ -16,26 +16,22 @@ USE_RUBY_FEATURES= ruby18
NO_BUILD= yes
+PLIST_FILES= bin/rsyncmanager.rb etc/rsyncmanager.xml.sample
PORTDOCS= README
USE_RC_SUBR= ${PORTNAME}
SUB_LIST= RUBY_WITHOUT_SUFFIX="${RUBY_WITHOUT_SUFFIX}"
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-extract:
@${MV} ${WRKDIR}/${PORTNAME} ${WRKSRC}
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/${PORTNAME}.rb ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/documentation/${PORTNAME}.xml ${PREFIX}/etc/${PORTNAME}.xml.sample
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for docfile in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/documentation/${docfile} ${DOCSDIR}
-.endfor
-.endif
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/${PORTNAME}.rb ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/documentation/${PORTNAME}.xml \
+ ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.xml.sample
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/documentation/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>