aboutsummaryrefslogtreecommitdiff
path: root/sysutils/u-boot-pandaboard/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/u-boot-pandaboard/Makefile')
-rw-r--r--sysutils/u-boot-pandaboard/Makefile42
1 files changed, 5 insertions, 37 deletions
diff --git a/sysutils/u-boot-pandaboard/Makefile b/sysutils/u-boot-pandaboard/Makefile
index 9dd1357ae90c..ff41b2b37c49 100644
--- a/sysutils/u-boot-pandaboard/Makefile
+++ b/sysutils/u-boot-pandaboard/Makefile
@@ -1,42 +1,10 @@
# $FreeBSD$
-PORTNAME= u-boot
-PORTVERSION= 2014.10
-CATEGORIES= sysutils
-MASTER_SITES= ftp://ftp.denx.de/pub/u-boot/
-PKGNAMESUFFIX= -pandaboard
+MAINTAINER= imp@FreeBSD.org
+USES= u-boot gmake
-MAINTAINER= ian@FreeBSD.org
-COMMENT= Cross-build U-Boot loader for PandaBoard
-
-LICENSE= GPLv2
-
-BUILD_DEPENDS= ${CROSS_GCC}:devel/arm-none-eabi-gcc492
-
-CROSS_GCC= arm-none-eabi-gcc-4.9.2
-
-NO_ARCH= yes
-
-WRKSRC= ${WRKDIR}/u-boot-${PORTVERSION}
-USES= gmake tar:bzip2
-SSP_UNSAFE= yes # cross-LD does not support -fstack-protector
-
-U_BOOT_DIR= share/u-boot/${PORTNAME}${PKGNAMESUFFIX}
-PLIST_FILES= ${U_BOOT_DIR}/u-boot.img \
- ${U_BOOT_DIR}/MLO \
- ${U_BOOT_DIR}/README
-
-MAKE_ARGS+= ARCH=arm \
- CC=${CROSS_GCC} \
- CROSS_COMPILE=arm-none-eabi-
-
-do-configure:
- (cd ${WRKSRC}; ${MAKE_CMD} omap4_panda_config)
-
-do-install:
- ${MKDIR} ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}
- ${INSTALL_DATA} ${WRKSRC}/MLO ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}
- ${INSTALL_DATA} ${WRKSRC}/u-boot.img ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}
- ${INSTALL_DATA} ${DESCR} ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}/README
+MODEL= pandaboard
+BOARD_CONFIG= omap4_panda_config
+FAMILY= omap
.include <bsd.port.mk>