aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/filedupe/Makefile3
-rw-r--r--sysutils/fileschanged/Makefile23
-rw-r--r--sysutils/fileschanged/pkg-plist8
-rw-r--r--sysutils/fortunelock/Makefile5
-rw-r--r--sysutils/fortunelock/files/patch-aa10
-rw-r--r--sysutils/fusefs-cryptofs/Makefile13
-rw-r--r--sysutils/fusefs-cryptofs/pkg-plist4
-rw-r--r--sysutils/fusefs-funionfs/Makefile4
-rw-r--r--sysutils/fusefs-fur/Makefile9
-rw-r--r--sysutils/fusefs-fusepak/Makefile6
-rw-r--r--sysutils/fusefs-gnome-vfs/Makefile10
-rw-r--r--sysutils/fusefs-httpfs/Makefile6
-rw-r--r--sysutils/fusefs-ntfs/Makefile9
-rw-r--r--sysutils/fusefs-ntfs/pkg-plist17
-rw-r--r--sysutils/fusefs-smbnetfs/Makefile6
-rw-r--r--sysutils/fusefs-sqlfs/Makefile10
16 files changed, 72 insertions, 71 deletions
diff --git a/sysutils/filedupe/Makefile b/sysutils/filedupe/Makefile
index e7e90b6515ac..5c4bb9663b78 100644
--- a/sysutils/filedupe/Makefile
+++ b/sysutils/filedupe/Makefile
@@ -14,12 +14,11 @@ LIB_DEPENDS= gdbm:${PORTSDIR}/databases/gdbm
PLIST_FILES= bin/filedupe
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's|filename\[80\]|filename[1024]|g; \
s|your_database|/var/db/filedupe.db|' ${WRKSRC}/filedupe.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/filedupe ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/filedupe ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/sysutils/fileschanged/Makefile b/sysutils/fileschanged/Makefile
index 58e9b755e3ce..248b019204d1 100644
--- a/sysutils/fileschanged/Makefile
+++ b/sysutils/fileschanged/Makefile
@@ -10,12 +10,11 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Utility that reports when files have been altered
-BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone \
- help2man:${PORTSDIR}/misc/help2man
+LIB_DEPENDS= libargp.so:${PORTSDIR}/devel/argp-standalone
+BUILD_DEPENDS= help2man:${PORTSDIR}/misc/help2man
GNU_CONFIGURE= yes
-NO_STAGE= yes
-USE_GMAKE= yes
+USES= gmake
USE_FAM= yes
CONFIGURE_ENV+= LIBS="-largp"
CPPFLAGS+= -I${LOCALBASE}/include
@@ -23,15 +22,17 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --datadir=${PREFIX}/share/doc --disable-nls
INFO= fileschanged
-MAN1= fileschanged.1
-PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README
-PLIST_FILES= bin/fileschanged
+DOCS= AUTHORS ChangeLog INSTALL NEWS README
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
-.if !defined(NOPORTDOCS)
post-install:
- ${MKDIR} ${DOCSDIR}
-.for DOCFILE in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${DOCFILE} ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for DOCFILE in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${DOCFILE} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
diff --git a/sysutils/fileschanged/pkg-plist b/sysutils/fileschanged/pkg-plist
new file mode 100644
index 000000000000..0be7c3602b20
--- /dev/null
+++ b/sysutils/fileschanged/pkg-plist
@@ -0,0 +1,8 @@
+bin/fileschanged
+man/man1/fileschanged.1.gz
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/sysutils/fortunelock/Makefile b/sysutils/fortunelock/Makefile
index cf51610eccee..a48ba2187359 100644
--- a/sysutils/fortunelock/Makefile
+++ b/sysutils/fortunelock/Makefile
@@ -12,9 +12,6 @@ COMMENT= Locks a terminal while showing fortunes
USE_BZIP2= yes
-MAN1= fortunelock.1
-MANCOMPRESSED= no
-PLIST_FILES= bin/fortunelock
+PLIST_FILES= bin/fortunelock man/man1/${PORTNAME}.1.gz
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/sysutils/fortunelock/files/patch-aa b/sysutils/fortunelock/files/patch-aa
index 440a2c72e4ef..d6fdac07c8a0 100644
--- a/sysutils/fortunelock/files/patch-aa
+++ b/sysutils/fortunelock/files/patch-aa
@@ -1,5 +1,5 @@
---- Makefile.orig Thu Apr 20 14:15:07 2000
-+++ Makefile Wed Apr 26 19:16:04 2000
+--- Makefile.orig 2000-04-21 05:15:07.000000000 +0800
++++ Makefile 2013-11-09 19:38:12.000000000 +0800
@@ -1,10 +1,10 @@
-CC=gcc
-CFLAGS=-O3
@@ -14,14 +14,14 @@
all: $(TARGET)
-@@ -19,8 +19,8 @@
+@@ -19,8 +19,8 @@ fortunelock.o: fortunelock.c fortunelock
install:
strip fortunelock
- install -m 755 fortunelock $(PREFIXDIR)/bin
- install -m 644 fortunelock.1 $(PREFIXDIR)/man/man1
-+ install -c -m 755 fortunelock $(PREFIX)/bin
-+ install -c -m 644 fortunelock.1 $(PREFIX)/man/man1
++ install -c -m 755 fortunelock $(DESTDIR)$(PREFIX)/bin
++ install -c -m 644 fortunelock.1 $(DESTDIR)$(PREFIX)/man/man1
uninstall:
- rm -rf $(PREFIXDIR)/bin/fortunelock
diff --git a/sysutils/fusefs-cryptofs/Makefile b/sysutils/fusefs-cryptofs/Makefile
index 35600f589729..4463074c09a6 100644
--- a/sysutils/fusefs-cryptofs/Makefile
+++ b/sysutils/fusefs-cryptofs/Makefile
@@ -17,15 +17,16 @@ LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt \
USE_BZIP2= yes
GNU_CONFIGURE= yes
USES= fuse pkgconfig
-NO_STAGE= yes
+DOCS= README cryptofs.conf
-PLIST_FILES= bin/cryptofs
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
-.if !defined(NOPORTDOCS)
-PORTDOCS= README cryptofs.conf
post-install:
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/sysutils/fusefs-cryptofs/pkg-plist b/sysutils/fusefs-cryptofs/pkg-plist
new file mode 100644
index 000000000000..aec457c0685e
--- /dev/null
+++ b/sysutils/fusefs-cryptofs/pkg-plist
@@ -0,0 +1,4 @@
+bin/cryptofs
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/cryptofs.conf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/sysutils/fusefs-funionfs/Makefile b/sysutils/fusefs-funionfs/Makefile
index 61391506c9c3..2c22f208f554 100644
--- a/sysutils/fusefs-funionfs/Makefile
+++ b/sysutils/fusefs-funionfs/Makefile
@@ -15,8 +15,6 @@ CFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
USES= fuse
-MAN1= funionfs.1
-PLIST_FILES= bin/funionfs
+PLIST_FILES= bin/funionfs man/man1/${PORTNAME}.1.gz
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/sysutils/fusefs-fur/Makefile b/sysutils/fusefs-fur/Makefile
index 1f861ae06760..ec520c22ba14 100644
--- a/sysutils/fusefs-fur/Makefile
+++ b/sysutils/fusefs-fur/Makefile
@@ -11,22 +11,19 @@ DISTNAME= FUR-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= FUSE-based filesystem for Windows CE based devices
-LIB_DEPENDS= rapi:${PORTSDIR}/palm/synce-librapi2
+LIB_DEPENDS= librapi.so:${PORTSDIR}/palm/synce-librapi2
OPTIONS_DEFINE= VCHMOD
OPTIONS_DEFAULT= VCHMOD
VCHMOD_DESC= Fake hook for chmod that just returns 0
-
GNU_CONFIGURE= yes
-USES= fuse pkgconfig iconv
-USE_GMAKE= yes
+USES= fuse pkgconfig iconv gmake
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include -DFUSE_USE_VERSION=26
PLIST_FILES= bin/${PORTNAME}
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MVCHMOD}
@@ -34,6 +31,6 @@ CONFIGURE_ARGS+= --enable-void-chmod
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/Fur ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/Fur ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>
diff --git a/sysutils/fusefs-fusepak/Makefile b/sysutils/fusefs-fusepak/Makefile
index 52328594e98e..0118b804c1a7 100644
--- a/sysutils/fusefs-fusepak/Makefile
+++ b/sysutils/fusefs-fusepak/Makefile
@@ -16,12 +16,10 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USES= fuse pkgconfig
-PLIST_FILES= bin/pakmount
-MAN1= pakmount.1
+PLIST_FILES= bin/pakmount man/man1/pakmount.1.gz
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's,Linux,${OPSYS}, ; s,Fatnasy,Fantasy,' \
- ${WRKSRC}/src/${MAN1}
+ ${WRKSRC}/src/pakmount.1
.include <bsd.port.mk>
diff --git a/sysutils/fusefs-gnome-vfs/Makefile b/sysutils/fusefs-gnome-vfs/Makefile
index ff0dc2f9d906..25b2ac564fb0 100644
--- a/sysutils/fusefs-gnome-vfs/Makefile
+++ b/sysutils/fusefs-gnome-vfs/Makefile
@@ -13,18 +13,16 @@ COMMENT= Interface between FUSE and the Gnome VFS 2.0
RPORTNAME= gnome-vfs-fuse
WRKSRC= ${WRKDIR}/${RPORTNAME}
-USES= fuse pkgconfig
+USES= fuse pkgconfig gmake
USE_GNOME= gnomevfs2
-USE_GMAKE= yes
PLIST_FILES= bin/gnomevfs-mount
PORTDOCS= README
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/gnomevfs-mount ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/gnomevfs-mount ${STAGEDIR}${PREFIX}/bin
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/sysutils/fusefs-httpfs/Makefile b/sysutils/fusefs-httpfs/Makefile
index d0ece95c033c..bb34f6f62b8d 100644
--- a/sysutils/fusefs-httpfs/Makefile
+++ b/sysutils/fusefs-httpfs/Makefile
@@ -15,14 +15,12 @@ COMMENT= Fuse-based http filesystem
WRKSRC= ${WRKDIR}/${PORTNAME}2-${VERSION}
VERSION= 0.1.5
-USES= fuse pkgconfig
-USE_GMAKE= yes
+USES= fuse pkgconfig gmake
CFLAGS+= -D__BSD_VISIBLE
ALL_TARGET= httpfs2
PLIST_FILES= bin/httpfs2
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/httpfs2 ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/httpfs2 ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/sysutils/fusefs-ntfs/Makefile b/sysutils/fusefs-ntfs/Makefile
index 7cf0f4329449..ca567074dc25 100644
--- a/sysutils/fusefs-ntfs/Makefile
+++ b/sysutils/fusefs-ntfs/Makefile
@@ -32,12 +32,6 @@ UBLIO_DESC= Enable user space cache for improved speed
SUB_FILES= pkg-message
DOCSDIR= ${PREFIX}/share/doc/ntfs-3g
-MAN8= mkntfs.8 ntfs-3g.8 ntfs-3g.probe.8 \
- ntfs-3g.secaudit.8 ntfs-3g.usermap.8 ntfscat.8 ntfsclone.8 \
- ntfscluster.8 ntfscmp.8 ntfscp.8 ntfsfix.8 ntfsinfo.8 \
- ntfslabel.8 ntfsls.8 ntfsprogs.8 ntfsresize.8 ntfsundelete.8
-
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MLOCK}
@@ -64,8 +58,7 @@ post-patch:
post-install:
.if !defined(NOPORTDOCS)
- ${INSTALL_DATA} ${FILESDIR}/README.FreeBSD ${DOCSDIR}
+ ${INSTALL_DATA} ${FILESDIR}/README.FreeBSD ${STAGEDIR}${DOCSDIR}
.endif
- @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
.include <bsd.port.post.mk>
diff --git a/sysutils/fusefs-ntfs/pkg-plist b/sysutils/fusefs-ntfs/pkg-plist
index f7cf3bbf9e86..ac3e4985d25a 100644
--- a/sysutils/fusefs-ntfs/pkg-plist
+++ b/sysutils/fusefs-ntfs/pkg-plist
@@ -50,6 +50,23 @@ lib/libntfs-3g.la
lib/libntfs-3g.so
lib/libntfs-3g.so.83
libdata/pkgconfig/libntfs-3g.pc
+man/man8/mkntfs.8.gz
+man/man8/ntfs-3g.8.gz
+man/man8/ntfs-3g.probe.8.gz
+man/man8/ntfs-3g.secaudit.8.gz
+man/man8/ntfs-3g.usermap.8.gz
+man/man8/ntfscat.8.gz
+man/man8/ntfsclone.8.gz
+man/man8/ntfscluster.8.gz
+man/man8/ntfscmp.8.gz
+man/man8/ntfscp.8.gz
+man/man8/ntfsfix.8.gz
+man/man8/ntfsinfo.8.gz
+man/man8/ntfslabel.8.gz
+man/man8/ntfsls.8.gz
+man/man8/ntfsprogs.8.gz
+man/man8/ntfsresize.8.gz
+man/man8/ntfsundelete.8.gz
sbin/mkntfs
sbin/ntfsclone
sbin/ntfscp
diff --git a/sysutils/fusefs-smbnetfs/Makefile b/sysutils/fusefs-smbnetfs/Makefile
index 4a6549c37dbf..a8f48f5e8220 100644
--- a/sysutils/fusefs-smbnetfs/Makefile
+++ b/sysutils/fusefs-smbnetfs/Makefile
@@ -14,7 +14,7 @@ OPTIONS_DEFINE= GNOME_KEYRING
OPTIONS_DEFAULT=GNOME_KEYRING
GNOME_KEYRING_DESC= Build with gnome-keyring support
-LIB_DEPENDS= smbclient.0:${PORTSDIR}/net/samba-libsmbclient
+LIB_DEPENDS= libsmbclient.so:${PORTSDIR}/net/samba-libsmbclient
DOCSDIR+= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
@@ -26,7 +26,6 @@ CFLAGS+= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
SUB_FILES= pkg-message
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGNOME_KEYRING}
@@ -39,7 +38,4 @@ CONFIGURE_ARGS+=--with-gnome-keyring=no
post-patch:
${REINPLACE_CMD} -e 's|а|a|g' ${WRKSRC}/${CONFIGURE_SCRIPT}
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>
diff --git a/sysutils/fusefs-sqlfs/Makefile b/sysutils/fusefs-sqlfs/Makefile
index ec23a165c408..9978b4b6011b 100644
--- a/sysutils/fusefs-sqlfs/Makefile
+++ b/sysutils/fusefs-sqlfs/Makefile
@@ -22,7 +22,6 @@ PORTDOCS= README
PLIST_FILES= bin/sqlfs
-NO_STAGE= yes
.include <bsd.port.pre.mk>
do-build:
@@ -33,14 +32,11 @@ do-build:
-o sqlfs)
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/sqlfs ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/sqlfs ${STAGEDIR}${PREFIX}/bin/
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}/
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/
.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.post.mk>