aboutsummaryrefslogtreecommitdiff
path: root/textproc/beediff
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/beediff')
-rw-r--r--textproc/beediff/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/textproc/beediff/Makefile b/textproc/beediff/Makefile
index 44accd071931..8cb322ce8b05 100644
--- a/textproc/beediff/Makefile
+++ b/textproc/beediff/Makefile
@@ -8,11 +8,10 @@ MASTER_SITES= http://www.beesoft.pl/download/
DISTNAME= ${PORTNAME}_${PORTVERSION}_src
MAINTAINER= makc@FreeBSD.org
-COMMENT= Qt4 based diff frontend
+COMMENT= Qt 4 based diff frontend
+USES= qmake
USE_QT4= gui moc_build rcc_build qmake_build
-HAS_CONFIGURE= yes
-INSTALLS_ICONS= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -20,14 +19,10 @@ PLIST_FILES= bin/beediff share/pixmaps/beediff.png
DESKTOP_ENTRIES="BeeDiff" "diff frontend" \
"${PREFIX}/share/pixmaps/${PORTNAME}.png" \
- "beediff" "" false
-
-NO_STAGE= yes
-do-configure:
- cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS}
+ "beediff" "" true
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/beediff ${PREFIX}/bin/
- ${INSTALL_DATA} ${WRKSRC}/img/beediff.png ${PREFIX}/share/pixmaps/
+ ${INSTALL_PROGRAM} ${WRKSRC}/beediff ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/img/beediff.png ${STAGEDIR}${PREFIX}/share/pixmaps
.include <bsd.port.mk>