aboutsummaryrefslogtreecommitdiff
path: root/textproc/discount/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/discount/Makefile')
-rw-r--r--textproc/discount/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/textproc/discount/Makefile b/textproc/discount/Makefile
index f51232ad8136..22286914dd2d 100644
--- a/textproc/discount/Makefile
+++ b/textproc/discount/Makefile
@@ -4,6 +4,7 @@
PORTNAME= discount
PORTVERSION= 2.2.7
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= textproc devel
MAINTAINER= sunpoet@FreeBSD.org
@@ -18,12 +19,13 @@ USE_GITHUB= yes
GH_ACCOUNT= Orc
CFLAGS+= -fPIC
-CONFIGURE_ARGS= --mandir=${PREFIX}/share/man --prefix=${PREFIX}
+CONFIGURE_ARGS= --mandir=${PREFIX}/share/man --prefix=${PREFIX} --shared
CONFIGURE_SCRIPT= configure.sh
HAS_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes # libmarkdown is used before it is built
INSTALL_TARGET= install install.man
TEST_TARGET= test
+USE_LDCONFIG= yes
CONFLICTS_INSTALL= markdown
@@ -38,4 +40,11 @@ EXTRA_CONFIGURE_ON= --with-dl=both --with-fenced-code --with-github-tags --with-
SAMPLES_INSTALL_TARGET= install install.samples
TAB8_CONFIGURE_ON= --with-tabstops=8
+post-configure:
+ @${REINPLACE_CMD} -e 's|/sbin/ldconfig|#&|' ${WRKSRC}/librarian.sh
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/libmarkdown.a ${STAGEDIR}${PREFIX}/lib/libmarkdown.a
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmarkdown.so
+
.include <bsd.port.mk>