aboutsummaryrefslogtreecommitdiff
path: root/textproc/eruby/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/eruby/Makefile')
-rw-r--r--textproc/eruby/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/textproc/eruby/Makefile b/textproc/eruby/Makefile
index 7d01da624941..0282bbad7d21 100644
--- a/textproc/eruby/Makefile
+++ b/textproc/eruby/Makefile
@@ -13,15 +13,10 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
-RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+USE_RUBY= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-RUBY?= ${LOCALBASE}/bin/ruby
-RUBY_VER?= 1.4
-RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
-
DOCS_EN= ChangeLog README.en
DOCS_JA= README.ja
@@ -30,13 +25,15 @@ do-configure:
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/ruby/eruby/ja
+ ${MKDIR} ${RUBY_DOCDIR}/eruby/ja
.for f in ${DOCS_EN}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/eruby/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/eruby/
.endfor
.for f in ${DOCS_JA}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/eruby/ja/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/eruby/ja/
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.ruby.mk"
+.include <bsd.port.post.mk>