aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-texmath/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/hs-texmath/Makefile')
-rw-r--r--textproc/hs-texmath/Makefile22
1 files changed, 6 insertions, 16 deletions
diff --git a/textproc/hs-texmath/Makefile b/textproc/hs-texmath/Makefile
index 260793b7f217..162a190c78e2 100644
--- a/textproc/hs-texmath/Makefile
+++ b/textproc/hs-texmath/Makefile
@@ -6,17 +6,18 @@
#
PORTNAME= texmath
-PORTVERSION= 0.3.0.2
+PORTVERSION= 0.5.0.1
CATEGORIES= textproc haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Conversion of LaTeX math formulas to MathML for Haskell
+LICENSE= GPLv2
+
CABAL_SETUP= Setup.hs
-USE_HACKAGE= xml utf8-string
+USE_CABAL= parsec>=2 syb xml
-OPTIONS= CGI "Compile CGI executable" off \
- TEST "Compile test executable" off
+OPTIONS= CGI "Compile CGI executable" off
PORTDATA= *
@@ -25,21 +26,10 @@ PORTDATA= *
.if defined(WITH_CGI)
CONFIGURE_ARGS+= --flags="cgi"
-USE_HACKAGE+= cgi json
+USE_CABAL+= cgi json utf8-string
EXECUTABLE+= texmath-cgi
-PLIST_SUB+= MAYBE_CGI=""
.else
CONFIGURE_ARGS+= --flags="-cgi"
-PLIST_SUB+= MAYBE_CGI="@comment "
-.endif
-
-.if defined(WITH_TEST)
-CONFIGURE_ARGS+= --flags="test"
-EXECUTABLE+= testTeXMathML
-PLIST_SUB+= MAYBE_TEST=""
-.else
-CONFIGURE_ARGS+= --flags="-test"
-PLIST_SUB+= MAYBE_TEST="@comment "
.endif
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"