aboutsummaryrefslogtreecommitdiff
path: root/textproc/html-pretty/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/html-pretty/Makefile')
-rw-r--r--textproc/html-pretty/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/textproc/html-pretty/Makefile b/textproc/html-pretty/Makefile
index 41e51044abb7..d9923d5e72df 100644
--- a/textproc/html-pretty/Makefile
+++ b/textproc/html-pretty/Makefile
@@ -18,17 +18,17 @@ GNU_CONFIGURE= yes
PORTDOCS= *
-DOCFILES= AUTHORS BUGS COPYING ChangeLog NEWS README THANKS
+OPTIONS_DEFINE= DOCS
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/html
- ${INSTALL_DATA} ${WRKSRC}/*.html \
- ${STAGEDIR}${DOCSDIR}/html
- ${INSTALL_DATA} ${WRKSRC}/Docs/*.html \
+ ${INSTALL_DATA} ${WRKSRC}/*.html ${WRKSRC}/Docs/*.html \
${STAGEDIR}${DOCSDIR}/html
- for docfile in ${DOCFILES}; do \
- ${INSTALL_DATA} ${WRKSRC}/$$docfile ${STAGEDIR}${DOCSDIR}/; \
- done
+.for f in AUTHORS BUGS ChangeLog NEWS README THANKS
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
.include <bsd.port.mk>