aboutsummaryrefslogtreecommitdiff
path: root/textproc/libextractor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/libextractor/Makefile')
-rw-r--r--textproc/libextractor/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/textproc/libextractor/Makefile b/textproc/libextractor/Makefile
index 0f846b9bb9c3..a8e205faaad0 100644
--- a/textproc/libextractor/Makefile
+++ b/textproc/libextractor/Makefile
@@ -17,12 +17,16 @@ USE_BZIP2= yes
USE_GNOME= glib20
USE_PYTHON= yes
USE_LIBLTDL= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-ltdl-install
-USE_REINPLACE= yes
INSTALLS_SHLIB= yes
MAN1= extract.1
MAN3= libextractor.3
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/src/plugins/Makefile.in
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/src/plugins/Makefile.am
+
.include <bsd.port.mk>