aboutsummaryrefslogtreecommitdiff
path: root/textproc/odt2txt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/odt2txt/Makefile')
-rw-r--r--textproc/odt2txt/Makefile27
1 files changed, 12 insertions, 15 deletions
diff --git a/textproc/odt2txt/Makefile b/textproc/odt2txt/Makefile
index 84dbef2735fa..0c4904ddb0ec 100644
--- a/textproc/odt2txt/Makefile
+++ b/textproc/odt2txt/Makefile
@@ -2,34 +2,31 @@
# $FreeBSD$
PORTNAME= odt2txt
-PORTVERSION= 0.4
-PORTREVISION= 2
+PORTVERSION= 0.5
CATEGORIES= textproc
-MASTER_SITES= GHL
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Simple converter from OpenDocument Text to plain text
LICENSE= GPLv2
-USE_GITHUB= yes
-GH_ACCOUNT= dstosberg
-GH_PROJECT= odt2txt
-GH_COMMIT= 97b8999
-GH_TAGNAME= ${GH_COMMIT}
-USES= iconv gmake
-
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+USES= gmake iconv
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PLIST_FILES= bin/odt2txt man/man1/odt2txt.1.gz
+GH_ACCOUNT= dstosberg
+GH_PROJECT= odt2txt
+GH_TAGNAME= v${PORTVERSION}
+USE_GITHUB= yes
+
post-patch:
- ${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' \
- -e 's#-liconv#${ICONV_LIB}#' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g; s|-liconv|${ICONV_LIB}|' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/odt2txt ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/odt2txt.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/odt2txt ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/odt2txt.1 ${STAGEDIR}${MANPREFIX}/man/man1/
.include <bsd.port.mk>