aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-FormValidator-Lite/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-FormValidator-Lite/Makefile')
-rw-r--r--textproc/p5-FormValidator-Lite/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/textproc/p5-FormValidator-Lite/Makefile b/textproc/p5-FormValidator-Lite/Makefile
index 6ddd7f358a48..1126c03cdc02 100644
--- a/textproc/p5-FormValidator-Lite/Makefile
+++ b/textproc/p5-FormValidator-Lite/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= FormValidator-Lite
-PORTVERSION= 0.08
+PORTVERSION= 0.10
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -16,8 +16,17 @@ COMMENT= Lightleight form validation library
RUN_DEPENDS= ${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-require
-PERL_CONFIGURE= 5.10.1+
+PERL_CONFIGURE= 5.8.9+
-MAN3= FormValidator::Lite.3
+MAN3= FormValidator::Lite.3 \
+ FormValidator::Lite::Constraint.3 \
+ FormValidator::Lite::Constraint::Date.3 \
+ FormValidator::Lite::Constraint::Default.3 \
+ FormValidator::Lite::Constraint::Email.3 \
+ FormValidator::Lite::Constraint::File.3 \
+ FormValidator::Lite::Constraint::Japanese.3 \
+ FormValidator::Lite::Constraint::URL.3 \
+ FormValidator::Lite::Messages::en.3 \
+ FormValidator::Lite::Messages::ja.3
.include <bsd.port.mk>