aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Simple/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-XML-Simple/Makefile')
-rw-r--r--textproc/p5-XML-Simple/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/textproc/p5-XML-Simple/Makefile b/textproc/p5-XML-Simple/Makefile
new file mode 100644
index 000000000000..5ad739fc5181
--- /dev/null
+++ b/textproc/p5-XML-Simple/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-XML-Simple
+# Date created: October 10th 2000
+# Whom: Andrew <andrew@ugh.net.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Simple
+PORTVERSION= 1.05
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= andrew@ugh.net.au
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+
+USE_PERL5= YES
+
+MAN3= XML::Simple.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>