aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-pdfminer.six
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/py-pdfminer.six')
-rw-r--r--textproc/py-pdfminer.six/Makefile12
-rw-r--r--textproc/py-pdfminer.six/distinfo6
-rw-r--r--textproc/py-pdfminer.six/files/patch-pyproject.toml27
-rw-r--r--textproc/py-pdfminer.six/files/patch-setup.py17
4 files changed, 37 insertions, 25 deletions
diff --git a/textproc/py-pdfminer.six/Makefile b/textproc/py-pdfminer.six/Makefile
index adcb1fcb4a24..3c09f888d96c 100644
--- a/textproc/py-pdfminer.six/Makefile
+++ b/textproc/py-pdfminer.six/Makefile
@@ -1,9 +1,9 @@
PORTNAME= pdfminer.six
-DISTVERSION= 20240706
-PORTREVISION= 1
+DISTVERSION= 20250327
CATEGORIES= textproc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pdfminer_six-${DISTVERSION}
MAINTAINER= kai@FreeBSD.org
COMMENT= PDF parser and analyzer
@@ -12,11 +12,13 @@ WWW= https://github.com/pdfminer/pdfminer.six
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools-git-versioning<3:devel/py-setuptools-git-versioning@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}charset-normalizer>0:textproc/py-charset-normalizer@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools-scm>=8:devel/py-setuptools-scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}charset-normalizer>=2.0.0:textproc/py-charset-normalizer@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent cryptography distutils
+USE_PYTHON= autoplist concurrent cryptography pep517
CONFLICTS_INSTALL= py??-pdfminer py??-pdfminer3k
NO_ARCH= yes
diff --git a/textproc/py-pdfminer.six/distinfo b/textproc/py-pdfminer.six/distinfo
index 442a4edd8ce5..24967ee77985 100644
--- a/textproc/py-pdfminer.six/distinfo
+++ b/textproc/py-pdfminer.six/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1727003623
-SHA256 (pdfminer.six-20240706.tar.gz) = c631a46d5da957a9ffe4460c5dce21e8431dabb615fee5f9f4400603a58d95a6
-SIZE (pdfminer.six-20240706.tar.gz) = 7363505
+TIMESTAMP = 1743834310
+SHA256 (pdfminer_six-20250327.tar.gz) = 57f6c34c2702df04cfa3191622a3db0a922ced686d35283232b00094f8914aa1
+SIZE (pdfminer_six-20250327.tar.gz) = 7381506
diff --git a/textproc/py-pdfminer.six/files/patch-pyproject.toml b/textproc/py-pdfminer.six/files/patch-pyproject.toml
new file mode 100644
index 000000000000..1e48727c6106
--- /dev/null
+++ b/textproc/py-pdfminer.six/files/patch-pyproject.toml
@@ -0,0 +1,27 @@
+* Omit "license" keyword for now to be able to build with older py-setuptools.
+
+* Provide the console scripts without their ".py" extension.
+
+See also: https://github.com/pdfminer/pdfminer.six/issues/724
+
+--- pyproject.toml.orig 2025-04-05 16:54:46 UTC
++++ pyproject.toml
+@@ -7,7 +7,6 @@ readme = "README.md"
+ dynamic = ["version"]
+ description = "PDF parser and analyzer"
+ readme = "README.md"
+-license = "MIT"
+ requires-python = ">=3.9"
+ authors = [
+ { name = "Yusuke Shinyama" },
+@@ -63,8 +62,8 @@ script-files = [
+ [tool.setuptools]
+ packages = ["pdfminer"]
+ script-files = [
+- "tools/pdf2txt.py",
+- "tools/dumppdf.py",
++ "tools/pdf2txt",
++ "tools/dumppdf",
+ ]
+
+ [tool.setuptools_scm]
diff --git a/textproc/py-pdfminer.six/files/patch-setup.py b/textproc/py-pdfminer.six/files/patch-setup.py
deleted file mode 100644
index 1113b979a382..000000000000
--- a/textproc/py-pdfminer.six/files/patch-setup.py
+++ /dev/null
@@ -1,17 +0,0 @@
-Provide the console scripts without their ".py" extension.
-
-See also: https://github.com/pdfminer/pdfminer.six/issues/724
-
---- setup.py.orig 2022-03-19 20:13:07 UTC
-+++ setup.py
-@@ -33,8 +33,8 @@ setup(
- author_email="pdfminer@goulu.net",
- url="https://github.com/pdfminer/pdfminer.six",
- scripts=[
-- "tools/pdf2txt.py",
-- "tools/dumppdf.py",
-+ "tools/pdf2txt",
-+ "tools/dumppdf",
- ],
- keywords=[
- "pdf parser",