aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-rst2html5/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/py-rst2html5/Makefile')
-rw-r--r--textproc/py-rst2html5/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/textproc/py-rst2html5/Makefile b/textproc/py-rst2html5/Makefile
new file mode 100644
index 000000000000..241cccc95911
--- /dev/null
+++ b/textproc/py-rst2html5/Makefile
@@ -0,0 +1,21 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+#
+
+PORTNAME= rst2html5
+PORTVERSION= 0.10
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= olivierd@FreeBSD.org
+COMMENT= Produces HTML5 documents from reStructuredText sources
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Genshi>=0.6:${PORTSDIR}/textproc/py-genshi \
+ ${PYTHON_PKGNAMEPREFIX}pygments>=1.5:${PORTSDIR}/textproc/py-pygments \
+ ${PYTHON_PKGNAMEPREFIX}docutils>=0.10:${PORTSDIR}/textproc/py-docutils
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>