aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-rdtool/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/ruby-rdtool/Makefile')
-rw-r--r--textproc/ruby-rdtool/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/textproc/ruby-rdtool/Makefile b/textproc/ruby-rdtool/Makefile
index 0ed5ea256122..399ef003b27f 100644
--- a/textproc/ruby-rdtool/Makefile
+++ b/textproc/ruby-rdtool/Makefile
@@ -7,6 +7,7 @@
PORTNAME= rdtool
PORTVERSION= 0.6.33
+PORTREVISION= 1
CATEGORIES= textproc ruby
MASTER_SITES= https://github.com/uwabami/${PORTNAME}/tarball/v${PORTVERSION}/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -24,12 +25,16 @@ WRKSRC= ${WRKDIR}/uwabami-${PORTNAME}-${GITVERSION}
USE_RUBY= yes
USE_RUBY_SETUP= yes
+USE_RAKE= yes
RUBY_MODNAME= rd
DOCS_EN= README.rd doc/rd-draft.rd
DOCS_JA= README.rd.ja doc/rd-draft.rd.ja
+post-build:
+ cd ${WRKSRC} && ${RAKE_BIN} racc
+
post-install:
${MKDIR} ${RUBY_SITELIBDIR}/rd
${INSTALL_DATA} ${WRKSRC}/lib/rd/dot.rd2rc ${RUBY_SITELIBDIR}/rd/