aboutsummaryrefslogtreecommitdiff
path: root/textproc/sphinxsearch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/sphinxsearch/Makefile')
-rw-r--r--textproc/sphinxsearch/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/textproc/sphinxsearch/Makefile b/textproc/sphinxsearch/Makefile
index c03beb9215a3..167ee5147e01 100644
--- a/textproc/sphinxsearch/Makefile
+++ b/textproc/sphinxsearch/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sphinxsearch
PORTVERSION= 2.1.9
+PORTREVISION= 1
CATEGORIES= textproc databases
MASTER_SITES= http://sphinxsearch.com/files/ \
http://snowball.tartarus.org/dist/:libstemmer
@@ -24,7 +25,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
OPTIONS_DEFINE= ICONV ID64 LIBSTEMMER MYSQL OPTIMIZED_CFLAGS PGSQL \
- SYSLOG UNIXODBC DOCS
+ RE2 SYSLOG UNIXODBC DOCS
OPTIONS_DEFAULT=ICONV MYSQL SYSLOG
ICONV_CONFIGURE_WITH= iconv
@@ -72,7 +73,13 @@ OPTIMIZED_CFLAGS_CXXFLAGS=-O3 -fomit-frame-pointer
PGSQL_CONFIGURE_WITH= pgsql
PGSQL_CONFIGURE_ON= --with-pgsql-includes=${LOCALBASE}/include \
--with-pgsql-libs=${LOCALBASE}/lib
-PGSQL_USE= pgsql
+PGSQL_USES= pgsql
+
+# Why does this insist on linking against the libre2.a static library?
+
+RE2_DESC= Enable re2 regular expression library
+RE2_CONFIGURE_WITH= re2
+RE2_BUILD_DEPENDS= ${LOCALBASE}/lib/libre2.a:${PORTSDIR}/devel/re2
SYSLOG_DESC= Enable logging via syslog
SYSLOG_CONFIGURE_WITH= syslog