aboutsummaryrefslogtreecommitdiff
path: root/textproc/xmlindent/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/xmlindent/Makefile')
-rw-r--r--textproc/xmlindent/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/textproc/xmlindent/Makefile b/textproc/xmlindent/Makefile
index 66262d4a183f..5fe618544c8d 100644
--- a/textproc/xmlindent/Makefile
+++ b/textproc/xmlindent/Makefile
@@ -16,17 +16,15 @@ MANCOMPRESSED= no
SOURCES= error.c indent.c buffer.c main.c
-MAN1= xmlindent.1
-PLIST_FILES= bin/xmlindent
+PLIST_FILES= bin/xmlindent man/man1/xmlindent.1.gz
-NO_STAGE= yes
do-build:
@cd ${WRKSRC}; flex xmlindent.yy
${CC} ${CFLAGS} ${SOURCES:C/(.*)/${WRKSRC}\/\1/} \
-o ${WRKSRC}/${PORTNAME} -lfl
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>