aboutsummaryrefslogtreecommitdiff
path: root/textproc/yodl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/yodl/Makefile')
-rw-r--r--textproc/yodl/Makefile99
1 files changed, 71 insertions, 28 deletions
diff --git a/textproc/yodl/Makefile b/textproc/yodl/Makefile
index 0e75880f496f..ff9d6cc69f0e 100644
--- a/textproc/yodl/Makefile
+++ b/textproc/yodl/Makefile
@@ -6,41 +6,84 @@
#
PORTNAME= yodl
-PORTVERSION= 1.31.18
-PORTREVISION= 2
+PORTVERSION= 2.13.2
CATEGORIES= textproc
-MASTER_SITES= ftp://ftp.lilypond.org/pub/yodl/development/ \
- http://www.foad.org/zsh/zsh/ \
- http://www.zsh.org/pub/GPL/ \
- http://mirrors.sunsite.dk/ \
- http://www.math.technion.ac.il/pub/zsh/GPL/ \
- http://litterbug.lut.ac.uk/zsh/ \
- http://ftp.dmz.digex.net/pub/packages/ \
- http://linux.sarang.net/ftp/mirror/system/shell/zsh/GPL/
-
-MAINTAINER= ports@FreeBSD.org
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+EXTRACT_SUFX= .orig.tar.gz
+
+MAINTAINER= pgj@FreeBSD.org
COMMENT= An easy to use but powerful document formatting/preparation language
-BUILD_DEPENDS= latex:${PORTSDIR}/print/latex \
- dvips:${PORTSDIR}/print/dvips
-RUN_DEPENDS= latex:${PORTSDIR}/print/latex \
- dvips:${PORTSDIR}/print/dvips
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ getopt:${PORTSDIR}/misc/getopt
+BUILD_DEPENDS= icmake:${PORTSDIR}/devel/icmake \
+ bash:${PORTSDIR}/shells/bash \
+ gsed:${PORTSDIR}/textproc/gsed
+
+USE_PERL5_BUILD= yes
+
+MANCOMPRESSED= no
+MAN1= yodl.1 yodlpost.1 yodlconverters.1 yodlverbinsert.1
+MAN7= yodlmanpage.7 yodlletter.7 yodlmacros.7 yodlbuiltins.7
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-MAKEFILE= GNUmakefile
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= *
-MAN1= yodl.1 \
- striproff.1 \
- yodlconverters.1
-MAN7= yodlmacros.7 \
- yodlmanpage.7
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX-base \
+ dvips:${PORTSDIR}/print/dvipsk-tetex
+.endif
post-patch:
- @${REINPLACE_CMD} -e "s,tr '.*' '.*',tr '[:lower:]' '[:upper:]'," \
- ${WRKSRC}/src/yodl/GNUmakefile
+ @${REINPLACE_CMD} -e 's|"/usr/share/yodl"|"${PREFIX}/share/${PORTNAME}-${PORTVERSION}"| ; \
+ s|"/usr/bin"|"${PREFIX}/bin"|' \
+ ${WRKSRC}/src/config.h
+ @${REINPLACE_CMD} -e 's|"/share/yodl"|"/share/yodl-${PORTVERSION}"| ; \
+ s|"-r"|"-R"| ; \
+ s|"/share/man"|"/man"| ; \
+ s|"/share/doc"|"/share/doc/yodl-${PORTVERSION}"| ; \
+ s|"/share/doc/yodl"|"/share/doc/yodl-${PORTVERSION}"|' \
+ ${WRKSRC}/build
+ @${REINPLACE_CMD} -e 's|#!/usr/bin/icmake|#!${LOCALBASE}/bin/icmake|' \
+ ${WRKSRC}/build \
+ ${WRKSRC}/src/build \
+ ${WRKSRC}/src/yodlpost/build \
+ ${WRKSRC}/src/yodl/build \
+ ${WRKSRC}/manual/build \
+ ${WRKSRC}/man/build \
+ ${WRKSRC}/macros/build
+ @${REINPLACE_CMD} -e 's|#!/bin/bash|#!${LOCALBASE}/bin/bash| ; \
+ s|sed |${LOCALBASE}/bin/gsed | ; \
+ s|getopt |${LOCALBASE}/bin/getopt |' \
+ ${WRKSRC}/src/yodl/replace \
+ ${WRKSRC}/scripts/yodl2whatever.in \
+ ${WRKSRC}/scripts/configreplacements \
+ ${WRKSRC}/macros/rawmacros/separator \
+ ${WRKSRC}/macros/rawmacros/keepdiff \
+ ${WRKSRC}/macros/rawmacros/repairs \
+ ${WRKSRC}/macros/rawmacros/startdoc \
+ ${WRKSRC}/macros/rawmacros/makeyoin \
+ ${WRKSRC}/macros/rawmacros/create
+ @${REINPLACE_CMD} -e 's|#!/usr/bin/perl|#!${PERL}|' \
+ ${WRKSRC}/macros/rawmacros/separator.pl \
+ ${WRKSRC}/macros/rawmacros/startdoc.pl \
+ ${WRKSRC}/contrib/build.pl
+
+do-build:
+ @cd ${WRKSRC} && ./build package
+.if !defined(NOPORTDOCS)
+ @cd ${WRKSRC} && ./build doc
+.endif
-post-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/scripts/out/striproff ${PREFIX}/bin
+do-install:
+ @cd ${WRKSRC} && ./build install ${PREFIX}
+.if !defined(NOPORTDOCS)
+ @cd ${WRKSRC} && ./build install_doc ${PREFIX}
+.endif
.include <bsd.port.mk>