aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/php73-ctype/Makefile11
-rw-r--r--textproc/php73-dom/Makefile11
-rw-r--r--textproc/php73-enchant/Makefile11
-rw-r--r--textproc/php73-pspell/Makefile11
-rw-r--r--textproc/php73-simplexml/Makefile11
-rw-r--r--textproc/php73-simplexml/files/patch-config.m443
-rw-r--r--textproc/php73-wddx/Makefile11
-rw-r--r--textproc/php73-wddx/files/patch-config.m422
-rw-r--r--textproc/php73-wddx/files/patch-wddx.c40
-rw-r--r--textproc/php73-xml/Makefile11
-rw-r--r--textproc/php73-xml/files/patch-compat.c13
-rw-r--r--textproc/php73-xmlreader/Makefile11
-rw-r--r--textproc/php73-xmlwriter/Makefile11
-rw-r--r--textproc/php73-xsl/Makefile11
-rw-r--r--textproc/php73-xsl/files/patch-php_xsl.h11
15 files changed, 239 insertions, 0 deletions
diff --git a/textproc/php73-ctype/Makefile b/textproc/php73-ctype/Makefile
new file mode 100644
index 000000000000..cdf5365da224
--- /dev/null
+++ b/textproc/php73-ctype/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -ctype
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php73-dom/Makefile b/textproc/php73-dom/Makefile
new file mode 100644
index 000000000000..de994d53586e
--- /dev/null
+++ b/textproc/php73-dom/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -dom
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php73-enchant/Makefile b/textproc/php73-enchant/Makefile
new file mode 100644
index 000000000000..cd35343214a6
--- /dev/null
+++ b/textproc/php73-enchant/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -enchant
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php73-pspell/Makefile b/textproc/php73-pspell/Makefile
new file mode 100644
index 000000000000..820666d1a5dd
--- /dev/null
+++ b/textproc/php73-pspell/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -pspell
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php73-simplexml/Makefile b/textproc/php73-simplexml/Makefile
new file mode 100644
index 000000000000..51af25294a5b
--- /dev/null
+++ b/textproc/php73-simplexml/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -simplexml
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php73-simplexml/files/patch-config.m4 b/textproc/php73-simplexml/files/patch-config.m4
new file mode 100644
index 000000000000..6dd1ab631c39
--- /dev/null
+++ b/textproc/php73-simplexml/files/patch-config.m4
@@ -0,0 +1,43 @@
+--- config.m4.orig 2018-09-25 09:08:02 UTC
++++ config.m4
+@@ -3,6 +3,9 @@ dnl config.m4 for extension simplexml
+ PHP_ARG_ENABLE(simplexml, whether to enable SimpleXML support,
+ [ --disable-simplexml Disable SimpleXML support], yes)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir SimpleXML: pcre install prefix], no, no)
++
+ if test -z "$PHP_LIBXML_DIR"; then
+ PHP_ARG_WITH(libxml-dir, libxml2 install dir,
+ [ --with-libxml-dir=DIR SimpleXML: libxml2 install prefix], no, no)
+@@ -10,6 +13,30 @@ fi
+
+ if test "$PHP_SIMPLEXML" != "no"; then
+
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ if test "$PHP_LIBXML" = "no"; then
+ AC_MSG_ERROR([SimpleXML extension requires LIBXML extension, add --enable-libxml])
+ fi
diff --git a/textproc/php73-wddx/Makefile b/textproc/php73-wddx/Makefile
new file mode 100644
index 000000000000..4809b7fdbc26
--- /dev/null
+++ b/textproc/php73-wddx/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -wddx
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php73-wddx/files/patch-config.m4 b/textproc/php73-wddx/files/patch-config.m4
new file mode 100644
index 000000000000..08787003b8f9
--- /dev/null
+++ b/textproc/php73-wddx/files/patch-config.m4
@@ -0,0 +1,22 @@
+--- config.m4.orig Mon Jul 26 09:05:10 2004
++++ config.m4 Mon Jul 26 09:07:46 2004
+@@ -5,6 +5,9 @@
+ PHP_ARG_ENABLE(wddx,whether to enable WDDX support,
+ [ --enable-wddx Enable WDDX support.])
+
++PHP_ARG_WITH(libxml-dir, libxml2 install dir,
++[ --with-libxml-dir=<DIR> WDDX: libxml2 install prefix], no, no)
++
+ if test "$PHP_WDDX" != "no"; then
+ if test "$ext_shared" != "yes" && test "$enable_xml" = "no"; then
+ AC_MSG_WARN(Activating XML)
+@@ -12,4 +15,9 @@
+ fi
+ AC_DEFINE(HAVE_WDDX, 1, [ ])
+ PHP_NEW_EXTENSION(wddx, wddx.c, $ext_shared)
++
++ PHP_SETUP_LIBXML(WDDX_SHARED_LIBADD, [
++ ], [
++ AC_MSG_ERROR([xml2-config not found. Please check your libxml2 installation.])
++ ])
+ fi
diff --git a/textproc/php73-wddx/files/patch-wddx.c b/textproc/php73-wddx/files/patch-wddx.c
new file mode 100644
index 000000000000..a8a6a79fe47f
--- /dev/null
+++ b/textproc/php73-wddx/files/patch-wddx.c
@@ -0,0 +1,40 @@
+--- wddx.c.orig Sun Jan 1 13:50:16 2006
++++ wddx.c Mon Jan 16 12:56:21 2006
+@@ -18,6 +18,10 @@
+
+ /* $Id: wddx.c,v 1.119.2.8 2006/01/01 12:50:16 sniper Exp $ */
+
++#ifdef HAVE_CONFIG_H
++# include "config.h"
++#endif
++
+ #include "php.h"
+
+ #if HAVE_WDDX
+@@ -223,7 +227,7 @@
+
+ #include "ext/session/php_session.h"
+
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ /* {{{ PS_SERIALIZER_ENCODE_FUNC
+ */
+ PS_SERIALIZER_ENCODE_FUNC(wddx)
+@@ -302,7 +306,7 @@
+ {
+ le_wddx = zend_register_list_destructors_ex(release_wddx_packet_rsrc, NULL, "wddx", module_number);
+
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ php_session_register_serializer("wddx",
+ PS_SERIALIZER_ENCODE_NAME(wddx),
+ PS_SERIALIZER_DECODE_NAME(wddx));
+@@ -317,7 +321,7 @@
+ PHP_MINFO_FUNCTION(wddx)
+ {
+ php_info_print_table_start();
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ php_info_print_table_header(2, "WDDX Support", "enabled" );
+ php_info_print_table_row(2, "WDDX Session Serializer", "enabled" );
+ #else
diff --git a/textproc/php73-xml/Makefile b/textproc/php73-xml/Makefile
new file mode 100644
index 000000000000..4b787bc5d157
--- /dev/null
+++ b/textproc/php73-xml/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -xml
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php73-xml/files/patch-compat.c b/textproc/php73-xml/files/patch-compat.c
new file mode 100644
index 000000000000..02125961b20c
--- /dev/null
+++ b/textproc/php73-xml/files/patch-compat.c
@@ -0,0 +1,13 @@
+--- compat.c.orig Tue Jul 20 10:55:02 2004
++++ compat.c Tue Jul 20 10:55:55 2004
+@@ -16,6 +16,10 @@
+ +----------------------------------------------------------------------+
+ */
+
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
+ #include "php.h"
+ #if defined(HAVE_LIBXML) && defined(HAVE_XML) && !defined(HAVE_LIBEXPAT)
+ #include "expat_compat.h"
diff --git a/textproc/php73-xmlreader/Makefile b/textproc/php73-xmlreader/Makefile
new file mode 100644
index 000000000000..c5d137b1fc18
--- /dev/null
+++ b/textproc/php73-xmlreader/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -xmlreader
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php73-xmlwriter/Makefile b/textproc/php73-xmlwriter/Makefile
new file mode 100644
index 000000000000..cb7cce272023
--- /dev/null
+++ b/textproc/php73-xmlwriter/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -xmlwriter
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php73-xsl/Makefile b/textproc/php73-xsl/Makefile
new file mode 100644
index 000000000000..9c43a2fca5f6
--- /dev/null
+++ b/textproc/php73-xsl/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -xsl
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php73-xsl/files/patch-php_xsl.h b/textproc/php73-xsl/files/patch-php_xsl.h
new file mode 100644
index 000000000000..9777187f8748
--- /dev/null
+++ b/textproc/php73-xsl/files/patch-php_xsl.h
@@ -0,0 +1,11 @@
+--- php_xsl.h.orig Sun Jan 1 13:50:17 2006
++++ php_xsl.h Tue Jan 17 16:23:10 2006
+@@ -43,7 +43,7 @@
+ #include <libexslt/exsltconfig.h>
+ #endif
+
+-#include "../dom/xml_common.h"
++#include "ext/dom/xml_common.h"
+ #include "xsl_fe.h"
+
+ #include <libxslt/extensions.h>