aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/xmlprpr/Makefile26
-rw-r--r--textproc/xmlprpr/distinfo3
-rw-r--r--textproc/xmlprpr/pkg-descr13
4 files changed, 43 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 3eaa3053e17c..9869b718f98c 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -813,6 +813,7 @@
SUBDIR += xmlindent
SUBDIR += xmlpp
SUBDIR += xmlppm
+ SUBDIR += xmlprpr
SUBDIR += xmlpull
SUBDIR += xmlroff
SUBDIR += xmlstarlet
diff --git a/textproc/xmlprpr/Makefile b/textproc/xmlprpr/Makefile
new file mode 100644
index 000000000000..e5607ef6905b
--- /dev/null
+++ b/textproc/xmlprpr/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: xmlprpr
+# Date created: Sun Oct 9 10:33:37 EDT 2005
+# Whom: Paul Chvostek <paul+ports@it.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmlprpr
+PORTVERSION= 1.32
+CATEGORIES= textproc
+MASTER_SITES= http://software.decisionsoft.com/software/
+DISTFILES= xmlpp.pl
+EXTRACT_ONLY=
+
+MAINTAINER= paul+ports@it.ca
+COMMENT= A XML pretty printer
+
+USE_PERL5= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+PLIST_FILES= bin/xmlprpr
+
+do-install:
+ ${INSTALL_SCRIPT} ${_DISTDIR}/${_DISTFILES} ${PREFIX}/bin/xmlprpr
+
+.include <bsd.port.mk>
diff --git a/textproc/xmlprpr/distinfo b/textproc/xmlprpr/distinfo
new file mode 100644
index 000000000000..c9e4e83f768e
--- /dev/null
+++ b/textproc/xmlprpr/distinfo
@@ -0,0 +1,3 @@
+MD5 (xmlpp.pl) = ea353effc32e136ddd05b345fa0f757a
+SHA256 (xmlpp.pl) = b4a21130076455c4503ef55fe738a7c955e4111a5aed6a878877a4df473a7287
+SIZE (xmlpp.pl) = 9466
diff --git a/textproc/xmlprpr/pkg-descr b/textproc/xmlprpr/pkg-descr
new file mode 100644
index 000000000000..9917c98ef2a1
--- /dev/null
+++ b/textproc/xmlprpr/pkg-descr
@@ -0,0 +1,13 @@
+An XML pretty printer created to format XML that doesn't make use of
+mixed content. In the default mode each element is put on a separate
+line with consistent indentation. It can also separate attributes onto
+individual lines, sort attributes in a specified or alphabetic order,
+expand self closing tags, and more.
+
+Note that the distribution calls this tool "xmlpp", but it has been
+renamed so as not to conflict with an xmlpp already in the ports tree.
+
+WWW: http://software.decisionsoft.com/tools.html
+
+- Paul Chvostek
+paul+ports@it.ca