aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/opengrm-ngram/Makefile22
-rw-r--r--textproc/opengrm-ngram/distinfo2
-rw-r--r--textproc/opengrm-ngram/files/patch-src-bin-Makefile.in11
-rw-r--r--textproc/opengrm-ngram/files/patch-src-test-Makefile.in11
-rw-r--r--textproc/opengrm-ngram/pkg-descr8
-rw-r--r--textproc/opengrm-ngram/pkg-plist49
7 files changed, 104 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 8f2bda606536..327188035fca 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -465,6 +465,7 @@
SUBDIR += ocaml-tyxml
SUBDIR += odt2txt
SUBDIR += openfts
+ SUBDIR += opengrm-ngram
SUBDIR += openjade
SUBDIR += opensched
SUBDIR += opensp
diff --git a/textproc/opengrm-ngram/Makefile b/textproc/opengrm-ngram/Makefile
new file mode 100644
index 000000000000..d7a154eecdbd
--- /dev/null
+++ b/textproc/opengrm-ngram/Makefile
@@ -0,0 +1,22 @@
+# Created by: Dmitry Sivachenko <mitya@yandex-team.ru>
+# $FreeBSD$
+
+PORTNAME= opengrm-ngram
+PORTVERSION= 1.2.1
+CATEGORIES= textproc
+MASTER_SITES= http://openfst.cs.nyu.edu/twiki/pub/GRM/NGramDownload/
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= Library for making n-gram language models encoded as weighted FSTs
+
+LICENSE= APACHE20
+
+LIB_DEPENDS= libfst.so:${PORTSDIR}/math/openfst
+
+USES= compiler:c++11-lib libtool
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.include <bsd.port.mk>
diff --git a/textproc/opengrm-ngram/distinfo b/textproc/opengrm-ngram/distinfo
new file mode 100644
index 000000000000..033d3afa52b2
--- /dev/null
+++ b/textproc/opengrm-ngram/distinfo
@@ -0,0 +1,2 @@
+SHA256 (opengrm-ngram-1.2.1.tar.gz) = 713f07dccf225cde29cb048ce955d45d3c2a5ce6be7d923b5a688012d4285453
+SIZE (opengrm-ngram-1.2.1.tar.gz) = 15062420
diff --git a/textproc/opengrm-ngram/files/patch-src-bin-Makefile.in b/textproc/opengrm-ngram/files/patch-src-bin-Makefile.in
new file mode 100644
index 000000000000..03f9cb344ab0
--- /dev/null
+++ b/textproc/opengrm-ngram/files/patch-src-bin-Makefile.in
@@ -0,0 +1,11 @@
+--- src/bin/Makefile.in.orig 2014-10-20 15:50:21.000000000 +0400
++++ src/bin/Makefile.in 2014-10-20 15:50:35.000000000 +0400
+@@ -255,7 +255,7 @@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ AM_CPPFLAGS = -I$(srcdir)/../include
+-AM_LDFLAGS = -L/usr/local/lib/fst -lfstfar -lfst -lm -ldl
++AM_LDFLAGS = -L/usr/local/lib/fst -lfstfar -lfst -lm
+ dist_noinst_SCRIPTS = ngram.sh
+ ngramapply_SOURCES = ngramapply.cc
+ ngramapply_LDADD = ../lib/libngram.la
diff --git a/textproc/opengrm-ngram/files/patch-src-test-Makefile.in b/textproc/opengrm-ngram/files/patch-src-test-Makefile.in
new file mode 100644
index 000000000000..8c69f347b278
--- /dev/null
+++ b/textproc/opengrm-ngram/files/patch-src-test-Makefile.in
@@ -0,0 +1,11 @@
+--- src/test/Makefile.in.orig 2014-10-20 16:03:57.000000000 +0400
++++ src/test/Makefile.in 2014-10-20 16:04:02.000000000 +0400
+@@ -192,7 +192,7 @@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ AM_CPPFLAGS = -I$(srcdir)/../include
+-AM_LDFLAGS = -L/usr/local/lib/fst -lfstfar -lfst -lm -ldl
++AM_LDFLAGS = -L/usr/local/lib/fst -lfstfar -lfst -lm
+ ngramrandtest_SOURCES = ngramrandtest.cc
+ ngramrandtest_LDADD = ../lib/libngram.la
+ dist_check_SCRIPTS = ngramprint_test.sh ngramcount_test.sh \
diff --git a/textproc/opengrm-ngram/pkg-descr b/textproc/opengrm-ngram/pkg-descr
new file mode 100644
index 000000000000..9f995ff21dd1
--- /dev/null
+++ b/textproc/opengrm-ngram/pkg-descr
@@ -0,0 +1,8 @@
+The OpenGrm NGram library is used for making and modifying n-gram language
+models encoded as weighted finite-state transducers (FSTs). It makes use of
+functionality in the OpenFst library to create, access and manipulate n-gram
+models. Operations for counting, smoothing, pruning, applying, and
+evaluating models as well as support for distributed computation are among
+those provided. It was developed by contributors from OHSU and Google Research.
+
+WWW: http://www.openfst.org/twiki/bin/view/GRM/NGramLibrary
diff --git a/textproc/opengrm-ngram/pkg-plist b/textproc/opengrm-ngram/pkg-plist
new file mode 100644
index 000000000000..cce4f4dc0649
--- /dev/null
+++ b/textproc/opengrm-ngram/pkg-plist
@@ -0,0 +1,49 @@
+bin/ngramapply
+bin/ngramcontext
+bin/ngramcount
+bin/ngraminfo
+bin/ngrammake
+bin/ngrammarginalize
+bin/ngrammerge
+bin/ngramperplexity
+bin/ngramprint
+bin/ngramrandgen
+bin/ngramrandtest
+bin/ngramread
+bin/ngramshrink
+bin/ngramsort
+bin/ngramsplit
+bin/ngramsymbols
+bin/ngramtransfer
+include/ngram/lexicographic-map.h
+include/ngram/ngram-absolute.h
+include/ngram/ngram-complete.h
+include/ngram/ngram-context-merge.h
+include/ngram/ngram-context-prune.h
+include/ngram/ngram-context.h
+include/ngram/ngram-count-merge.h
+include/ngram/ngram-count-of-counts.h
+include/ngram/ngram-count-prune.h
+include/ngram/ngram-count.h
+include/ngram/ngram-input.h
+include/ngram/ngram-katz.h
+include/ngram/ngram-kneser-ney.h
+include/ngram/ngram-make.h
+include/ngram/ngram-marginalize.h
+include/ngram/ngram-merge.h
+include/ngram/ngram-model-merge.h
+include/ngram/ngram-model.h
+include/ngram/ngram-mutable-model.h
+include/ngram/ngram-output.h
+include/ngram/ngram-randgen.h
+include/ngram/ngram-relentropy.h
+include/ngram/ngram-seymore-shrink.h
+include/ngram/ngram-shrink.h
+include/ngram/ngram-split.h
+include/ngram/ngram-transfer.h
+include/ngram/ngram-unsmoothed.h
+include/ngram/ngram-witten-bell.h
+include/ngram/ngram.h
+lib/libngram.so
+lib/libngram.so.1
+lib/libngram.so.1.0.0