aboutsummaryrefslogtreecommitdiff
path: root/www/hastymail2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/hastymail2/Makefile')
-rw-r--r--www/hastymail2/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/www/hastymail2/Makefile b/www/hastymail2/Makefile
index c97c5d694f87..edd071a29aeb 100644
--- a/www/hastymail2/Makefile
+++ b/www/hastymail2/Makefile
@@ -42,19 +42,19 @@ MBSTRING_DESC= Support multi-byte character sets
.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
.if ! ${PORT_OPTIONS:MDB}
-RUN_DEPENDS+= ${LOCALBASE}/share/pear/MDB2/Driver/mysql.php:databases/pear-MDB2_Driver_mysql
+RUN_DEPENDS+= ${LOCALBASE}/share/pear/MDB2/Driver/mysql.php:databases/pear-MDB2_Driver_mysql@${PHP_FLAVOR}
.endif
.endif
.if ${PORT_OPTIONS:MPGSQL}
USES+= pgsql
.if ! ${PORT_OPTIONS:MDB}
-RUN_DEPENDS+= ${LOCALBASE}/share/pear/MDB2/Driver/pgsql.php:databases/pear-MDB2_Driver_pgsql
+RUN_DEPENDS+= ${LOCALBASE}/share/pear/MDB2/Driver/pgsql.php:databases/pear-MDB2_Driver_pgsql@${PHP_FLAVOR}
.endif
.endif
.if ${PORT_OPTIONS:MDB} && (${PORT_OPTIONS:MMYSQL} || ${PORT_OPTIONS:MPGSQL})
-RUN_DEPENDS+= ${LOCALBASE}/share/pear/DB.php:databases/pear-DB
+RUN_DEPENDS+= ${LOCALBASE}/share/pear/DB.php:databases/pear-DB@${PHP_FLAVOR}
.endif
.if ${PORT_OPTIONS:MICONV}