aboutsummaryrefslogtreecommitdiff
path: root/www/lychee/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/lychee/Makefile')
-rw-r--r--www/lychee/Makefile401
1 files changed, 180 insertions, 221 deletions
diff --git a/www/lychee/Makefile b/www/lychee/Makefile
index 04da6fe98cce..04aef11111fb 100644
--- a/www/lychee/Makefile
+++ b/www/lychee/Makefile
@@ -1,7 +1,7 @@
PORTNAME= lychee
-DISTVERSIONPREFIX= v
-DISTVERSION= 0.5.0
-PORTREVISION= 2
+#DISTVERSIONPREFIX= v
+DISTVERSION= 0.7.0
+PORTREVISION= 0
CATEGORIES= www net
MAINTAINER= pizzamig@FreeBSD.org
@@ -16,345 +16,304 @@ GH_ACCOUNT= lycheeverse
PLIST_FILES= bin/lychee
-CARGO_CRATES= addr2line-0.13.0 \
- adler-0.2.3 \
- aho-corasick-0.7.13 \
+GH_TUPLE= softprops:hubcaps:a9e6616ecc7b8eef0ea0eaf6055d9610c8961500:hubcaps
+CARGO_INSTALL_PATH= lychee-bin
+CARGO_CRATES= adler-1.0.2 \
+ aho-corasick-0.7.15 \
ansi_term-0.11.0 \
- anyhow-1.0.37 \
- arc-swap-0.4.7 \
- arrayvec-0.5.1 \
+ ansi_term-0.12.1 \
+ anyhow-1.0.40 \
+ arrayvec-0.5.2 \
ascii_utils-0.9.3 \
- assert_cmd-1.0.2 \
- async-channel-1.5.1 \
+ assert_cmd-1.0.3 \
+ async-channel-1.6.1 \
async-compression-0.3.7 \
async-executor-1.4.0 \
- async-global-executor-1.4.3 \
- async-io-1.1.0 \
- async-mutex-1.1.5 \
+ async-global-executor-2.0.2 \
+ async-io-1.3.1 \
+ async-lock-2.3.0 \
+ async-mutex-1.4.0 \
async-native-tls-0.3.3 \
- async-process-1.0.1 \
- async-smtp-0.3.4 \
- async-std-1.8.0 \
- async-std-resolver-0.19.5 \
+ async-process-1.0.2 \
+ async-smtp-0.4.0 \
+ async-std-1.9.0 \
+ async-std-resolver-0.20.1 \
async-task-4.0.3 \
- async-trait-0.1.42 \
+ async-trait-0.1.48 \
atomic-waker-1.0.0 \
atty-0.2.14 \
- autocfg-1.0.0 \
- backtrace-0.3.50 \
- base-x-0.2.8 \
- base64-0.11.0 \
+ autocfg-1.0.1 \
base64-0.12.3 \
base64-0.13.0 \
bitflags-1.2.1 \
- block-buffer-0.7.3 \
- block-padding-0.1.5 \
+ block-buffer-0.9.0 \
blocking-1.0.2 \
+ bstr-0.2.15 \
bufstream-0.1.4 \
- bumpalo-3.4.0 \
- byte-tools-0.3.1 \
- byteorder-1.3.4 \
- bytes-0.4.12 \
- bytes-0.5.6 \
- bytes-1.0.0 \
+ bumpalo-3.6.1 \
+ byteorder-1.4.3 \
+ bytes-1.0.1 \
cache-padded-1.1.1 \
- cc-1.0.59 \
- cfg-if-0.1.10 \
+ cc-1.0.67 \
cfg-if-1.0.0 \
- check-if-email-exists-0.8.17 \
- chrono-0.4.15 \
+ check-if-email-exists-0.8.21 \
+ chrono-0.4.19 \
clap-2.33.3 \
- cloudabi-0.1.0 \
concurrent-queue-1.2.2 \
config-0.10.1 \
- console-0.12.0 \
- const_fn-0.4.2 \
- cookie-0.14.3 \
- core-foundation-0.7.0 \
- core-foundation-sys-0.7.0 \
- crc32fast-1.2.0 \
- crossbeam-queue-0.3.0 \
- crossbeam-utils-0.8.0 \
- darling-0.10.2 \
- darling_core-0.10.2 \
- darling_macro-0.10.2 \
- data-encoding-2.3.0 \
- deadpool-0.6.0 \
+ console-0.14.1 \
+ core-foundation-0.9.1 \
+ core-foundation-sys-0.8.2 \
+ cpuid-bool-0.1.2 \
+ crc32fast-1.2.1 \
+ crossbeam-queue-0.3.1 \
+ crossbeam-utils-0.8.3 \
+ ctor-0.1.20 \
+ data-encoding-2.3.2 \
deadpool-0.7.0 \
- derive_builder-0.9.0 \
- derive_builder_core-0.9.0 \
+ diff-0.1.12 \
difference-2.0.0 \
- digest-0.8.1 \
+ digest-0.9.0 \
dirs-next-2.0.0 \
- dirs-sys-next-0.1.1 \
- discard-1.0.4 \
+ dirs-sys-next-0.1.2 \
doc-comment-0.3.3 \
- either-1.6.0 \
+ either-1.6.1 \
encode_unicode-0.3.6 \
- encoding_rs-0.8.23 \
+ encoding_rs-0.8.28 \
enum-as-inner-0.3.3 \
- event-listener-2.4.0 \
- fake-simd-0.1.2 \
- fast-socks5-0.3.1 \
+ event-listener-2.5.1 \
+ fast-socks5-0.4.2 \
fast_chemail-0.9.6 \
- fastrand-1.3.4 \
- flate2-1.0.17 \
+ fastrand-1.4.0 \
+ flate2-1.0.20 \
float-cmp-0.8.0 \
fnv-1.0.7 \
foreign-types-0.3.2 \
foreign-types-shared-0.1.1 \
- form_urlencoded-1.0.0 \
- fuchsia-zircon-0.3.3 \
- fuchsia-zircon-sys-0.3.3 \
+ form_urlencoded-1.0.1 \
futf-0.1.4 \
- futures-0.3.9 \
- futures-channel-0.3.9 \
- futures-core-0.3.9 \
- futures-executor-0.3.9 \
- futures-io-0.3.9 \
- futures-lite-1.11.2 \
- futures-macro-0.3.9 \
- futures-sink-0.3.9 \
- futures-task-0.3.9 \
+ futures-0.3.14 \
+ futures-channel-0.3.14 \
+ futures-core-0.3.14 \
+ futures-executor-0.3.14 \
+ futures-io-0.3.14 \
+ futures-lite-1.11.3 \
+ futures-macro-0.3.14 \
+ futures-sink-0.3.14 \
+ futures-task-0.3.14 \
futures-timer-3.0.2 \
- futures-util-0.3.9 \
- generic-array-0.12.3 \
+ futures-util-0.3.14 \
+ generic-array-0.14.4 \
getopts-0.2.21 \
- getrandom-0.1.14 \
- gimli-0.22.0 \
+ getrandom-0.1.16 \
+ getrandom-0.2.2 \
glob-0.3.0 \
gloo-timers-0.2.1 \
- h2-0.2.6 \
- h2-0.3.0 \
- hashbrown-0.8.2 \
- headers-0.3.2 \
+ h2-0.3.2 \
+ hashbrown-0.9.1 \
+ headers-0.3.4 \
headers-core-0.2.0 \
- heck-0.3.1 \
- hermit-abi-0.1.15 \
+ heck-0.3.2 \
+ hermit-abi-0.1.18 \
hostname-0.1.5 \
hostname-0.3.1 \
html5ever-0.25.1 \
- http-0.2.2 \
- http-body-0.3.1 \
- http-body-0.4.0 \
- http-types-2.9.0 \
- httparse-1.3.4 \
+ http-0.2.4 \
+ http-body-0.4.1 \
+ http-types-2.10.0 \
+ httparse-1.3.6 \
httpdate-0.3.2 \
- hubcaps-0.6.2 \
- hyper-0.13.9 \
- hyper-0.14.2 \
- hyper-tls-0.4.3 \
+ hyper-0.14.5 \
hyper-tls-0.5.0 \
- hyperx-1.0.0 \
- ident_case-1.0.1 \
- idna-0.2.0 \
- indexmap-1.5.1 \
+ hyperx-1.3.0 \
+ idna-0.2.2 \
+ indexmap-1.6.2 \
indicatif-0.15.0 \
infer-0.2.3 \
instant-0.1.9 \
- iovec-0.1.4 \
ipconfig-0.2.2 \
ipnet-2.3.0 \
- itoa-0.4.6 \
- js-sys-0.3.45 \
+ itoa-0.4.7 \
+ js-sys-0.3.50 \
jsonwebtoken-7.2.0 \
- kernel32-sys-0.2.2 \
kv-log-macro-1.0.7 \
language-tags-0.2.2 \
lazy_static-1.4.0 \
- lexical-core-0.7.4 \
- libc-0.2.76 \
- linked-hash-map-0.5.3 \
- linkify-0.4.0 \
- lock_api-0.4.2 \
- log-0.4.11 \
+ lexical-core-0.7.5 \
+ libc-0.2.93 \
+ linked-hash-map-0.5.4 \
+ linkify-0.6.0 \
+ lock_api-0.4.3 \
+ log-0.4.14 \
lru-cache-0.1.2 \
mac-0.1.1 \
- mailchecker-4.0.1 \
+ mailchecker-4.0.6 \
markup5ever-0.10.0 \
markup5ever_rcdom-0.1.0 \
match_cfg-0.1.0 \
matches-0.1.8 \
- memchr-2.3.3 \
+ memchr-2.3.4 \
mime-0.3.16 \
- mime_guess-2.0.3 \
- miniz_oxide-0.4.0 \
- mio-0.6.22 \
- mio-0.7.7 \
- miow-0.2.1 \
- miow-0.3.6 \
- native-tls-0.2.4 \
- net2-0.2.34 \
+ miniz_oxide-0.4.4 \
+ mio-0.7.11 \
+ miow-0.3.7 \
+ native-tls-0.2.7 \
+ nb-connect-1.1.0 \
new_debug_unreachable-1.0.4 \
nom-5.1.2 \
normalize-line-endings-0.3.0 \
ntapi-0.3.6 \
num-bigint-0.2.6 \
- num-integer-0.1.43 \
- num-traits-0.2.12 \
+ num-integer-0.1.44 \
+ num-traits-0.2.14 \
num_cpus-1.13.0 \
number_prefix-0.3.0 \
- object-0.20.0 \
- once_cell-1.5.2 \
- opaque-debug-0.2.3 \
- openssl-0.10.30 \
+ once_cell-1.7.2 \
+ opaque-debug-0.3.0 \
+ openssl-0.10.33 \
openssl-probe-0.1.2 \
- openssl-sys-0.9.60 \
+ openssl-sys-0.9.61 \
+ output_vt100-0.1.2 \
+ pad-0.1.6 \
parking-2.0.0 \
parking_lot-0.11.1 \
- parking_lot_core-0.8.0 \
- pem-0.8.1 \
+ parking_lot_core-0.8.3 \
+ pem-0.8.3 \
percent-encoding-2.1.0 \
phf-0.8.0 \
phf_codegen-0.8.0 \
phf_generator-0.8.0 \
phf_shared-0.8.0 \
- pin-project-0.4.23 \
- pin-project-1.0.2 \
- pin-project-internal-0.4.23 \
- pin-project-internal-1.0.2 \
- pin-project-lite-0.1.7 \
- pin-project-lite-0.2.0 \
+ pin-project-1.0.6 \
+ pin-project-internal-1.0.6 \
+ pin-project-lite-0.2.6 \
pin-utils-0.1.0 \
- pkg-config-0.3.18 \
- polling-1.0.2 \
- ppv-lite86-0.2.9 \
+ pkg-config-0.3.19 \
+ polling-2.0.3 \
+ ppv-lite86-0.2.10 \
precomputed-hash-0.1.1 \
- predicates-1.0.6 \
- predicates-core-1.0.0 \
- predicates-tree-1.0.0 \
+ predicates-1.0.7 \
+ predicates-core-1.0.2 \
+ predicates-tree-1.0.2 \
+ pretty_assertions-0.7.2 \
proc-macro-error-1.0.4 \
proc-macro-error-attr-1.0.4 \
proc-macro-hack-0.5.19 \
- proc-macro-nested-0.1.6 \
- proc-macro2-1.0.24 \
+ proc-macro-nested-0.1.7 \
+ proc-macro2-1.0.26 \
pulldown-cmark-0.8.0 \
quick-error-1.2.3 \
- quote-1.0.7 \
+ quote-1.0.9 \
rand-0.7.3 \
+ rand-0.8.3 \
rand_chacha-0.2.2 \
+ rand_chacha-0.3.0 \
rand_core-0.5.1 \
+ rand_core-0.6.2 \
rand_hc-0.2.0 \
+ rand_hc-0.3.0 \
rand_pcg-0.2.1 \
- redox_syscall-0.1.57 \
- redox_users-0.3.5 \
- regex-1.4.2 \
- regex-syntax-0.6.21 \
+ redox_syscall-0.2.6 \
+ redox_users-0.4.0 \
+ regex-1.4.5 \
+ regex-automata-0.1.9 \
+ regex-syntax-0.6.23 \
remove_dir_all-0.5.3 \
- reqwest-0.10.10 \
- reqwest-0.11.0 \
- resolv-conf-0.6.3 \
- ring-0.16.15 \
- rustc-demangle-0.1.16 \
- rustc_version-0.2.3 \
+ reqwest-0.11.3 \
+ resolv-conf-0.7.0 \
+ ring-0.16.20 \
ryu-1.0.5 \
schannel-0.1.19 \
scopeguard-1.1.0 \
- security-framework-0.4.4 \
- security-framework-sys-0.4.3 \
- semver-0.9.0 \
- semver-parser-0.7.0 \
- serde-1.0.118 \
- serde_derive-1.0.118 \
- serde_json-1.0.61 \
- serde_qs-0.7.0 \
+ security-framework-2.2.0 \
+ security-framework-sys-2.2.0 \
+ serde-1.0.125 \
+ serde_derive-1.0.125 \
+ serde_json-1.0.64 \
+ serde_qs-0.7.2 \
serde_urlencoded-0.7.0 \
- sha-1-0.8.2 \
- sha1-0.6.0 \
+ sha-1-0.9.4 \
shellexpand-2.1.0 \
- signal-hook-0.1.17 \
- signal-hook-registry-1.2.1 \
+ signal-hook-0.3.8 \
+ signal-hook-registry-1.3.0 \
simple_asn1-0.4.1 \
- siphasher-0.3.3 \
+ siphasher-0.3.5 \
slab-0.4.2 \
- smallvec-1.4.2 \
+ smallvec-1.6.1 \
+ smawk-0.3.1 \
socket2-0.3.19 \
+ socket2-0.4.0 \
spin-0.5.2 \
- standback-0.2.13 \
static_assertions-1.1.0 \
- stdweb-0.4.20 \
- stdweb-derive-0.5.3 \
- stdweb-internal-macros-0.2.9 \
- stdweb-internal-runtime-0.1.5 \
string_cache-0.8.1 \
string_cache_codegen-0.5.1 \
strsim-0.8.0 \
- strsim-0.9.3 \
structopt-0.3.21 \
structopt-derive-0.4.14 \
- syn-1.0.53 \
- tempfile-3.1.0 \
- tendril-0.4.1 \
- terminal_size-0.1.13 \
- termios-0.3.2 \
+ syn-1.0.69 \
+ tempfile-3.2.0 \
+ tendril-0.4.2 \
+ terminal_size-0.1.16 \
textwrap-0.11.0 \
- thiserror-1.0.20 \
- thiserror-impl-1.0.20 \
- thread_local-1.0.1 \
+ textwrap-0.13.4 \
+ thiserror-1.0.24 \
+ thiserror-impl-1.0.24 \
time-0.1.43 \
- time-0.2.23 \
- time-macros-0.1.1 \
- time-macros-impl-0.1.1 \
- tinyvec-0.3.4 \
- tokio-0.2.22 \
- tokio-0.3.6 \
- tokio-1.0.1 \
- tokio-macros-1.0.0 \
+ tinyvec-1.2.0 \
+ tinyvec_macros-0.1.0 \
+ tokio-1.5.0 \
+ tokio-macros-1.1.0 \
tokio-native-tls-0.3.0 \
- tokio-socks-0.3.0 \
- tokio-stream-0.1.1 \
- tokio-tls-0.3.1 \
- tokio-util-0.3.1 \
- tokio-util-0.6.0 \
+ tokio-socks-0.5.1 \
+ tokio-util-0.6.6 \
toml-0.5.8 \
- tower-service-0.3.0 \
- tracing-0.1.19 \
- tracing-core-0.1.14 \
- tracing-futures-0.2.4 \
+ tower-service-0.3.1 \
+ tracing-0.1.25 \
+ tracing-core-0.1.17 \
treeline-0.1.0 \
- trust-dns-proto-0.19.5 \
- trust-dns-resolver-0.19.5 \
+ trust-dns-proto-0.20.1 \
+ trust-dns-resolver-0.20.1 \
try-lock-0.2.3 \
- typenum-1.12.0 \
+ typed-builder-0.9.0 \
+ typenum-1.13.0 \
unicase-2.6.0 \
- unicode-bidi-0.3.4 \
- unicode-normalization-0.1.13 \
- unicode-segmentation-1.6.0 \
+ unicode-bidi-0.3.5 \
+ unicode-normalization-0.1.17 \
+ unicode-segmentation-1.7.1 \
unicode-width-0.1.8 \
unicode-xid-0.2.1 \
untrusted-0.7.1 \
- url-2.2.0 \
+ url-2.2.1 \
utf-8-0.7.5 \
- uuid-0.8.1 \
- vcpkg-0.2.10 \
- vec-arena-1.0.0 \
+ uuid-0.8.2 \
+ value-bag-1.0.0-alpha.6 \
+ vcpkg-0.2.11 \
+ vec-arena-1.1.0 \
vec_map-0.8.2 \
- version_check-0.9.2 \
+ version_check-0.9.3 \
wait-timeout-0.2.0 \
- waker-fn-1.0.0 \
+ waker-fn-1.1.0 \
want-0.3.0 \
wasi-0.9.0+wasi-snapshot-preview1 \
- wasm-bindgen-0.2.68 \
- wasm-bindgen-backend-0.2.68 \
- wasm-bindgen-futures-0.4.18 \
- wasm-bindgen-macro-0.2.68 \
- wasm-bindgen-macro-support-0.2.68 \
- wasm-bindgen-shared-0.2.68 \
- web-sys-0.3.44 \
- wepoll-sys-stjepang-1.0.6 \
- widestring-0.4.2 \
- winapi-0.2.8 \
+ wasi-0.10.2+wasi-snapshot-preview1 \
+ wasm-bindgen-0.2.73 \
+ wasm-bindgen-backend-0.2.73 \
+ wasm-bindgen-futures-0.4.23 \
+ wasm-bindgen-macro-0.2.73 \
+ wasm-bindgen-macro-support-0.2.73 \
+ wasm-bindgen-shared-0.2.73 \
+ web-sys-0.3.50 \
+ wepoll-sys-3.0.1 \
+ widestring-0.4.3 \
winapi-0.3.9 \
- winapi-build-0.1.1 \
winapi-i686-pc-windows-gnu-0.4.0 \
- winapi-util-0.1.5 \
winapi-x86_64-pc-windows-gnu-0.4.0 \
winreg-0.6.2 \
winreg-0.7.0 \
winutil-0.1.1 \
- wiremock-0.4.3 \
- ws2_32-sys-0.2.1 \
+ wiremock-0.5.2 \
xml5ever-0.16.1
+CARGO_USE_GITHUB= yes
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/lychee