aboutsummaryrefslogtreecommitdiff
path: root/www/otrs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/otrs/Makefile')
-rw-r--r--www/otrs/Makefile21
1 files changed, 9 insertions, 12 deletions
diff --git a/www/otrs/Makefile b/www/otrs/Makefile
index 2e9714919d9b..bafff6beb7c3 100644
--- a/www/otrs/Makefile
+++ b/www/otrs/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= otrs
-PORTVERSION= 5.0.18
-PORTREVISION= 1
+PORTVERSION= 5.0.26
CATEGORIES= www
MASTER_SITES= http://ftp.otrs.org/pub/otrs/ \
ftp://ftp.samurai.com/pub/otrs/ \
@@ -44,6 +43,9 @@ BUILD_DEPENDS= p5-Archive-Zip>=0:archivers/p5-Archive-Zip \
p5-SOAP-Lite>=0:net/p5-SOAP-Lite \
p5-Class-Inspector>=0:devel/p5-Class-Inspector \
p5-Mozilla-CA>=0:www/p5-Mozilla-CA \
+ p5-CGI>=0:www/p5-CGI \
+ p5-Lingua-Translit>=0:devel/p5-Lingua-Translit \
+ p5-Pod-Strip>=0:textproc/p5-Pod-Strip \
p5-Template-Toolkit>=0:www/p5-Template-Toolkit
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -98,6 +100,7 @@ SSL_RUN_DEPENDS= p5-Crypt-SSLeay>=0:security/p5-Crypt-SSLeay
APACHE_RUN_DEPENDS= ${APACHE_PKGNAMEPREFIX}mod_perl2>=2.0.5:www/mod_perl2 \
p5-Apache-DBI>0:www/p5-Apache-DBI
+APACHE_USE= apache_run=22+
REPORTS_RUN_DEPENDS= p5-GD>=0:graphics/p5-GD \
p5-GD-Graph>=0:graphics/p5-GD-Graph \
@@ -124,10 +127,6 @@ GNUPG_RUN_DEPENDS= gpg:security/gnupg1
.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MAPACHE}
-USE_APACHE_RUN= 22+
-.endif
-
post-patch:
@${FIND} ${WRKSRC} -name "*.pm" | \
${XARGS} ${REINPLACE_CMD} -i '' \
@@ -141,18 +140,16 @@ do-build:
@${FIND} ${WRKSRC}/Kernel -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
@${FIND} ${WRKSRC} -type f | ${XARGS} ${SED} -i '' \
-e "s=/opt/=${PREFIX}/=g;s=wwwrun=${WWWOWN}=g;"
-.if ${PORT_OPTIONS:MISPELL}
+
+do-build-ISPELL-on:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${SED} -i '' \
-e "s=/usr/bin/ispell=${PREFIX}/bin/ispell=g"
-.endif
-.if ${PORT_OPTIONS:MASPELL}
+do-build-ASPELL-on:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${SED} -i '' \
-e "s=/usr/bin/ispell=${PREFIX}/bin/aspell=g"
-.endif
-.if ${PORT_OPTIONS:MGNUPG}
+do-build-GNUPG-on:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${SED} -i '' \
-e "s=/usr/bin/gpg=${PREFIX}/bin/gpg=g"
-.endif
do-install:
.for D in ${ROOT_DIRS_LIST:S!^!${OTRSDIR}/!} ${BIN_DIRS_LIST:S!^!${OTRSDIR}/bin/!} ${SCRIPTS_DIRS_LIST:S!^!${OTRSDIR}/scripts/!}