aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-Log-Handler/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Catalyst-Plugin-Log-Handler/Makefile')
-rw-r--r--www/p5-Catalyst-Plugin-Log-Handler/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Log-Handler/Makefile b/www/p5-Catalyst-Plugin-Log-Handler/Makefile
new file mode 100644
index 000000000000..3f69cf9c1324
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Log-Handler/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: p5-Catalyst-Log-Handler
+# Date created: October 27, 2011
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Log-Handler
+PORTVERSION= 0.08
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Catalyst log handler
+
+BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Log-Handler>=0:${PORTSDIR}/devel/p5-Log-Handler \
+ p5-MRO-Compat>=0:${PORTSDIR}/devel/p5-MRO-Compat
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::Log::Handler.3
+
+PLIST_FILES= %%SITE_PERL%%/Catalyst/Plugin/Log/Handler.pm
+PLIST_DIRS= %%SITE_PERL%%/Catalyst/Plugin/Log \
+ %%SITE_PERL%%/Catalyst/Plugin \
+ %%SITE_PERL%%/Catalyst
+
+.include <bsd.port.mk>