aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Pod-Site/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Pod-Site/Makefile')
-rw-r--r--www/p5-Pod-Site/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/www/p5-Pod-Site/Makefile b/www/p5-Pod-Site/Makefile
index 0f81aec15b18..5cbef32d1771 100644
--- a/www/p5-Pod-Site/Makefile
+++ b/www/p5-Pod-Site/Makefile
@@ -40,4 +40,15 @@ TEST_DEPENDS+= p5-Test-Pod>=1.41:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=1.06:${PORTSDIR}/devel/p5-Test-Pod-Coverage
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+RUN_DEPENDS+= p5-File-Path>=2.07:${PORTSDIR}/devel/p5-File-Path
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.if ${PERL_LEVEL} < 501200
+RUN_DEPENDS+= p5-Pod-Simple>=3.12:${PORTSDIR}/textproc/p5-Pod-Simple
+.endif
+
+.include <bsd.port.post.mk>