aboutsummaryrefslogtreecommitdiff
path: root/www/punbb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/punbb/Makefile')
-rw-r--r--www/punbb/Makefile25
1 files changed, 11 insertions, 14 deletions
diff --git a/www/punbb/Makefile b/www/punbb/Makefile
index 08cf2da0fb24..ee7772d291ee 100644
--- a/www/punbb/Makefile
+++ b/www/punbb/Makefile
@@ -24,14 +24,13 @@ SUB_FILES= pkg-message
NO_BUILD= yes
USE_PHP= yes
-USE_BZIP2= yes
+USES= tar:bzip2
-OPTIONS_DEFINE= LANGUAGE_PACK EXTRAS
+OPTIONS_DEFINE= LANGUAGE_PACK EXTRAS
OPTIONS_DEFAULT= LANGUAGE_PACK EXTRAS
LANGUAGE_PACK_DESC= Install language packs
EXTRAS_DESC= Install all plugins available
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MLANGUAGE_PACK}
@@ -111,25 +110,23 @@ PLIST_SUB+= PLUGINS="@comment "
.endif
do-install:
- @cd ${WRKSRC}/upload && ${COPYTREE_SHARE} . ${WWWDIR}
+ @cd ${WRKSRC}/upload && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
.for i in ${LANGFILES}
- ${UNZIP_CMD} -o ${DISTDIR}/${i} -d ${WWWDIR}/lang -x '*/.DS_Store' -x '*/._.DS_Store'
+ ${UNZIP_CMD} -o ${DISTDIR}/${i} -d ${STAGEDIR}${WWWDIR}/lang -x '*/.DS_Store' -x '*/._.DS_Store'
.endfor
.for i in ${PLUGINS}
- ${UNZIP_CMD} -o ${DISTDIR}/${i} -d ${WWWDIR}/plugins
+ ${UNZIP_CMD} -o ${DISTDIR}/${i} -d ${STAGEDIR}${WWWDIR}/plugins
.endfor
-.if !defined(NOPORTEXAMPLES)
- @${INSTALL} -d ${EXAMPLESDIR}
- cd ${WRKSRC}/extras && ${INSTALL_DATA} ${PORTEXAMPLES} ${EXAMPLESDIR}
-.endif
+ @${INSTALL} -d ${STAGEDIR}${EXAMPLESDIR}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
- @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}' >> ${TMPPLIST}
+.for i in ${PORTEXAMPLES}
+ @${INSTALL_DATA} ${WRKSRC}/extras/${i} ${STAGEDIR}${EXAMPLESDIR}
+.endfor
-post-install:
- @${CAT} ${PKGMESSAGE}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}
+ @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}' >> ${TMPPLIST}
.include <bsd.port.mk>