aboutsummaryrefslogtreecommitdiff
path: root/www/py-cssselect/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-cssselect/Makefile')
-rw-r--r--www/py-cssselect/Makefile27
1 files changed, 25 insertions, 2 deletions
diff --git a/www/py-cssselect/Makefile b/www/py-cssselect/Makefile
index 7ecc3cd05a63..2117fc90472a 100644
--- a/www/py-cssselect/Makefile
+++ b/www/py-cssselect/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cssselect
-PORTVERSION= 0.6.1
+PORTVERSION= 0.7.1
#PORTREVISION= 0
CATEGORIES= www
MASTER_SITES= CHEESESHOP
@@ -15,8 +15,31 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= nivit@FreeBSD.org
COMMENT= Cssselect parses CSS3 Selectors and translates them to XPath 1.0
+LICENSE= BSD
+
+OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT= DOCS
+
+.include <bsd.port.options.mk>
+
# Python3 ready
USE_PYTHON= -2.7
USE_PYDISTUTILS= easy_install
-.include <bsd.port.mk>
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+SPHINX_BUILD= sphinx-build
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+BUILD_DEPENDS= sphinx-build:${PORTSDIR}/textproc/py-sphinx
+
+post-install:
+ ${SETENV} PYTHONPATH="${PYTHONPREFIX_SITELIBDIR}" \
+ ${SPHINX_BUILD} -a -b html ${WRKSRC}/docs ${WRKSRC}/docs.html && \
+ cd ${WRKSRC}/docs.html && ${MKDIR} ${DOCSDIR} && \
+ ${COPYTREE_SHARE} . ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>