aboutsummaryrefslogtreecommitdiff
path: root/www/py-django-smart-selects/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-django-smart-selects/Makefile')
-rw-r--r--www/py-django-smart-selects/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/www/py-django-smart-selects/Makefile b/www/py-django-smart-selects/Makefile
new file mode 100644
index 000000000000..00f59a2fab15
--- /dev/null
+++ b/www/py-django-smart-selects/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= django-smart-selects
+PORTVERSION= 1.5.9
+CATEGORIES= www
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gatemken@cisco.com
+COMMENT= Quickly filter or group "chained" models
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django22>0:www/py-django22@${PY_FLAVOR}
+
+USES= python:3.6+,run
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>