aboutsummaryrefslogtreecommitdiff
path: root/www/py-plone.app.contentrules/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-plone.app.contentrules/Makefile')
-rw-r--r--www/py-plone.app.contentrules/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/www/py-plone.app.contentrules/Makefile b/www/py-plone.app.contentrules/Makefile
index adceb7866385..71bf9fdd3122 100644
--- a/www/py-plone.app.contentrules/Makefile
+++ b/www/py-plone.app.contentrules/Makefile
@@ -1,12 +1,7 @@
-# New ports collection makefile for: py-plone.app.contentrules
-# Date created: 03 January 2012
-# Whom: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
-#
# $FreeBSD$
-#
PORTNAME= plone.app.contentrules
-PORTVERSION= 2.1.4
+PORTVERSION= 2.1.8
CATEGORIES= www python zope
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -34,14 +29,11 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}five.formlib>=0:${PORTSDIR}/devel/py-five.fo
${PYTHON_PKGNAMEPREFIX}zope.i18nmessageid>=0:${PORTSDIR}/textproc/py-zope.i18nmessageid \
${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
${PYTHON_PKGNAMEPREFIX}zope.lifecycleevent>=0:${PORTSDIR}/devel/py-zope.lifecycleevent \
- ${PYTHON_PKGNAMEPREFIX}zope.publisher>=0:${PORTSDIR}/devel/py-zope.publisher \
+ ${PYTHON_PKGNAMEPREFIX}zope.publisher>=3.11.0:${PORTSDIR}/devel/py-zope.publisher \
${PYTHON_PKGNAMEPREFIX}zope.schema>=0:${PORTSDIR}/devel/py-zope.schema \
${PYTHON_PKGNAMEPREFIX}zope.site>=0:${PORTSDIR}/devel/py-zope.site \
${PYTHON_PKGNAMEPREFIX}zope.traversing>=0:${PORTSDIR}/devel/py-zope.traversing \
- ${PYTHON_PKGNAMEPREFIX}zope.app.publication>=0:${PORTSDIR}/devel/py-zope.app.publication \
${PYTHON_PKGNAMEPREFIX}Acquisition>=0:${PORTSDIR}/devel/py-Acquisition \
- ${PYTHON_PKGNAMEPREFIX}Products.Archetypes>=0:${PORTSDIR}/devel/py-Products.Archetypes \
- ${PYTHON_PKGNAMEPREFIX}Products.ATContentTypes>=0:${PORTSDIR}/devel/py-Products.ATContentTypes \
${PYTHON_PKGNAMEPREFIX}Products.CMFCore>=0:${PORTSDIR}/devel/py-Products.CMFCore \
${PYTHON_PKGNAMEPREFIX}Products.CMFDefault>=0:${PORTSDIR}/devel/py-Products.CMFDefault \
${PYTHON_PKGNAMEPREFIX}Products.GenericSetup>=0:${PORTSDIR}/devel/py-Products.GenericSetup \
@@ -49,8 +41,9 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}five.formlib>=0:${PORTSDIR}/devel/py-five.fo
zodb${PYTHON_PKGNAMESUFFIX}>=0:${PORTSDIR}/databases/zodb3
DIST_SUBDIR= zope
-USE_PYTHON= yes
+USE_PYTHON= -2.7
USE_PYDISTUTILS= easy_install
-#USE_ZOPE= yes
+USE_ZIP= yes
+USE_ZOPE= yes
.include <bsd.port.mk>