aboutsummaryrefslogtreecommitdiff
path: root/www/py-plone.schemaeditor/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-plone.schemaeditor/Makefile')
-rw-r--r--www/py-plone.schemaeditor/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/www/py-plone.schemaeditor/Makefile b/www/py-plone.schemaeditor/Makefile
new file mode 100644
index 000000000000..4d02e793fc97
--- /dev/null
+++ b/www/py-plone.schemaeditor/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= plone.schemaeditor
+PORTVERSION= 1.3.3
+CATEGORIES= www python zope
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= zope@FreeBSD.org
+COMMENT= Provides through-the-web editing of a zope schema/interface
+
+LICENSE= BSD
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.component>0:${PORTSDIR}/devel/py-zope.component \
+ ${PYTHON_PKGNAMEPREFIX}zope.container>0:${PORTSDIR}/devel/py-zope.container \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>0:${PORTSDIR}/devel/py-zope.interface \
+ ${PYTHON_PKGNAMEPREFIX}zope.lifecycleevent>0:${PORTSDIR}/devel/py-zope.lifecycleevent \
+ ${PYTHON_PKGNAMEPREFIX}zope.schema>0:${PORTSDIR}/devel/py-zope.schema \
+ ${PYTHON_PKGNAMEPREFIX}zope.publisher>0:${PORTSDIR}/devel/py-zope.publisher \
+ ${PYTHON_PKGNAMEPREFIX}z3c.form>0:${PORTSDIR}/devel/py-z3c.form \
+ ${PYTHON_PKGNAMEPREFIX}plone.z3cform>0:${PORTSDIR}/www/py-plone.z3cform \
+ ${PYTHON_PKGNAMEPREFIX}plone.autoform>0:${PORTSDIR}/www/py-plone.autoform
+
+DIST_SUBDIR= zope
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+USE_ZIP= yes
+
+NO_STAGE= yes
+
+.include <bsd.port.mk>