aboutsummaryrefslogtreecommitdiff
path: root/www/py-strawberry-graphql-django/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-strawberry-graphql-django/Makefile')
-rw-r--r--www/py-strawberry-graphql-django/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/www/py-strawberry-graphql-django/Makefile b/www/py-strawberry-graphql-django/Makefile
index 428a83537adc..80092556f6a4 100644
--- a/www/py-strawberry-graphql-django/Makefile
+++ b/www/py-strawberry-graphql-django/Makefile
@@ -1,5 +1,5 @@
PORTNAME= strawberry-graphql-django
-DISTVERSION= 0.37.0
+DISTVERSION= 0.39.2
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,8 +14,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PY_SETUPTOOLS} \
${PYTHON_PKGNAMEPREFIX}poetry-core>=1.0.0:devel/py-poetry-core@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django32>=3.2:www/py-django32@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}strawberry-graphql>=0.212.0:devel/py-strawberry-graphql@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asgiref>=3.8:www/py-asgiref@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django42>=3.2:www/py-django42@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}strawberry-graphql>=0.227.1:devel/py-strawberry-graphql@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist pep517