aboutsummaryrefslogtreecommitdiff
path: root/www/uwsgi
diff options
context:
space:
mode:
Diffstat (limited to 'www/uwsgi')
-rw-r--r--www/uwsgi/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/www/uwsgi/Makefile b/www/uwsgi/Makefile
index 3178cae50d0b..b1805f11e9dc 100644
--- a/www/uwsgi/Makefile
+++ b/www/uwsgi/Makefile
@@ -7,7 +7,7 @@ PORTREVISION= 2
CATEGORIES= www python
MASTER_SITES= http://projects.unbit.it/downloads/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= eugene@zhegan.in
COMMENT= Developer-friendly WSGI server which uses uwsgi protocol
LICENSE= GPLv2
@@ -33,6 +33,12 @@ PLIST_FILES= bin/uwsgi \
OPTIONS_DEFINE= DEBUG JSON PCRE XML
+OPTIONS_GROUP= PLG
+OPTIONS_GROUP_PLG= PSGI
+
+PLG_DESC= Enable plugins
+PSGI_DESC= PSGI embedded plugin
+
DEBUG_VARS= PYDISTUTILS_BUILDARGS+=--debug
JSON_VARS= BUILDCONF_JSON=jansson
@@ -53,6 +59,9 @@ post-patch:
@${REINPLACE_CMD} -e '/^${var:tl} =/ s|= .*|= ${BUILDCONF_${var}:Ufalse}|' ${WRKSRC}/buildconf/base.ini
.endfor
+post-patch-PSGI-on:
+ @${REINPLACE_CMD} -e 's/%(main_plugin)s,/%(main_plugin)s, psgi,/' ${WRKSRC}/buildconf/base.ini
+
do-configure:
@${DO_NADA}