aboutsummaryrefslogtreecommitdiff
path: root/www/webcpp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/webcpp/Makefile')
-rw-r--r--www/webcpp/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/www/webcpp/Makefile b/www/webcpp/Makefile
new file mode 100644
index 000000000000..2e61ff1e48c5
--- /dev/null
+++ b/www/webcpp/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: webcpp
+# Date created: 12 May 2003
+# Whom: Nosov Artem <chip-set@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= webcpp
+PORTVERSION= 0.8.2
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= chip-set@mail.ru
+COMMENT= Convert you source code to syntax highlighted HTML
+
+USE_GCC= 3.2
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+USE_REINPLACE= yes
+
+.if defined(WANT_FINAL)
+CONFIGURE_ARGS+= --enable-final
+USE_GMAKE= yes
+.endif
+
+pre-patch:
+ ${FIND} ${WRKSRC} -name '*.h' | xargs ${REINPLACE_CMD} \
+ 's|IO->close()|if(IO) IO->close()|g'
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in AUTHORS COPYING README TODO docs.html
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>