aboutsummaryrefslogtreecommitdiff
path: root/www/yarn/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/yarn/Makefile')
-rw-r--r--www/yarn/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/www/yarn/Makefile b/www/yarn/Makefile
index 5cf89a222587..14b9e5962da2 100644
--- a/www/yarn/Makefile
+++ b/www/yarn/Makefile
@@ -56,4 +56,16 @@ do-install-HADOOPCOMPAT-off:
${RLN} ${STAGEDIR}${PREFIX}/lib/node_modules/yarn/bin/yarn \
${STAGEDIR}${PREFIX}/bin/yarn
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNODE10}
+DEPRECATED= Uses EOL Python 2.7 via www/node10
+EXPIRATION_DATE=2021-06-23
+.endif
+.if ${PORT_OPTIONS:MNODE12}
+DEPRECATED= Uses EOL Python 2.7 via www/node12
+EXPIRATION_DATE=2021-06-23
+.endif
+
+
.include <bsd.port.mk>