aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/linux-flashplugin9/Makefile3
-rw-r--r--www/linux-mplayer-plugin/Makefile7
-rw-r--r--www/linux-opera-devel/Makefile4
-rw-r--r--www/linux-opera/Makefile4
-rw-r--r--www/linux-seamonkey/Makefile.common7
-rw-r--r--www/nspluginwrapper-devel/Makefile2
-rw-r--r--www/nspluginwrapper/Makefile2
-rw-r--r--www/opera-linuxplugins/Makefile2
8 files changed, 9 insertions, 22 deletions
diff --git a/www/linux-flashplugin9/Makefile b/www/linux-flashplugin9/Makefile
index 30d17b1ce288..d9359f7d4f29 100644
--- a/www/linux-flashplugin9/Makefile
+++ b/www/linux-flashplugin9/Makefile
@@ -19,10 +19,9 @@ EXTRACT_ONLY= install_flash_player_9.tar.gz
MAINTAINER= jamie@bishopston.net
COMMENT= Adobe Flash Player NPAPI Plugin
-RUN_DEPENDS= ${LINUXBASE}/lib/libssl.so.5:${PORTSDIR}/security/linux-openssl
-
ONLY_FOR_ARCHS= amd64 i386
USE_LINUX= yes
+USE_LINUX_APPS= openssl
RESTRICTED= Redistribution not allowed
RESTRICTED_FILES= ${DISTFILES:Nlibflashsupport*:C/:[^:]+$//}
diff --git a/www/linux-mplayer-plugin/Makefile b/www/linux-mplayer-plugin/Makefile
index 4434762eb6bd..3b41bef1c702 100644
--- a/www/linux-mplayer-plugin/Makefile
+++ b/www/linux-mplayer-plugin/Makefile
@@ -17,14 +17,11 @@ PKGNAMEPREFIX= linux-
MAINTAINER= ports@FreeBSD.org
COMMENT= Embed MPlayer into browser
-RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer \
- ${LINUXBASE}/usr/lib/libgtk-x11-2.0.so.0:${PORTSDIR}/x11-toolkits/linux-gtk2 \
- ${LINUXBASE}/usr/lib/libatk-1.0.so.0:${PORTSDIR}/accessibility/linux-atk \
- ${LINUXBASE}/usr/lib/libpangoxft-1.0.so.0:${PORTSDIR}/x11-toolkits/linux-pango
+RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
NO_BUILD= yes
USE_LINUX_RPM= yes
-USE_XLIB= yes
+USE_LINUX_APPS= atk gtk2 pango xorglibs
LINUX_DIST= fedora
LINUX_DIST_VER= 4
PREFIX?= ${LOCALBASE}
diff --git a/www/linux-opera-devel/Makefile b/www/linux-opera-devel/Makefile
index 9e0323f366cf..7490e33a5ea1 100644
--- a/www/linux-opera-devel/Makefile
+++ b/www/linux-opera-devel/Makefile
@@ -24,12 +24,10 @@ DISTNAME= ${PORTNAME}-${OPERA_VER}.gcc4-static-qt3.i386
MAINTAINER= mezz@FreeBSD.org
COMMENT= A blazingly fast, full-featured, standards-compliant browser
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libaspell.so.15:${PORTSDIR}/textproc/linux-aspell
-
WRKSRC= ${WRKDIR}/${DISTNAME:S/.gcc/-${OPERA_BUILD}.gcc/}
-USE_XLIB= yes
USE_BZIP2= yes
USE_LINUX= yes
+USE_LINUX_APPS= aspell xorglibs
ONLY_FOR_ARCHS= i386 amd64
NO_BUILD= yes
diff --git a/www/linux-opera/Makefile b/www/linux-opera/Makefile
index 9e0323f366cf..7490e33a5ea1 100644
--- a/www/linux-opera/Makefile
+++ b/www/linux-opera/Makefile
@@ -24,12 +24,10 @@ DISTNAME= ${PORTNAME}-${OPERA_VER}.gcc4-static-qt3.i386
MAINTAINER= mezz@FreeBSD.org
COMMENT= A blazingly fast, full-featured, standards-compliant browser
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libaspell.so.15:${PORTSDIR}/textproc/linux-aspell
-
WRKSRC= ${WRKDIR}/${DISTNAME:S/.gcc/-${OPERA_BUILD}.gcc/}
-USE_XLIB= yes
USE_BZIP2= yes
USE_LINUX= yes
+USE_LINUX_APPS= aspell xorglibs
ONLY_FOR_ARCHS= i386 amd64
NO_BUILD= yes
diff --git a/www/linux-seamonkey/Makefile.common b/www/linux-seamonkey/Makefile.common
index dc6d260e4e88..36fa877cfedc 100644
--- a/www/linux-seamonkey/Makefile.common
+++ b/www/linux-seamonkey/Makefile.common
@@ -12,17 +12,12 @@ MASTER_SITE_SUBDIR?= ${PORTNAME}/releases/${DISTVERSION}
.endif
PKGNAMEPREFIX?= linux-
-RUN_DEPENDS?= ${LINUXBASE}/usr/lib/libgtk-x11-2.0.so.0:${PORTSDIR}/x11-toolkits/linux-gtk2 \
- ${LINUXBASE}/usr/lib/libatk-1.0.so.0:${PORTSDIR}/accessibility/linux-atk \
- ${LINUXBASE}/usr/lib/libpangoxft-1.0.so.0:${PORTSDIR}/x11-toolkits/linux-pango\
- ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
- ${LINUXBASE}/usr/share/icons/hicolor/index.theme:${PORTSDIR}/x11-themes/linux-hicolor-icon-theme
-
NO_BUILD= yes
ONLY_FOR_ARCHS= i386 amd64
APP_NAME= ${PKGBASE}
BIN_NAME?= ${PORTNAME}
USE_LINUX= yes
+USE_LINUX_APPS= atk fontconfig gtk2 hicontheme pango
WRKSRC?= ${WRKDIR}/${BIN_NAME}
FDIR= ${PREFIX}/lib/${APP_NAME}
COMMON_DIR= ${.CURDIR}/../../www/linux-seamonkey
diff --git a/www/nspluginwrapper-devel/Makefile b/www/nspluginwrapper-devel/Makefile
index 77be439eb3f8..6cec5899052f 100644
--- a/www/nspluginwrapper-devel/Makefile
+++ b/www/nspluginwrapper-devel/Makefile
@@ -18,7 +18,6 @@ COMMENT= A compatibility plugin for Netscape 4 (NPAPI) plugins
EXTRACT_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm
LIB_DEPENDS= curl.5:${PORTSDIR}/ftp/curl
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-x11-2.0.so.0:${PORTSDIR}/x11-toolkits/linux-gtk2
RPMFILE= ${PORTNAME}-i386-${PORTVERSION}-1.x86_64.rpm
@@ -26,6 +25,7 @@ ONLY_FOR_ARCHS= i386 amd64
USE_BZIP2= yes
USE_LINUX= yes
+USE_LINUX_APPS= gtk2
USE_XORG= x11 xext xt
USE_GNOME= glib20 gtk20 pkgconfig
diff --git a/www/nspluginwrapper/Makefile b/www/nspluginwrapper/Makefile
index 77be439eb3f8..6cec5899052f 100644
--- a/www/nspluginwrapper/Makefile
+++ b/www/nspluginwrapper/Makefile
@@ -18,7 +18,6 @@ COMMENT= A compatibility plugin for Netscape 4 (NPAPI) plugins
EXTRACT_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm
LIB_DEPENDS= curl.5:${PORTSDIR}/ftp/curl
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-x11-2.0.so.0:${PORTSDIR}/x11-toolkits/linux-gtk2
RPMFILE= ${PORTNAME}-i386-${PORTVERSION}-1.x86_64.rpm
@@ -26,6 +25,7 @@ ONLY_FOR_ARCHS= i386 amd64
USE_BZIP2= yes
USE_LINUX= yes
+USE_LINUX_APPS= gtk2
USE_XORG= x11 xext xt
USE_GNOME= glib20 gtk20 pkgconfig
diff --git a/www/opera-linuxplugins/Makefile b/www/opera-linuxplugins/Makefile
index 7fc79c11d085..b70d91f87393 100644
--- a/www/opera-linuxplugins/Makefile
+++ b/www/opera-linuxplugins/Makefile
@@ -39,7 +39,7 @@ OPERA_BUILD= 2456
USE_BZIP2= yes
USE_LINUX= yes
-USE_XLIB= yes
+USE_LINUX_APPS= xorglibs
ONLY_FOR_ARCHS= i386 amd64
WRKSRC= ${WRKDIR}/${PORTNAME}-${OPERA_VER}-${OPERA_BUILD}.gcc3-shared-qt3.i386