aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_bw/Makefile33
-rw-r--r--www/mod_bw/distinfo2
-rw-r--r--www/mod_bw/pkg-descr6
4 files changed, 42 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 6d5089db500d..e7a18e0f80c3 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -273,6 +273,7 @@
SUBDIR += mod_blosxom
SUBDIR += mod_blowchunks
SUBDIR += mod_bunzip2
+ SUBDIR += mod_bw
SUBDIR += mod_cband
SUBDIR += mod_curb
SUBDIR += mod_cfg_ldap
diff --git a/www/mod_bw/Makefile b/www/mod_bw/Makefile
new file mode 100644
index 000000000000..228593b69e51
--- /dev/null
+++ b/www/mod_bw/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: mod_bw
+# Date created: Sep 11 2005
+# Whom: Clement Laforet <clement@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_bw
+PORTVERSION= 0.6
+CATEGORIES= www
+MASTER_SITES= http://www.ivn.cl/apache/
+DISTNAME= bw_mod-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= apache2
+
+MAINTAINER= apache@FreeBSD.org
+COMMENT= Bandwidth and Connection control per Virtual Host or Directory
+
+WANT_APACHE= 2
+AP_FAST_BUILD= YES
+AP_GENPLIST= YES
+
+SRC_FILE= bw_mod-0.6.c
+PORTDOCS= APACHE2-LICENSE LICENSE bw_mod-0.6.txt
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/apache20/Makefile.modules.3rd"
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC} && \
+ ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+
+.include <bsd.port.post.mk>
diff --git a/www/mod_bw/distinfo b/www/mod_bw/distinfo
new file mode 100644
index 000000000000..eb34626134a0
--- /dev/null
+++ b/www/mod_bw/distinfo
@@ -0,0 +1,2 @@
+MD5 (apache2/bw_mod-0.6.tgz) = 0c92fa6344f487321291a592dbb49856
+SIZE (apache2/bw_mod-0.6.tgz) = 50298
diff --git a/www/mod_bw/pkg-descr b/www/mod_bw/pkg-descr
new file mode 100644
index 000000000000..8c597384a814
--- /dev/null
+++ b/www/mod_bw/pkg-descr
@@ -0,0 +1,6 @@
+Bandwidth and Connection control per Virtual Host or Directory.
+It can:
+ * Restrict the number of simultaneous connections per vhost/dir
+ * Limit the bandwidth for files on vhost/dir
+
+WWW: http://www.ivn.cl/apache/