aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/amyc/Makefile2
-rw-r--r--www/apache-jserv/Makefile2
-rw-r--r--www/apache2/Makefile3
-rw-r--r--www/apache20/Makefile3
-rw-r--r--www/apache21/Makefile3
-rw-r--r--www/apache22/Makefile3
-rw-r--r--www/aria/Makefile2
-rw-r--r--www/bookmarkbridge/Makefile2
-rw-r--r--www/cgicc/Makefile2
-rw-r--r--www/comclear/Makefile3
-rw-r--r--www/dpsearch/Makefile2
-rw-r--r--www/emacs-w3m/Makefile2
-rw-r--r--www/flood/Makefile3
-rw-r--r--www/gforge/Makefile2
-rw-r--r--www/glibwww/Makefile2
-rw-r--r--www/gnome-user-share/Makefile2
-rw-r--r--www/gtkhtml/Makefile2
-rw-r--r--www/harvest/Makefile2
-rw-r--r--www/httrack/Makefile2
-rw-r--r--www/kazehakase/Makefile2
-rw-r--r--www/libapreq2/Makefile2
-rw-r--r--www/libghttp/Makefile2
-rw-r--r--www/libwww/Makefile2
-rw-r--r--www/lighttpd/Makefile3
-rw-r--r--www/mdw/Makefile2
-rw-r--r--www/mnogosearch/Makefile2
-rw-r--r--www/mnogosearch31/Makefile2
-rw-r--r--www/mod_clamav/Makefile2
-rw-r--r--www/mod_webapp/Makefile3
-rw-r--r--www/mozilla-bonobo/Makefile2
-rw-r--r--www/oops/Makefile2
-rw-r--r--www/openvrml/Makefile2
-rw-r--r--www/osb-browser/Makefile2
-rw-r--r--www/osb-nrcit/Makefile2
-rw-r--r--www/osb-nrcore/Makefile2
-rw-r--r--www/p5-libapreq2/Makefile2
-rw-r--r--www/peacock/Makefile2
-rw-r--r--www/privoxy+ipv6/Makefile2
-rw-r--r--www/privoxy/Makefile2
-rw-r--r--www/scout/Makefile2
-rw-r--r--www/swfdec-plugin/Makefile2
-rw-r--r--www/swish-e/Makefile2
-rw-r--r--www/twhttpd/Makefile2
-rw-r--r--www/webstone-ssl/Makefile2
-rw-r--r--www/winhelpcgi/Makefile2
-rw-r--r--www/wml/Makefile2
-rw-r--r--www/wsdlpull/Makefile2
-rw-r--r--www/wyvern/Makefile2
48 files changed, 48 insertions, 56 deletions
diff --git a/www/amyc/Makefile b/www/amyc/Makefile
index 43aea5ae113c..6ff1f847f1c2 100644
--- a/www/amyc/Makefile
+++ b/www/amyc/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.crevola.com/about/current/
MAINTAINER= petef@FreeBSD.org
COMMENT= Display the contents of your Netscape cache
-USE_AUTOCONF_VER= 213
+USE_AUTOTOOLS= autoconf:213
USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/www/apache-jserv/Makefile b/www/apache-jserv/Makefile
index 0a5ffbbd1fe0..0e1da71bcfae 100644
--- a/www/apache-jserv/Makefile
+++ b/www/apache-jserv/Makefile
@@ -26,7 +26,7 @@ RUN_DEPENDS= ${JAVAVM}:${PORTSDIR}/java/javavmwrapper\
USE_GMAKE= yes
GMAKE= ${LOCALBASE}/bin/gmake # Must have the full path.
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
USE_PERL5= yes
APACHE_COMPAT= yes
JAVAVM?= ${LOCALBASE}/bin/javavm
diff --git a/www/apache2/Makefile b/www/apache2/Makefile
index f0002f8c86a6..3baad1ee2316 100644
--- a/www/apache2/Makefile
+++ b/www/apache2/Makefile
@@ -52,8 +52,7 @@ SCRIPTS_ENV+= LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} \
LIBTOOL_M4=${LOCALBASE}/share/aclocal/libtool${LIBTOOL_VERSION}.m4 \
AUTOHEADER=${AUTOHEADER}
USE_ICONV= yes
-USE_AUTOCONF_VER= 259
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= autoconf:259 libtool:15
USE_PERL5= yes
USE_RC_SUBR= yes
USE_REINPLACE= yes
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index 81c32cd90afd..c49f1f096892 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -51,8 +51,7 @@ SCRIPTS_ENV+= LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} \
LIBTOOL_M4=${LOCALBASE}/share/aclocal/libtool${LIBTOOL_VERSION}.m4 \
AUTOHEADER=${AUTOHEADER}
USE_ICONV= yes
-USE_AUTOCONF_VER= 259
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= autoconf:259 libtool:15
USE_PERL5= yes
USE_RC_SUBR= yes
USE_REINPLACE= yes
diff --git a/www/apache21/Makefile b/www/apache21/Makefile
index b7756748ab8b..b8be68d8bb1c 100644
--- a/www/apache21/Makefile
+++ b/www/apache21/Makefile
@@ -41,8 +41,7 @@ SCRIPTS_ENV+= LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} \
USE_BZIP2= yes
USE_ICONV= yes
-USE_AUTOCONF_VER= 259
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= autoconf:259 libtool:15
USE_PERL5= yes
USE_RC_SUBR= yes
USE_REINPLACE= yes
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index b7756748ab8b..b8be68d8bb1c 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -41,8 +41,7 @@ SCRIPTS_ENV+= LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} \
USE_BZIP2= yes
USE_ICONV= yes
-USE_AUTOCONF_VER= 259
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= autoconf:259 libtool:15
USE_PERL5= yes
USE_RC_SUBR= yes
USE_REINPLACE= yes
diff --git a/www/aria/Makefile b/www/aria/Makefile
index c985c4ed88fa..453422acd49e 100644
--- a/www/aria/Makefile
+++ b/www/aria/Makefile
@@ -21,7 +21,7 @@ USE_OPENSSL= yes
USE_GETOPT_LONG=yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
diff --git a/www/bookmarkbridge/Makefile b/www/bookmarkbridge/Makefile
index 1fa50b7601f7..367673ea0f6d 100644
--- a/www/bookmarkbridge/Makefile
+++ b/www/bookmarkbridge/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
USE_QT_VER= 3
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-mt --program-prefix="" \
--with-libxml2-include="${LOCALBASE}/include/libxml2"
diff --git a/www/cgicc/Makefile b/www/cgicc/Makefile
index 7a0a8e5c71a0..5a0059ae5375 100644
--- a/www/cgicc/Makefile
+++ b/www/cgicc/Makefile
@@ -16,7 +16,7 @@ COMMENT= A C++ class library for writing CGI applications
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAKE_ARGS= NOPORTDOCS=${NOPORTDOCS}
INSTALLS_SHLIB= yes
diff --git a/www/comclear/Makefile b/www/comclear/Makefile
index 7085a187c03a..1dce4b61c2ff 100644
--- a/www/comclear/Makefile
+++ b/www/comclear/Makefile
@@ -17,8 +17,7 @@ COMMENT= A history cleaner for Netscape Navigator and Communicator
USE_REINPLACE= yes
WANT_GNOME= yes
USE_GMAKE= yes
-USE_AUTOMAKE_VER= 14
-USE_AUTOCONF_VER= 213
+USE_AUTOTOOLS= automake:14 autoconf:213
.include <bsd.port.pre.mk>
diff --git a/www/dpsearch/Makefile b/www/dpsearch/Makefile
index 89b8612216e4..dcb572829d57 100644
--- a/www/dpsearch/Makefile
+++ b/www/dpsearch/Makefile
@@ -18,7 +18,7 @@ COMMENT= Open source search engine for Internet and Intranet sites
INSTALLS_SHLIB= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
DOCSDIR= ${PREFIX}/share/doc/dataparksearch
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/www/emacs-w3m/Makefile b/www/emacs-w3m/Makefile
index a0999e0284c0..28f9cc2c0361 100644
--- a/www/emacs-w3m/Makefile
+++ b/www/emacs-w3m/Makefile
@@ -25,7 +25,7 @@ ICONDIR?= ${EMACS_LIBDIR_WITH_VER}/etc/w3m/icons
ETCDIR?= ${EMACS_LIBDIR_WITH_VER}/etc/w3m
INFODIR?= info
-USE_AUTOCONF_VER= 213
+USE_AUTOTOOLS= autoconf:213
ALL_TARGET= default
PLIST_SUB+= LISPDIR=${LISPDIR} \
diff --git a/www/flood/Makefile b/www/flood/Makefile
index 1bd8a85a6154..ce6213711f37 100644
--- a/www/flood/Makefile
+++ b/www/flood/Makefile
@@ -18,8 +18,7 @@ LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2 \
apr-1:${PORTSDIR}/devel/apr
WRKSRC= ${WRKDIR}/httpd-test/flood
-USE_AUTOCONF_VER= 253
-WANT_LIBTOOL_VER= 15
+USE_AUTOTOOLS= autoconf:253 libtool:15:env
CONFIGURE_ARGS= --disable-shared \
--with-apr=${LOCALBASE}/bin/apr-1-config \
--with-apr-util=${LOCALBASE}/bin/apu-1-config
diff --git a/www/gforge/Makefile b/www/gforge/Makefile
index 53162bc0562f..2b4156e528d5 100644
--- a/www/gforge/Makefile
+++ b/www/gforge/Makefile
@@ -21,7 +21,7 @@ USE_REINPLACE= YES
USE_PERL5= YES
HAS_CONFIGURE= YES
USE_APACHE= YES
-USE_AUTOCONF_VER= 253
+USE_AUTOTOOLS= autoconf:253
NO_BUILD= YES
USE_PHP= pgsql session pcre
WANT_PHP_CLI= YES
diff --git a/www/glibwww/Makefile b/www/glibwww/Makefile
index f4100e528fdf..3fec17d27c70 100644
--- a/www/glibwww/Makefile
+++ b/www/glibwww/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= wwwzip.1:${PORTSDIR}/www/libwww
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomelibs
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/www/gnome-user-share/Makefile b/www/gnome-user-share/Makefile
index b7c837ae7c75..7104814a2498 100644
--- a/www/gnome-user-share/Makefile
+++ b/www/gnome-user-share/Makefile
@@ -24,7 +24,7 @@ USE_APACHE= yes
APACHE_PORT= www/apache2
USE_GNOME= gnomeprefix gnomehack intlhack libglade2 gconf2
USE_REINPLACE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/www/gtkhtml/Makefile b/www/gtkhtml/Makefile
index 2afdef7917b5..a2835636f566 100644
--- a/www/gtkhtml/Makefile
+++ b/www/gtkhtml/Makefile
@@ -23,7 +23,7 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix gnomehier glibwww libghttp libcapplet gal
INSTALLS_SHLIB= yes
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
CONFIGURE_ARGS= --with-gconf=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/www/harvest/Makefile b/www/harvest/Makefile
index 9d2cfc6abb4b..b1c7e1348fdc 100644
--- a/www/harvest/Makefile
+++ b/www/harvest/Makefile
@@ -17,7 +17,7 @@ COMMENT= Collect information from all over the Internet
USE_BZIP2= yes
USE_PERL5= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 13
+USE_AUTOTOOLS= libtool:13
INSTALLS_SHLIB= yes
NO_MTREE= yes
CONFIGURE_ARGS?= --prefix=${PREFIX}/${PORTNAME} --without-wish
diff --git a/www/httrack/Makefile b/www/httrack/Makefile
index 9bdb1036f89a..c074686b3406 100644
--- a/www/httrack/Makefile
+++ b/www/httrack/Makefile
@@ -18,7 +18,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
diff --git a/www/kazehakase/Makefile b/www/kazehakase/Makefile
index 9925bf52b77e..0db5da8e7628 100644
--- a/www/kazehakase/Makefile
+++ b/www/kazehakase/Makefile
@@ -18,7 +18,7 @@ COMMENT= Kazehakase is a browser with gecko engine like Epiphany or Galeon
BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/${MOZILLA}-plugin${HEADERS_SUFX}.pc:${PORTSDIR}/www/${MOZILLA}${HEADERS_SUFX}
RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/${MOZILLA}-plugin${HEADERS_SUFX}.pc:${PORTSDIR}/www/${MOZILLA}${HEADERS_SUFX}
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_X_PREFIX= yes
USE_GNOME= gnomehack intlhack gnomeprefix gtk20
USE_GMAKE= yes
diff --git a/www/libapreq2/Makefile b/www/libapreq2/Makefile
index b4de3ee1e9df..e82c426bc28f 100644
--- a/www/libapreq2/Makefile
+++ b/www/libapreq2/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
WITH_APACHE2= yes
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-perl-glue --with-apache2-apxs=${APXS}
diff --git a/www/libghttp/Makefile b/www/libghttp/Makefile
index ec0b2c9886cb..e1056bad6593 100644
--- a/www/libghttp/Makefile
+++ b/www/libghttp/Makefile
@@ -14,7 +14,7 @@ MASTER_SITE_SUBDIR= sources/libghttp/1.0
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME http client library
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
INSTALLS_SHLIB= yes
.include <bsd.port.mk>
diff --git a/www/libwww/Makefile b/www/libwww/Makefile
index 9e6616d56b74..de8dea952924 100644
--- a/www/libwww/Makefile
+++ b/www/libwww/Makefile
@@ -16,7 +16,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= The W3C Reference Library
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
CONFIGURE_ARGS= --enable-shared --enable-static --with-zlib
USE_PERL5_BUILD=yes
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 90c2743ed72f..2ec371642ff0 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -17,10 +17,9 @@ COMMENT= A secure, fast, compliant, and very flexible Web Server
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
-USE_AUTOCONF_VER= 259
+USE_AUTOTOOLS= autoconf:259 libtool:15
USE_REINPLACE= yes
USE_RC_SUBR= lighttpd.sh
-USE_LIBTOOL_VER= 15
USE_GNOME= lthack
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --libdir=${PREFIX}/lib/lighttpd
diff --git a/www/mdw/Makefile b/www/mdw/Makefile
index 78f6490193a4..2b2cda5b6a69 100644
--- a/www/mdw/Makefile
+++ b/www/mdw/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://www.redbrick.dcu.ie/~colmmacc/mdw/
MAINTAINER= petef@FreeBSD.org
COMMENT= A utility to check the MD5 sum of a webpage
-USE_AUTOCONF_VER= 213
+USE_AUTOTOOLS= autoconf:213
USE_REINPLACE= yes
MAN1= mdw.1
diff --git a/www/mnogosearch/Makefile b/www/mnogosearch/Makefile
index 48b21cc5ce32..19799428c621 100644
--- a/www/mnogosearch/Makefile
+++ b/www/mnogosearch/Makefile
@@ -20,7 +20,7 @@ MAN5= indexer.conf.5
INSTALLS_SHLIB= yes
USE_GNOME= lthack
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/www/mnogosearch31/Makefile b/www/mnogosearch31/Makefile
index 690de528ec3a..9298749bea8f 100644
--- a/www/mnogosearch31/Makefile
+++ b/www/mnogosearch31/Makefile
@@ -21,7 +21,7 @@ MAN5= indexer.conf.5
INSTALLS_SHLIB= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
APACHE_COMPAT= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/www/mod_clamav/Makefile b/www/mod_clamav/Makefile
index bee4fe19e92b..b6d445a9cd16 100644
--- a/www/mod_clamav/Makefile
+++ b/www/mod_clamav/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS+= clamav:${PORTSDIR}/${CLAMAV_PORT}
USE_APACHE= YES
WITH_APACHE2= YES
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
.if defined(WITH_CLAMAVDEVEL)
CLAMAV_PORT= security/clamav-devel
diff --git a/www/mod_webapp/Makefile b/www/mod_webapp/Makefile
index 24f5ec28a80c..17b3c93d4ed2 100644
--- a/www/mod_webapp/Makefile
+++ b/www/mod_webapp/Makefile
@@ -21,8 +21,7 @@ BUILD_DEPENDS= ${NONEXISTANT}:${PORTSDIR}/devel/apr:configure
USE_REINPLACE= yes
USE_APACHE= yes
-WANT_AUTOCONF_VER=253
-WANT_LIBTOOL_VER=13
+USE_AUTOTOOLS= autoconf:253:env libtool:13:env
GNU_CONFIGURE= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
diff --git a/www/mozilla-bonobo/Makefile b/www/mozilla-bonobo/Makefile
index 607fe249d72a..02c7b63684fb 100644
--- a/www/mozilla-bonobo/Makefile
+++ b/www/mozilla-bonobo/Makefile
@@ -36,7 +36,7 @@ HEADERS_SUFX=
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix libgnomeui libgnomeprint
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
CONFIGURE_ARGS= --with-plugin-install-dir="${PREFIX}/lib/browser_plugins" \
diff --git a/www/oops/Makefile b/www/oops/Makefile
index f7ca5bd31c9f..362e9418645b 100644
--- a/www/oops/Makefile
+++ b/www/oops/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
OOPSVERSION= 1.5.24
USE_SUBMAKE= yes
-USE_AUTOCONF_VER= 259
+USE_AUTOTOOLS= autoconf:259
CONFIGURE_ARGS?=--sbindir=${PREFIX}/sbin \
--sysconfdir=${PREFIX}/etc/oops \
--localstatedir=${OOPSVAR} \
diff --git a/www/openvrml/Makefile b/www/openvrml/Makefile
index 69c8fda27c42..a589c298fec5 100644
--- a/www/openvrml/Makefile
+++ b/www/openvrml/Makefile
@@ -29,7 +29,7 @@ USE_X_PREFIX= yes
USE_GNOME= gnomehack gtk20
USE_SDL= sdl
USE_GCC= 3.4
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -largp -Wl,--rpath -Wl,${X11BASE}/lib/mozilla -L${X11BASE}/lib -lXext" \
XPIDLFLAGS="-I${X11BASE}/share/idl/mozilla"
diff --git a/www/osb-browser/Makefile b/www/osb-browser/Makefile
index df92ce5ce290..86eb8904f1d1 100644
--- a/www/osb-browser/Makefile
+++ b/www/osb-browser/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= nrcit.0:${PORTSDIR}/www/osb-nrcit
USE_X_PREFIX= yes
USE_GNOME= libglade2 gnomehack gnomeprefix
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" \
LDFLAGS="${PTHREAD_LIBS}"
diff --git a/www/osb-nrcit/Makefile b/www/osb-nrcit/Makefile
index 45bec41413c9..22a238c90432 100644
--- a/www/osb-nrcit/Makefile
+++ b/www/osb-nrcit/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= nrcore.0:${PORTSDIR}/www/osb-nrcore \
USE_GNOME= gtk20 gnomehack
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
.include <bsd.port.pre.mk>
diff --git a/www/osb-nrcore/Makefile b/www/osb-nrcore/Makefile
index 95b9f6215cd2..06c9091acccf 100644
--- a/www/osb-nrcore/Makefile
+++ b/www/osb-nrcore/Makefile
@@ -17,7 +17,7 @@ COMMENT= Gtk-Webcore's browser engine
LIB_DEPENDS= jscore.0:${PORTSDIR}/lang/osb-jscore
-USE_INC_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15:inc
USE_REINPLACE= yes
USE_GNOME= gtk20 gnomehack
USE_GCC= 3.4
diff --git a/www/p5-libapreq2/Makefile b/www/p5-libapreq2/Makefile
index b4de3ee1e9df..e82c426bc28f 100644
--- a/www/p5-libapreq2/Makefile
+++ b/www/p5-libapreq2/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
WITH_APACHE2= yes
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-perl-glue --with-apache2-apxs=${APXS}
diff --git a/www/peacock/Makefile b/www/peacock/Makefile
index 75856382689a..5d281fde8080 100644
--- a/www/peacock/Makefile
+++ b/www/peacock/Makefile
@@ -18,6 +18,6 @@ COMMENT= A GUI-based HTML Editor for GTK+/GNOME
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui gtksourceview gtkhtml3
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
.include <bsd.port.mk>
diff --git a/www/privoxy+ipv6/Makefile b/www/privoxy+ipv6/Makefile
index defa95177f9e..3d7fc6f545a0 100644
--- a/www/privoxy+ipv6/Makefile
+++ b/www/privoxy+ipv6/Makefile
@@ -24,7 +24,7 @@ DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/+ipv6//}
USE_BZIP2= yes
USE_GMAKE= yes
-USE_AUTOHEADER_VER=213
+USE_AUTOTOOLS= autoheader:213
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
--with-user=${USER} --with-group=${GROUP} \
diff --git a/www/privoxy/Makefile b/www/privoxy/Makefile
index 03cf4d7074ab..b02712789fbe 100644
--- a/www/privoxy/Makefile
+++ b/www/privoxy/Makefile
@@ -19,7 +19,7 @@ COMMENT= Privoxy is a web proxy with advanced filtering capabilities
WRKSRC= ${WRKDIR}/privoxy-${PORTVERSION}-stable
USE_GMAKE= yes
-USE_AUTOCONF_VER= 253
+USE_AUTOTOOLS= autoconf:253
USE_REINPLACE= yes
USE_RC_SUBR= privoxy.sh
diff --git a/www/scout/Makefile b/www/scout/Makefile
index e13ee57226e5..6f2f6567933c 100644
--- a/www/scout/Makefile
+++ b/www/scout/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= ftp://sid.joedog.org/pub/scout/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= A utility to harvest URLs from a given start point
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS+= --disable-shared --enable-static
MAN1= scout.1
PLIST_FILES= bin/scout
diff --git a/www/swfdec-plugin/Makefile b/www/swfdec-plugin/Makefile
index 389f26e4cd52..2fba8cd6420d 100644
--- a/www/swfdec-plugin/Makefile
+++ b/www/swfdec-plugin/Makefile
@@ -31,7 +31,7 @@ USE_GNOME= gnomehack gtk20 libartlgpl2
USE_GSTREAMER= gconf
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/www/swish-e/Makefile b/www/swish-e/Makefile
index 3ee04e43e8f9..3de8f4813009 100644
--- a/www/swish-e/Makefile
+++ b/www/swish-e/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Simple web indexing for humans - enhanced
USE_GNOME= libxml2
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
diff --git a/www/twhttpd/Makefile b/www/twhttpd/Makefile
index 9ca097182a0c..cca4cac1be47 100644
--- a/www/twhttpd/Makefile
+++ b/www/twhttpd/Makefile
@@ -17,7 +17,7 @@ COMMENT= Secure HTTP Proxy
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_AUTOCONF_VER= 213
+USE_AUTOTOOLS= autoconf:213
do-install:
@${INSTALL_PROGRAM} -o root -g wheel -m 0755 ${WRKSRC}/twhttpd ${PREFIX}/sbin/twhttpd
diff --git a/www/webstone-ssl/Makefile b/www/webstone-ssl/Makefile
index 898afd21369b..4a1b07866e78 100644
--- a/www/webstone-ssl/Makefile
+++ b/www/webstone-ssl/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= fortune@n.jpn.ph
COMMENT= World wide web server benchmarking with SSL support
USE_OPENSSL= yes
-USE_AUTOCONF_VER= 213
+USE_AUTOTOOLS= autoconf:213
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/WebStone${PORTVERSION}/src
ALL_TARGET= install
diff --git a/www/winhelpcgi/Makefile b/www/winhelpcgi/Makefile
index ac948684490f..96068402cd24 100644
--- a/www/winhelpcgi/Makefile
+++ b/www/winhelpcgi/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= wmf.2:${PORTSDIR}/graphics/libwmf
WRKSRC= ${WRKDIR}/${PORTNAME}-1.0rc3
GNU_CONFIGURE= yes
-USE_AUTOMAKE_VER= 14
+USE_AUTOTOOLS= automake:14
USE_GETTEXT= yes
USE_APACHE= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/www/wml/Makefile b/www/wml/Makefile
index 5f47736beccf..71e31e56deb6 100644
--- a/www/wml/Makefile
+++ b/www/wml/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_ARGS= --with-perl=${PERL5}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib" \
PERL_ARCH="${PERL_ARCH}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
LIBTOOLFILES= wml_backend/p2_mp4h/configure
PLIST_SUB+= ARCH=${PERL_ARCH}
diff --git a/www/wsdlpull/Makefile b/www/wsdlpull/Makefile
index 8e74587e9a3d..c9b8967ea749 100644
--- a/www/wsdlpull/Makefile
+++ b/www/wsdlpull/Makefile
@@ -18,7 +18,7 @@ COMMENT= C++ WSDL Parser
LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
USE_REINPLACE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_GETOPT_LONG=yes
WRKSRC= ${WRKDIR}/${DISTNAME:R}
GNU_CONFIGURE= yes
diff --git a/www/wyvern/Makefile b/www/wyvern/Makefile
index 6bf9ccc82074..625d090f4d88 100644
--- a/www/wyvern/Makefile
+++ b/www/wyvern/Makefile
@@ -16,7 +16,7 @@ COMMENT= Simple/powerful/lightweight/secure/embed-able HTTP server
USE_BZIP2= yes
USE_OPENSSL= yes
USE_GMAKE= yes
-USE_AUTOCONF_VER= 259
+USE_AUTOTOOLS= autoconf:259
NO_MTREE= yes