aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/mod_auth_form/Makefile1
-rw-r--r--www/mod_cplusplus/Makefile1
-rw-r--r--www/mod_jk-apache2/Makefile2
-rw-r--r--www/mod_proctitle/Makefile1
-rw-r--r--www/p5-Apache-Scoreboard/Makefile2
-rw-r--r--www/suphp/Makefile3
6 files changed, 8 insertions, 2 deletions
diff --git a/www/mod_auth_form/Makefile b/www/mod_auth_form/Makefile
index c76f85d982e8..90673a9c8140 100644
--- a/www/mod_auth_form/Makefile
+++ b/www/mod_auth_form/Makefile
@@ -27,7 +27,6 @@ CONFIGURE_ENV= MYSQL_PREFIX="${LOCALBASE}" APACHE2_PREFIX="${LOCALBASE}" \
APR1_INCLUDE="${LOCALBASE}/include/apache2"
CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -I${LOCALBASE}/lib
PORTDOCS= AUTHORS NEWS README
diff --git a/www/mod_cplusplus/Makefile b/www/mod_cplusplus/Makefile
index c928dd6d78a3..d34d0ef81553 100644
--- a/www/mod_cplusplus/Makefile
+++ b/www/mod_cplusplus/Makefile
@@ -17,6 +17,7 @@ MAKE_JOBS_SAFE= yes
USE_APACHE= 2.0+
USE_AUTOTOOLS= autoconf:262 autoheader:262 libtool:22 automake:19 aclocal:19
+CFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-apxs=${APXS}
diff --git a/www/mod_jk-apache2/Makefile b/www/mod_jk-apache2/Makefile
index 072d418cb7c2..2e8c71ec2225 100644
--- a/www/mod_jk-apache2/Makefile
+++ b/www/mod_jk-apache2/Makefile
@@ -16,4 +16,6 @@ COMMENT= Apache2 JK module for connecting to Tomcat using AJP1X
MAKE_JOBS_SAFE= yes
+CFLAGS+= -I${LOCALBASE}/include
+
.include "${MASTERDIR}/Makefile"
diff --git a/www/mod_proctitle/Makefile b/www/mod_proctitle/Makefile
index 078cc05cfe5b..fa09709c332d 100644
--- a/www/mod_proctitle/Makefile
+++ b/www/mod_proctitle/Makefile
@@ -18,6 +18,7 @@ MAKE_JOBS_SAFE= yes
USE_APACHE?= 2.0+
GNU_CONFIGURE= yes
USE_BZIP2= yes
+CFLAGS+= -I${LOCALBASE}/include
PLIST_FILES= ${APACHEMODDIR}/${PORTNAME}.so
do-install:
diff --git a/www/p5-Apache-Scoreboard/Makefile b/www/p5-Apache-Scoreboard/Makefile
index 0893ffaedeba..2952a73b835d 100644
--- a/www/p5-Apache-Scoreboard/Makefile
+++ b/www/p5-Apache-Scoreboard/Makefile
@@ -19,6 +19,8 @@ COMMENT= Perl interface to the Apache scoreboard structure
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
RUN_DEPENDS= ${BUILD_DEPENDS}
+CFLAGS+= -I${LOCALBASE}/include
+
PERL_CONFIGURE= YES
MAN3= Apache::Scoreboard.3
diff --git a/www/suphp/Makefile b/www/suphp/Makefile
index dc5e6b7b18d5..031879eb6213 100644
--- a/www/suphp/Makefile
+++ b/www/suphp/Makefile
@@ -20,12 +20,13 @@ USE_AUTOTOOLS= aclocal:110:env automake:110:env autoconf:262:env libtool:22:env
# Maintainer has not tested suPHP 0.6.x on Apache 1.3.
USE_APACHE= 2.0+
+CFLAGS+= -I${LOCALBASE}/include
USE_PHP= yes
WANT_PHP_CGI= yes
MYPORTDOCS= apache/CONFIG apache/INSTALL apache/README CONFIG LICENSE INSTALL README
-CONFIGURE_ARGS= CFLAGS=-I${LOCALBASE}/include --with-apxs=${APXS}
+CONFIGURE_ARGS= CFLAGS="${CFLAGS}" --with-apxs=${APXS}
# WITH_SETID_MODE should be a value of "owner", "force", or "paranoid".
# It's important that you understand the differences between each mode.