aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/aria/Makefile2
-rw-r--r--www/mod_perl/Makefile2
-rw-r--r--www/mod_perl2/Makefile2
-rw-r--r--www/mod_python3/Makefile2
-rw-r--r--www/mod_roaming2/Makefile2
-rw-r--r--www/p5-Apache-AddHostPath/Makefile2
-rw-r--r--www/p5-Apache-Archive/Makefile2
-rw-r--r--www/p5-Apache-AuthenCache/Makefile2
-rw-r--r--www/p5-Apache-AutoIndex/Makefile2
-rw-r--r--www/p5-Apache-CompressClientFixup/Makefile2
-rw-r--r--www/p5-Apache-ConfigParser/Makefile2
-rw-r--r--www/p5-Apache-DB/Makefile2
-rw-r--r--www/p5-Apache-DBI-mp1/Makefile2
-rw-r--r--www/p5-Apache-DBI-mp2/Makefile2
-rw-r--r--www/p5-Apache-DBI/Makefile2
-rw-r--r--www/p5-Apache-Language/Makefile2
-rw-r--r--www/p5-Apache-Reload/Makefile2
-rw-r--r--www/p5-Apache-Session/Makefile2
-rw-r--r--www/p5-Apache-Test/Makefile2
-rw-r--r--www/p5-ApacheBench/Makefile2
-rw-r--r--www/p5-AxKit/Makefile2
-rw-r--r--www/p5-HTML-Scrubber/Makefile2
-rw-r--r--www/p5-HTTP-Size/Makefile2
-rw-r--r--www/p5-MasonX-WebApp/Makefile2
-rw-r--r--www/p5-Maypole/Makefile2
-rw-r--r--www/ruby-cruisecontrolrb/Makefile2
-rw-r--r--www/serf/Makefile2
-rw-r--r--www/smb2www/Makefile2
-rw-r--r--www/webglimpse/Makefile2
-rw-r--r--www/wsdlpull/Makefile2
-rw-r--r--www/wwwstat/Makefile2
31 files changed, 62 insertions, 0 deletions
diff --git a/www/aria/Makefile b/www/aria/Makefile
index 82fcfda653d3..e4f33be2aa88 100644
--- a/www/aria/Makefile
+++ b/www/aria/Makefile
@@ -14,6 +14,8 @@ MASTER_SITES= SF/aria-rpm
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= Yet another download tool
+MAKE_JOBS_SAFE= yes
+
USE_BZIP2= yes
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
diff --git a/www/mod_perl/Makefile b/www/mod_perl/Makefile
index a4c482967522..a30261fa4483 100644
--- a/www/mod_perl/Makefile
+++ b/www/mod_perl/Makefile
@@ -17,6 +17,8 @@ COMMENT= Embeds a Perl interpreter in the Apache server
BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS= ${BUILD_DEPENDS}
+MAKE_JOBS_SAFE= yes
+
PORTSCOUT= limit:^1
USE_APACHE= 1.3
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
index 75f0929db34b..64fc4cb4f413 100644
--- a/www/mod_perl2/Makefile
+++ b/www/mod_perl2/Makefile
@@ -20,6 +20,8 @@ COMMENT= Embeds a Perl interpreter in the Apache2 server
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/BSD/Resource.pm:${PORTSDIR}/devel/p5-BSD-Resource
RUN_DEPENDS= ${BUILD_DEPENDS}
+MAKE_JOBS_SAFE= yes
+
SUB_FILES= pkg-message
SUB_LIST= APACHEMODDIR=${APACHEMODDIR}
USE_APACHE= 2.0+
diff --git a/www/mod_python3/Makefile b/www/mod_python3/Makefile
index b802d7afc6ad..2e45ccc6fd46 100644
--- a/www/mod_python3/Makefile
+++ b/www/mod_python3/Makefile
@@ -16,6 +16,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= Apache module that embeds the Python interpreter within the server
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 2.0+
USE_PYTHON= yes
diff --git a/www/mod_roaming2/Makefile b/www/mod_roaming2/Makefile
index 2f3f6d6ab6da..08fefecbdc1d 100644
--- a/www/mod_roaming2/Makefile
+++ b/www/mod_roaming2/Makefile
@@ -17,6 +17,8 @@ DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= An Apache module that works as a Netscape Roaming Access server
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 2.0+
AP_FAST_BUILD= yes
AP_GENPLIST= yes
diff --git a/www/p5-Apache-AddHostPath/Makefile b/www/p5-Apache-AddHostPath/Makefile
index 77e68c90ec12..d8fb8e297ebf 100644
--- a/www/p5-Apache-AddHostPath/Makefile
+++ b/www/p5-Apache-AddHostPath/Makefile
@@ -14,6 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= Perl interface for transforming a requested URI based on host/port
+MAKE_JOBS_SAFE= yes
+
PERL_CONFIGURE= yes
MAN3= Apache::AddHostPath.3
diff --git a/www/p5-Apache-Archive/Makefile b/www/p5-Apache-Archive/Makefile
index 4749ce8f5c72..bbf447028eca 100644
--- a/www/p5-Apache-Archive/Makefile
+++ b/www/p5-Apache-Archive/Makefile
@@ -17,6 +17,8 @@ COMMENT= Perl module that creates a menu to allow perusal of tarball contents
BUILD_DEPENDS= ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar
RUN_DEPENDS= ${BUILD_DEPENDS}
+MAKE_JOBS_SAFE= yes
+
PERL_CONFIGURE= yes
MAN3= Apache::Archive.3
diff --git a/www/p5-Apache-AuthenCache/Makefile b/www/p5-Apache-AuthenCache/Makefile
index bd0f12bf4293..523f23e78870 100644
--- a/www/p5-Apache-AuthenCache/Makefile
+++ b/www/p5-Apache-AuthenCache/Makefile
@@ -19,6 +19,8 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Time/Object.pm:${PORTSDIR}/devel/p5-Tim
${SITE_PERL}/IPC/Cache.pm:${PORTSDIR}/devel/p5-IPC-Cache
RUN_DEPENDS= ${BUILD_DEPENDS}
+MAKE_JOBS_SAFE= yes
+
.if defined(WITH_APACHE2)
IGNORE= this module is only for www/mod_perl
.else
diff --git a/www/p5-Apache-AutoIndex/Makefile b/www/p5-Apache-AutoIndex/Makefile
index fd1137188a90..e0d9279211cd 100644
--- a/www/p5-Apache-AutoIndex/Makefile
+++ b/www/p5-Apache-AutoIndex/Makefile
@@ -19,6 +19,8 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache/src.pm:${PORTSDIR}/www/mod_perl
${SITE_PERL}/${PERL_ARCH}/Apache/Language.pm:${PORTSDIR}/www/p5-Apache-Language \
${SITE_PERL}/${PERL_ARCH}/HTML/HeadParser.pm:${PORTSDIR}/www/p5-HTML-Parser
+MAKE_JOBS_SAFE= yes
+
PERL_CONFIGURE= yes
MAN3= Apache::AutoIndex.3
diff --git a/www/p5-Apache-CompressClientFixup/Makefile b/www/p5-Apache-CompressClientFixup/Makefile
index cb22a5ae8f86..46c97f1ba593 100644
--- a/www/p5-Apache-CompressClientFixup/Makefile
+++ b/www/p5-Apache-CompressClientFixup/Makefile
@@ -17,6 +17,8 @@ COMMENT= Perl extension for Apache-1.3.X to avoid gzip compression for known bug
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache/Constants.pm:${PORTSDIR}/www/mod_perl
RUN_DEPENDS= ${BUILD_DEPENDS}
+MAKE_JOBS_SAFE= yes
+
PERL_CONFIGURE= yes
MAN3= Apache::CompressClientFixup.3
diff --git a/www/p5-Apache-ConfigParser/Makefile b/www/p5-Apache-ConfigParser/Makefile
index 58b10999ac10..08cc67a4158f 100644
--- a/www/p5-Apache-ConfigParser/Makefile
+++ b/www/p5-Apache-ConfigParser/Makefile
@@ -17,6 +17,8 @@ COMMENT= Load Apache configuration files
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/FnMatch.pm:${PORTSDIR}/devel/p5-File-FnMatch \
${SITE_PERL}/Tree/DAG_Node.pm:${PORTSDIR}/devel/p5-Tree-DAG_Node
+MAKE_JOBS_SAFE= yes
+
MAN3= Apache::ConfigParser.3 Apache::ConfigParser::Directive.3
PERL_CONFIGURE= yes
diff --git a/www/p5-Apache-DB/Makefile b/www/p5-Apache-DB/Makefile
index 52d272a264ef..3a3f070b0c33 100644
--- a/www/p5-Apache-DB/Makefile
+++ b/www/p5-Apache-DB/Makefile
@@ -14,6 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= Debugging and profiling tools for mod_perl
+MAKE_JOBS_SAFE= yes
+
PERL_CONFIGURE= yes
MAN3= Apache::DB.3 Apache::DProf.3 Apache::perl5db.3 \
diff --git a/www/p5-Apache-DBI-mp1/Makefile b/www/p5-Apache-DBI-mp1/Makefile
index 5c6a4a2ec931..b483956e3692 100644
--- a/www/p5-Apache-DBI-mp1/Makefile
+++ b/www/p5-Apache-DBI-mp1/Makefile
@@ -10,6 +10,8 @@ PKGNAMESUFFIX= -mp1
COMMENT= DBI persistent connection, authentication and authorization (mp1)
+MAKE_JOBS_SAFE= yes
+
MASTERDIR= ${.CURDIR}/../p5-Apache-DBI
.if defined(WITH_MODPERL2) || defined(WITHOUT_MODPERL)
diff --git a/www/p5-Apache-DBI-mp2/Makefile b/www/p5-Apache-DBI-mp2/Makefile
index 698373d77e89..9ab74d71c596 100644
--- a/www/p5-Apache-DBI-mp2/Makefile
+++ b/www/p5-Apache-DBI-mp2/Makefile
@@ -10,6 +10,8 @@ PKGNAMESUFFIX= -mp2
COMMENT= DBI persistent connection, authentication and authorization (mp2)
+MAKE_JOBS_SAFE= yes
+
MASTERDIR= ${.CURDIR}/../p5-Apache-DBI
.if defined(WITH_MODPERL) || defined(WITHOUT_MODPERL2)
diff --git a/www/p5-Apache-DBI/Makefile b/www/p5-Apache-DBI/Makefile
index 99160492ef70..ee75fd653a83 100644
--- a/www/p5-Apache-DBI/Makefile
+++ b/www/p5-Apache-DBI/Makefile
@@ -20,6 +20,8 @@ SLAVEDIRS= www/p5-Apache-DBI-mp1 www/p5-Apache-DBI-mp2
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+MAKE_JOBS_SAFE= yes
+
MAN3= Apache::DBI.3 Apache::AuthDBI.3
PERL_CONFIGURE= yes
diff --git a/www/p5-Apache-Language/Makefile b/www/p5-Apache-Language/Makefile
index 761d622f386c..3c338593b2ab 100644
--- a/www/p5-Apache-Language/Makefile
+++ b/www/p5-Apache-Language/Makefile
@@ -17,6 +17,8 @@ COMMENT= A perl module that provides language-aware object hashes
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache/src.pm:${PORTSDIR}/www/mod_perl \
${SITE_PERL}/I18N/LangTags.pm:${PORTSDIR}/misc/p5-I18N-LangTags
+MAKE_JOBS_SAFE= yes
+
PERL_CONFIGURE= yes
MAN3= Apache::Language.3 Apache::Language::Constants.3 \
diff --git a/www/p5-Apache-Reload/Makefile b/www/p5-Apache-Reload/Makefile
index 4bd6d972d548..892e81f91bb9 100644
--- a/www/p5-Apache-Reload/Makefile
+++ b/www/p5-Apache-Reload/Makefile
@@ -15,6 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= Reload changed modules
+MAKE_JOBS_SAFE= yes
+
PERL_CONFIGURE= yes
MAN3= Apache2::Reload.3 Apache::Reload.3
diff --git a/www/p5-Apache-Session/Makefile b/www/p5-Apache-Session/Makefile
index e5138299452c..68aa5eccae55 100644
--- a/www/p5-Apache-Session/Makefile
+++ b/www/p5-Apache-Session/Makefile
@@ -14,6 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= A persistence framework for session data
+MAKE_JOBS_SAFE= yes
+
PERL_CONFIGURE= yes
MAN3= Apache::Session.3 \
diff --git a/www/p5-Apache-Test/Makefile b/www/p5-Apache-Test/Makefile
index 2ec5d17d20f9..c87c55ca69d6 100644
--- a/www/p5-Apache-Test/Makefile
+++ b/www/p5-Apache-Test/Makefile
@@ -15,6 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= Test.pm wrapper with helpers for testing Apache
+MAKE_JOBS_SAFE= yes
+
## XXX: Need to fix this, www/mod_perl2 currently @2.0.3 contains A-T 1.29,
## XXX: but
## XXX: A-T has released 1.30
diff --git a/www/p5-ApacheBench/Makefile b/www/p5-ApacheBench/Makefile
index 162c107cb754..6e214212e836 100644
--- a/www/p5-ApacheBench/Makefile
+++ b/www/p5-ApacheBench/Makefile
@@ -15,6 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= Perl module for HTTP benchmarking
+MAKE_JOBS_SAFE= yes
+
PERL_CONFIGURE= yes
MAN3= HTTPD::Bench::ApacheBench.3
diff --git a/www/p5-AxKit/Makefile b/www/p5-AxKit/Makefile
index 829d795a73d2..fba6947d72c1 100644
--- a/www/p5-AxKit/Makefile
+++ b/www/p5-AxKit/Makefile
@@ -31,6 +31,8 @@ BUILD_DEPENDS= \
${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS= ${BUILD_DEPENDS}
+MAKE_JOBS_SAFE= yes
+
MAN3= \
Apache::AxKit::DirHandler.3 \
Apache::AxKit::Language.3 \
diff --git a/www/p5-HTML-Scrubber/Makefile b/www/p5-HTML-Scrubber/Makefile
index 19d1566864fd..37f6f3eaa72b 100644
--- a/www/p5-HTML-Scrubber/Makefile
+++ b/www/p5-HTML-Scrubber/Makefile
@@ -17,6 +17,8 @@ COMMENT= Perl extension for scrubbing/sanitizing html
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser
+MAKE_JOBS_SAFE= yes
+
PERL_CONFIGURE= yes
MAN3= HTML::Scrubber.3
diff --git a/www/p5-HTTP-Size/Makefile b/www/p5-HTTP-Size/Makefile
index d028ddf5312d..39d58a432527 100644
--- a/www/p5-HTTP-Size/Makefile
+++ b/www/p5-HTTP-Size/Makefile
@@ -19,6 +19,8 @@ BUILD_DEPENDS= p5-libwww>0:${PORTSDIR}/www/p5-libwww \
p5-HTML-SimpleLinkExtor>0:${PORTSDIR}/www/p5-HTML-SimpleLinkExtor
RUN_DEPENDS= ${BUILD_DEPENDS}
+MAKE_JOBS_SAFE= yes
+
MAN3= HTTP::Size.3
PERL_CONFIGURE= yes
diff --git a/www/p5-MasonX-WebApp/Makefile b/www/p5-MasonX-WebApp/Makefile
index f75d620d54a1..672ee79ea3ed 100644
--- a/www/p5-MasonX-WebApp/Makefile
+++ b/www/p5-MasonX-WebApp/Makefile
@@ -26,6 +26,8 @@ BUILD_DEPENDS= ${RUN_DEPENDS}
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
.else
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+
+MAKE_JOBS_SAFE= yes
.endif
PERL_MODBUILD= yes
diff --git a/www/p5-Maypole/Makefile b/www/p5-Maypole/Makefile
index baa115e0efef..575be561aa54 100644
--- a/www/p5-Maypole/Makefile
+++ b/www/p5-Maypole/Makefile
@@ -39,6 +39,8 @@ BUILD_DEPENDS= p5-CGI-Simple>0:${PORTSDIR}/www/p5-CGI-Simple \
p5-libwww>0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS= ${BUILD_DEPENDS}
+MAKE_JOBS_SAFE= yes
+
OPTIONS= MODPERL "mod_perl support" on \
MODPERL2 "mod_perl2 support" off
diff --git a/www/ruby-cruisecontrolrb/Makefile b/www/ruby-cruisecontrolrb/Makefile
index bc5f8591c51a..e07ceb084d2b 100644
--- a/www/ruby-cruisecontrolrb/Makefile
+++ b/www/ruby-cruisecontrolrb/Makefile
@@ -18,6 +18,8 @@ COMMENT= Continuous Integration Server For Rails Applications
RUN_DEPENDS= rubygem-mongrel>=1.0.1:${PORTSDIR}/www/rubygem-mongrel \
svn:${PORTSDIR}/devel/subversion
+MAKE_JOBS_SAFE= yes
+
USE_RC_SUBR= cruisecontrolrb
NO_BUILD= yes
diff --git a/www/serf/Makefile b/www/serf/Makefile
index 0657a9100b48..8c8f79caaccb 100644
--- a/www/serf/Makefile
+++ b/www/serf/Makefile
@@ -17,6 +17,8 @@ COMMENT= Serf HTTP client library
LIB_DEPENDS+= apr-1:${PORTSDIR}/devel/apr
+MAKE_JOBS_SAFE= yes
+
PROJECTHOST= serf
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/www/smb2www/Makefile b/www/smb2www/Makefile
index 8dbdf13f33de..a554f5a1e1ce 100644
--- a/www/smb2www/Makefile
+++ b/www/smb2www/Makefile
@@ -19,6 +19,8 @@ COMMENT= Windows Network client that is accessible through a web browser
RUN_DEPENDS= smbclient:${PORTSDIR}/net/samba3 \
${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 1.3
USE_PERL5= yes
NO_BUILD= yes
diff --git a/www/webglimpse/Makefile b/www/webglimpse/Makefile
index 8cbf0ea64cb1..f13f910c996e 100644
--- a/www/webglimpse/Makefile
+++ b/www/webglimpse/Makefile
@@ -17,6 +17,8 @@ COMMENT= WWW interface to Glimpse search engine
RUN_DEPENDS= glimpse:${PORTSDIR}/textproc/glimpse
+MAKE_JOBS_SAFE= yes
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.edu
USE_PERL5= yes
diff --git a/www/wsdlpull/Makefile b/www/wsdlpull/Makefile
index 58b82bc702ac..884defa0c6ad 100644
--- a/www/wsdlpull/Makefile
+++ b/www/wsdlpull/Makefile
@@ -16,6 +16,8 @@ COMMENT= C++ WSDL Parser
LIB_DEPENDS= curl.5:${PORTSDIR}/ftp/curl
+MAKE_JOBS_SAFE= yes
+
USE_GNOME= gnometarget
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/www/wwwstat/Makefile b/www/wwwstat/Makefile
index e4e99984b629..d1e658f90889 100644
--- a/www/wwwstat/Makefile
+++ b/www/wwwstat/Makefile
@@ -19,6 +19,8 @@ PATCHFILES= patch-2.01.txt
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= Webserver logfile analysis package
+MAKE_JOBS_SAFE= yes
+
USE_APACHE= 1.3+
USE_PERL5= yes
MAKE_ENV+= PERL5=${PERL5}