aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/chromium/files/patch-third__party_wayland_include_config.h23
-rw-r--r--www/chromium/files/patch-ui_ozone_platform_wayland_host_zwp__text__input__wrapper__v1.cc21
-rw-r--r--www/edbrowse/Makefile7
-rw-r--r--www/edbrowse/files/extra-patch-openssl11
-rw-r--r--www/firefox-esr/files/patch-third__party_libwebrtc_rtc__base_ip__address.cc23
-rw-r--r--www/firefox/files/patch-third__party_libwebrtc_rtc__base_ip__address.cc23
-rw-r--r--www/h2o-devel/Makefile1
-rw-r--r--www/h2o/Makefile1
-rw-r--r--www/iridium/files/patch-third__party_wayland_include_config.h23
-rw-r--r--www/iridium/files/patch-ui_ozone_platform_wayland_host_zwp__text__input__wrapper__v1.cc21
-rw-r--r--www/ladybird/Makefile1
-rw-r--r--www/librewolf/files/patch-third__party_libwebrtc_rtc__base_ip__address.cc23
-rw-r--r--www/luakit-devel/Makefile3
-rw-r--r--www/luakit/Makefile3
-rw-r--r--www/nginx-devel/Makefile7
-rw-r--r--www/nginx/Makefile7
-rw-r--r--www/osrm-backend/Makefile10
-rw-r--r--www/qt5-webengine/Makefile4
-rw-r--r--www/tor-browser/files/patch-third__party_libwebrtc_rtc__base_ip__address.cc23
-rw-r--r--www/ungoogled-chromium/files/patch-third__party_wayland_include_config.h23
-rw-r--r--www/ungoogled-chromium/files/patch-ui_ozone_platform_wayland_host_zwp__text__input__wrapper__v1.cc21
-rw-r--r--www/webkit2-gtk4/files/patch-Source_WTF_wtf_PlatformCPU.h28
-rw-r--r--www/webkit2-gtk4/files/patch-Source_WTF_wtf_dtoa_utils.h12
23 files changed, 27 insertions, 292 deletions
diff --git a/www/chromium/files/patch-third__party_wayland_include_config.h b/www/chromium/files/patch-third__party_wayland_include_config.h
index 6b7e5c6c9d9a..30297975c5e9 100644
--- a/www/chromium/files/patch-third__party_wayland_include_config.h
+++ b/www/chromium/files/patch-third__party_wayland_include_config.h
@@ -1,21 +1,6 @@
---- third_party/wayland/include/config.h.orig 2023-03-01 05:42:12 UTC
+--- third_party/wayland/include/config.h.orig 2023-12-06 23:00:58 UTC
+++ third_party/wayland/include/config.h
-@@ -9,7 +9,14 @@
-
- #define HAVE_BROKEN_MSG_CMSG_CLOEXEC 0
-
-+#if defined(__FreeBSD__)
-+#include <osreldate.h>
-+#if defined(__FreeBSD_version) && __FreeBSD_version < 1300048
-+#undef HAVE_MEMFD_CREATE
-+#else
- #define HAVE_MEMFD_CREATE
-+#endif
-+#endif
-
- #define HAVE_MKOSTEMP
-
-@@ -25,7 +32,11 @@
+@@ -25,11 +25,14 @@
#undef HAVE_SYS_PROCCTL_H
@@ -27,3 +12,7 @@
#define HAVE_XUCRED_CR_PID 0
+ #define PACKAGE "wayland"
+
+ #define PACKAGE_VERSION "1.21.0"
+-
diff --git a/www/chromium/files/patch-ui_ozone_platform_wayland_host_zwp__text__input__wrapper__v1.cc b/www/chromium/files/patch-ui_ozone_platform_wayland_host_zwp__text__input__wrapper__v1.cc
deleted file mode 100644
index 93077eaa7c04..000000000000
--- a/www/chromium/files/patch-ui_ozone_platform_wayland_host_zwp__text__input__wrapper__v1.cc
+++ /dev/null
@@ -1,21 +0,0 @@
---- ui/ozone/platform/wayland/host/zwp_text_input_wrapper_v1.cc.orig 2023-10-11 18:22:24 UTC
-+++ ui/ozone/platform/wayland/host/zwp_text_input_wrapper_v1.cc
-@@ -226,6 +226,10 @@ void ZWPTextInputWrapperV1::SetSurroundingText(
- // so if it exceeds 16 bits, it may be broken.
- static constexpr size_t kSizeLimit = 60000;
- if (HasAdvancedSurroundingTextSupport() && text.length() > kSizeLimit) {
-+#if defined(__FreeBSD_version) && __FreeBSD_version < 1300048
-+ PLOG(ERROR) << "memfd is not supported";
-+ return;
-+#else
- base::ScopedFD memfd(memfd_create("surrounding_text", MFD_CLOEXEC));
- if (!memfd.get()) {
- PLOG(ERROR) << "Failed to create memfd";
-@@ -238,6 +242,7 @@ void ZWPTextInputWrapperV1::SetSurroundingText(
- zcr_extended_text_input_v1_set_large_surrounding_text(
- extended_obj_.get(), memfd.get(), text.length(),
- selection_range.start(), selection_range.end());
-+#endif
- } else {
- zwp_text_input_v1_set_surrounding_text(obj_.get(), text.c_str(),
- selection_range.start(),
diff --git a/www/edbrowse/Makefile b/www/edbrowse/Makefile
index c65a59d355f8..c8274684bdb0 100644
--- a/www/edbrowse/Makefile
+++ b/www/edbrowse/Makefile
@@ -31,13 +31,6 @@ PORTDOCS= *
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
-# Skip openssl.pc while using OpenSSL from base system on older FreeBSD versions which does not skip this file
-.if ${SSL_DEFAULT} == base && !exists(/usr/libdata/pkgconfig/openssl.pc)
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-openssl
-.endif
-
do-install:
${INSTALL_MAN} ${WRKSRC}/doc/man-edbrowse-freebsd.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/${PORTNAME}.1
${INSTALL_PROGRAM} ${WRKSRC}/src/edbrowse ${STAGEDIR}${PREFIX}/bin
diff --git a/www/edbrowse/files/extra-patch-openssl b/www/edbrowse/files/extra-patch-openssl
deleted file mode 100644
index 97786da57ebf..000000000000
--- a/www/edbrowse/files/extra-patch-openssl
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/makefile.orig 2023-11-17 18:00:41.589174000 +0100
-+++ src/makefile 2023-11-17 18:01:13.273125000 +0100
-@@ -9,7 +9,7 @@
- CFLAGS += $(PLATFORM_CFLAGS)
-
- # determine includes and linker flags
--DEPENDENCIES = libcurl:curl odbc libpcre2-8:pcre2-8 readline openssl
-+DEPENDENCIES = libcurl:curl odbc libpcre2-8:pcre2-8 readline
- INCLUDES = $(shell ./make-helper.sh pkg-config-includes $(DEPENDENCIES))
- LINKER_LIBS = $(shell ./make-helper.sh pkg-config-libs $(DEPENDENCIES))
- CFLAGS += $(INCLUDES)
diff --git a/www/firefox-esr/files/patch-third__party_libwebrtc_rtc__base_ip__address.cc b/www/firefox-esr/files/patch-third__party_libwebrtc_rtc__base_ip__address.cc
deleted file mode 100644
index 5af9e7ec2d70..000000000000
--- a/www/firefox-esr/files/patch-third__party_libwebrtc_rtc__base_ip__address.cc
+++ /dev/null
@@ -1,23 +0,0 @@
-commit d1f5a45c1906e9f1e6a51f3b44c52d981bb3958c
-Author: Christoph Moench-Tegeder <cmt@burggraben.net>
-Date: Wed Oct 12 19:57:20 2022 +0200
-
- pull in sys/types.h for u_XXX typedefs on FreeBSD 12
-
- In file included from /wrkdirs/usr/ports/www/firefox/work/firefox-106.0/third_party/libwebrtc/rtc_base/ip_address.cc:20:
- /usr/include/netinet/ip.h:53:2: error: unknown type name 'u_char'; did you mean 'char'?
- u_char ip_hl:4, /* header length */
-
-diff --git third_party/libwebrtc/rtc_base/ip_address.cc third_party/libwebrtc/rtc_base/ip_address.cc
-index d544b611e149..ef9b742dac5f 100644
---- third_party/libwebrtc/rtc_base/ip_address.cc
-+++ third_party/libwebrtc/rtc_base/ip_address.cc
-@@ -11,6 +11,8 @@
- #if defined(WEBRTC_POSIX)
- #include <netinet/in.h>
- #include <sys/socket.h>
-+/* for u_char/u_short etc on FreeBSD 12 */
-+#include <sys/types.h>
-
- #include "absl/strings/string_view.h"
- #ifdef OPENBSD
diff --git a/www/firefox/files/patch-third__party_libwebrtc_rtc__base_ip__address.cc b/www/firefox/files/patch-third__party_libwebrtc_rtc__base_ip__address.cc
deleted file mode 100644
index 5af9e7ec2d70..000000000000
--- a/www/firefox/files/patch-third__party_libwebrtc_rtc__base_ip__address.cc
+++ /dev/null
@@ -1,23 +0,0 @@
-commit d1f5a45c1906e9f1e6a51f3b44c52d981bb3958c
-Author: Christoph Moench-Tegeder <cmt@burggraben.net>
-Date: Wed Oct 12 19:57:20 2022 +0200
-
- pull in sys/types.h for u_XXX typedefs on FreeBSD 12
-
- In file included from /wrkdirs/usr/ports/www/firefox/work/firefox-106.0/third_party/libwebrtc/rtc_base/ip_address.cc:20:
- /usr/include/netinet/ip.h:53:2: error: unknown type name 'u_char'; did you mean 'char'?
- u_char ip_hl:4, /* header length */
-
-diff --git third_party/libwebrtc/rtc_base/ip_address.cc third_party/libwebrtc/rtc_base/ip_address.cc
-index d544b611e149..ef9b742dac5f 100644
---- third_party/libwebrtc/rtc_base/ip_address.cc
-+++ third_party/libwebrtc/rtc_base/ip_address.cc
-@@ -11,6 +11,8 @@
- #if defined(WEBRTC_POSIX)
- #include <netinet/in.h>
- #include <sys/socket.h>
-+/* for u_char/u_short etc on FreeBSD 12 */
-+#include <sys/types.h>
-
- #include "absl/strings/string_view.h"
- #ifdef OPENBSD
diff --git a/www/h2o-devel/Makefile b/www/h2o-devel/Makefile
index 49d731d58d6b..fb4319266318 100644
--- a/www/h2o-devel/Makefile
+++ b/www/h2o-devel/Makefile
@@ -13,7 +13,6 @@ LICENSE_COMB= multi
BROKEN_armv6= fails to compile: asm_arm.inc:139:36: '.syntax divided' arm assembly not supported
BROKEN_armv7= fails to compile: asm_arm.inc:139:36: '.syntax divided' arm assembly not supported
-BROKEN_FreeBSD_12_powerpc64= fails to link on powerpc64 elfv1: unrecognized option '-Wl,-rpath=/usr/local/lib/gcc6'
BUILD_DEPENDS= rubygem-rake>=0:devel/rubygem-rake
LIB_DEPENDS= libuv.so:devel/libuv
diff --git a/www/h2o/Makefile b/www/h2o/Makefile
index 1cd762f288ac..fe51682ffaea 100644
--- a/www/h2o/Makefile
+++ b/www/h2o/Makefile
@@ -17,7 +17,6 @@ LICENSE_COMB= multi
DEPRECATED= Upstream EOL confirmed on 2023-10-10, removal planned for 2023-12-30
BROKEN_armv6= fails to compile: asm_arm.inc:139:36: '.syntax divided' arm assembly not supported
BROKEN_armv7= fails to compile: asm_arm.inc:139:36: '.syntax divided' arm assembly not supported
-BROKEN_FreeBSD_12_powerpc64= fails to link: unrecognized option '-Wl,-rpath=/usr/local/lib/gcc6'
LIB_DEPENDS= libuv.so:devel/libuv
diff --git a/www/iridium/files/patch-third__party_wayland_include_config.h b/www/iridium/files/patch-third__party_wayland_include_config.h
index 4275b5ab44b4..40c25cadce67 100644
--- a/www/iridium/files/patch-third__party_wayland_include_config.h
+++ b/www/iridium/files/patch-third__party_wayland_include_config.h
@@ -1,21 +1,6 @@
---- third_party/wayland/include/config.h.orig 2023-03-13 07:33:08 UTC
+--- third_party/wayland/include/config.h.orig 2023-11-15 11:07:48 UTC
+++ third_party/wayland/include/config.h
-@@ -9,7 +9,14 @@
-
- #define HAVE_BROKEN_MSG_CMSG_CLOEXEC 0
-
-+#if defined(__FreeBSD__)
-+#include <osreldate.h>
-+#if defined(__FreeBSD_version) && __FreeBSD_version < 1300048
-+#undef HAVE_MEMFD_CREATE
-+#else
- #define HAVE_MEMFD_CREATE
-+#endif
-+#endif
-
- #define HAVE_MKOSTEMP
-
-@@ -25,7 +32,11 @@
+@@ -25,11 +25,14 @@
#undef HAVE_SYS_PROCCTL_H
@@ -27,3 +12,7 @@
#define HAVE_XUCRED_CR_PID 0
+ #define PACKAGE "wayland"
+
+ #define PACKAGE_VERSION "1.21.0"
+-
diff --git a/www/iridium/files/patch-ui_ozone_platform_wayland_host_zwp__text__input__wrapper__v1.cc b/www/iridium/files/patch-ui_ozone_platform_wayland_host_zwp__text__input__wrapper__v1.cc
deleted file mode 100644
index e187da9c1274..000000000000
--- a/www/iridium/files/patch-ui_ozone_platform_wayland_host_zwp__text__input__wrapper__v1.cc
+++ /dev/null
@@ -1,21 +0,0 @@
---- ui/ozone/platform/wayland/host/zwp_text_input_wrapper_v1.cc.orig 2023-10-21 11:51:27 UTC
-+++ ui/ozone/platform/wayland/host/zwp_text_input_wrapper_v1.cc
-@@ -226,6 +226,10 @@ void ZWPTextInputWrapperV1::SetSurroundingText(
- // so if it exceeds 16 bits, it may be broken.
- static constexpr size_t kSizeLimit = 60000;
- if (HasAdvancedSurroundingTextSupport() && text.length() > kSizeLimit) {
-+#if defined(__FreeBSD_version) && __FreeBSD_version < 1300048
-+ PLOG(ERROR) << "memfd is not supported";
-+ return;
-+#else
- base::ScopedFD memfd(memfd_create("surrounding_text", MFD_CLOEXEC));
- if (!memfd.get()) {
- PLOG(ERROR) << "Failed to create memfd";
-@@ -238,6 +242,7 @@ void ZWPTextInputWrapperV1::SetSurroundingText(
- zcr_extended_text_input_v1_set_large_surrounding_text(
- extended_obj_.get(), memfd.get(), text.length(),
- selection_range.start(), selection_range.end());
-+#endif
- } else {
- zwp_text_input_v1_set_surrounding_text(obj_.get(), text.c_str(),
- selection_range.start(),
diff --git a/www/ladybird/Makefile b/www/ladybird/Makefile
index 2dbdde6f42d8..d486369b303e 100644
--- a/www/ladybird/Makefile
+++ b/www/ladybird/Makefile
@@ -24,7 +24,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
# see Userland/Libraries/LibWeb/Loader/ResourceLoader.h
ONLY_FOR_ARCHS= aarch64 amd64 i386 riscv64
ONLY_FOR_ARCHS_REASON= other architectures not recognised by build system
-BROKEN_FreeBSD_12= C++ template issues
BROKEN_i386= Userland/Libraries/LibJIT/GDBElf.cpp:29:24: bit cast source size does not equal destination size
BUILD_DEPENDS= ${LOCALBASE}/share/public_suffix_list/public_suffix_list.dat:dns/public_suffix_list
diff --git a/www/librewolf/files/patch-third__party_libwebrtc_rtc__base_ip__address.cc b/www/librewolf/files/patch-third__party_libwebrtc_rtc__base_ip__address.cc
deleted file mode 100644
index 5af9e7ec2d70..000000000000
--- a/www/librewolf/files/patch-third__party_libwebrtc_rtc__base_ip__address.cc
+++ /dev/null
@@ -1,23 +0,0 @@
-commit d1f5a45c1906e9f1e6a51f3b44c52d981bb3958c
-Author: Christoph Moench-Tegeder <cmt@burggraben.net>
-Date: Wed Oct 12 19:57:20 2022 +0200
-
- pull in sys/types.h for u_XXX typedefs on FreeBSD 12
-
- In file included from /wrkdirs/usr/ports/www/firefox/work/firefox-106.0/third_party/libwebrtc/rtc_base/ip_address.cc:20:
- /usr/include/netinet/ip.h:53:2: error: unknown type name 'u_char'; did you mean 'char'?
- u_char ip_hl:4, /* header length */
-
-diff --git third_party/libwebrtc/rtc_base/ip_address.cc third_party/libwebrtc/rtc_base/ip_address.cc
-index d544b611e149..ef9b742dac5f 100644
---- third_party/libwebrtc/rtc_base/ip_address.cc
-+++ third_party/libwebrtc/rtc_base/ip_address.cc
-@@ -11,6 +11,8 @@
- #if defined(WEBRTC_POSIX)
- #include <netinet/in.h>
- #include <sys/socket.h>
-+/* for u_char/u_short etc on FreeBSD 12 */
-+#include <sys/types.h>
-
- #include "absl/strings/string_view.h"
- #ifdef OPENBSD
diff --git a/www/luakit-devel/Makefile b/www/luakit-devel/Makefile
index 484c51c1484f..5eb0029ff2c8 100644
--- a/www/luakit-devel/Makefile
+++ b/www/luakit-devel/Makefile
@@ -13,9 +13,6 @@ WWW= https://luakit.github.io
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING.GPLv3
-NOT_FOR_ARCHS= sparc64
-NOT_FOR_ARCHS_REASON_sparc64= Does not install on sparc64
-
BUILD_DEPENDS= help2man:misc/help2man \
${LUA_MODLIBDIR}/lfs.so:devel/luafilesystem@${LUA_FLAVOR}
LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
diff --git a/www/luakit/Makefile b/www/luakit/Makefile
index 06b1ad60ac83..543dea6d7344 100644
--- a/www/luakit/Makefile
+++ b/www/luakit/Makefile
@@ -11,9 +11,6 @@ WWW= https://luakit.github.io
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING.GPLv3
-NOT_FOR_ARCHS= sparc64
-NOT_FOR_ARCHS_REASON_sparc64= Does not install on sparc64
-
BUILD_DEPENDS= help2man:misc/help2man \
${LUA_MODLIBDIR}/lfs.so:devel/luafilesystem@${LUA_FLAVOR}
LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index db5d7e5ade6b..a10ae1556677 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -151,6 +151,8 @@ HTTP_IMAGE_FILTER_VARS= DSO_BASEMODS+=http_image_filter_module
HTTP_MP4_CONFIGURE_ON= --with-http_mp4_module
HTTP_PERL_CATEGORIES= perl5
HTTP_PERL_USES= perl5
+# Fix build failure on clang >= 12
+HTTP_PERL_CFLAGS= -Wno-compound-token-split-by-macro
HTTP_PERL_VARS= DSO_BASEMODS+=http_perl_module
HTTP_RANDOM_INDEX_CONFIGURE_ON= --with-http_random_index_module
HTTP_REALIP_CONFIGURE_ON= --with-http_realip_module
@@ -241,11 +243,6 @@ CFLAGS+= -DNDEBUG
CONFIGURE_ENV+= EXTRA_PRE_CXXFLAGS="-std=c++14"
.endif
-# Fix build failure on clang >= 12
-.if ${PORT_OPTIONS:MHTTP_PERL} && ${OSVERSION} >= 1301000
-CFLAGS+= -Wno-compound-token-split-by-macro
-.endif
-
.if empty(PORT_OPTIONS:MLUA) && empty(PORT_OPTIONS:MMODSECURITY3) && \
empty(PORT_OPTIONS:MPASSENGER)
CONFIGURE_ARGS+= --with-ld-opt="-L ${LOCALBASE}/lib"
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index cc09a0a1f60a..e18aca01d390 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -151,6 +151,8 @@ HTTP_IMAGE_FILTER_VARS= DSO_BASEMODS+=http_image_filter_module
HTTP_MP4_CONFIGURE_ON= --with-http_mp4_module
HTTP_PERL_CATEGORIES= perl5
HTTP_PERL_USES= perl5
+# Fix build failure on clang >= 12
+HTTP_PERL_CFLAGS= -Wno-compound-token-split-by-macro
HTTP_PERL_VARS= DSO_BASEMODS+=http_perl_module
HTTP_RANDOM_INDEX_CONFIGURE_ON= --with-http_random_index_module
HTTP_REALIP_CONFIGURE_ON= --with-http_realip_module
@@ -244,11 +246,6 @@ CFLAGS+= -DNDEBUG
CONFIGURE_ENV+= EXTRA_PRE_CXXFLAGS="-std=c++14"
.endif
-# Fix build failure on clang >= 12
-.if ${PORT_OPTIONS:MHTTP_PERL} && ${OSVERSION} >= 1301000
-CFLAGS+= -Wno-compound-token-split-by-macro
-.endif
-
.if empty(PORT_OPTIONS:MLUA) && empty(PORT_OPTIONS:MMODSECURITY3) && \
empty(PORT_OPTIONS:MPASSENGER)
CONFIGURE_ARGS+= --with-ld-opt="-L ${LOCALBASE}/lib"
diff --git a/www/osrm-backend/Makefile b/www/osrm-backend/Makefile
index 4a30f4f0226f..2b2c625515b8 100644
--- a/www/osrm-backend/Makefile
+++ b/www/osrm-backend/Makefile
@@ -31,17 +31,13 @@ OPTIONS_DEFINE= DEBUG
USE_RC_SUBR= osrm
+CXXFLAGS+= -Wno-range-loop-construct
+
USERS= osrm
GROUPS= osrm
CMAKE_ON= BUILD_STATIC_LIBS
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 1300084
-CXXFLAGS+= -Wno-range-loop-construct
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-Werror=all -Werror=extra|-Werror=extra|g' \
${PATCH_WRKSRC}/CMakeLists.txt
@@ -49,4 +45,4 @@ post-patch:
pre-install:
@${MKDIR} ${STAGEDIR}/var/db/osrm-backend
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/qt5-webengine/Makefile b/www/qt5-webengine/Makefile
index f7ac3d51ee88..e0789d04942a 100644
--- a/www/qt5-webengine/Makefile
+++ b/www/qt5-webengine/Makefile
@@ -124,7 +124,7 @@ QT_BINARIES= yes
.include <bsd.port.pre.mk>
-.if ${ARCH:Mmips*} || ${ARCH:Mpowerpc*} || ${ARCH} == sparc64
+.if ${ARCH:Mmips*} || ${ARCH:Mpowerpc*}
PLIST_SUB+= BE="" LE="@comment "
.else
PLIST_SUB+= BE="@comment " LE=""
@@ -152,7 +152,7 @@ post-patch:
@${REINPLACE_CMD} -E -e 's|^(MODULE_VERSION = ).*|\1${QT5_VERSION}|' \
${WRKSRC}/.qmake.conf
-.if ${ARCH:Mmips*} || ${ARCH:Mpowerpc*} || ${ARCH} == sparc64
+.if ${ARCH:Mmips*} || ${ARCH:Mpowerpc*}
@${REINPLACE_CMD} -e 's/icudtl.dat/icudtb.dat/' \
${WRKSRC}/src/core/core_module.pro
.endif
diff --git a/www/tor-browser/files/patch-third__party_libwebrtc_rtc__base_ip__address.cc b/www/tor-browser/files/patch-third__party_libwebrtc_rtc__base_ip__address.cc
deleted file mode 100644
index 5af9e7ec2d70..000000000000
--- a/www/tor-browser/files/patch-third__party_libwebrtc_rtc__base_ip__address.cc
+++ /dev/null
@@ -1,23 +0,0 @@
-commit d1f5a45c1906e9f1e6a51f3b44c52d981bb3958c
-Author: Christoph Moench-Tegeder <cmt@burggraben.net>
-Date: Wed Oct 12 19:57:20 2022 +0200
-
- pull in sys/types.h for u_XXX typedefs on FreeBSD 12
-
- In file included from /wrkdirs/usr/ports/www/firefox/work/firefox-106.0/third_party/libwebrtc/rtc_base/ip_address.cc:20:
- /usr/include/netinet/ip.h:53:2: error: unknown type name 'u_char'; did you mean 'char'?
- u_char ip_hl:4, /* header length */
-
-diff --git third_party/libwebrtc/rtc_base/ip_address.cc third_party/libwebrtc/rtc_base/ip_address.cc
-index d544b611e149..ef9b742dac5f 100644
---- third_party/libwebrtc/rtc_base/ip_address.cc
-+++ third_party/libwebrtc/rtc_base/ip_address.cc
-@@ -11,6 +11,8 @@
- #if defined(WEBRTC_POSIX)
- #include <netinet/in.h>
- #include <sys/socket.h>
-+/* for u_char/u_short etc on FreeBSD 12 */
-+#include <sys/types.h>
-
- #include "absl/strings/string_view.h"
- #ifdef OPENBSD
diff --git a/www/ungoogled-chromium/files/patch-third__party_wayland_include_config.h b/www/ungoogled-chromium/files/patch-third__party_wayland_include_config.h
index 6b7e5c6c9d9a..14da7a98faf5 100644
--- a/www/ungoogled-chromium/files/patch-third__party_wayland_include_config.h
+++ b/www/ungoogled-chromium/files/patch-third__party_wayland_include_config.h
@@ -1,21 +1,6 @@
---- third_party/wayland/include/config.h.orig 2023-03-01 05:42:12 UTC
+--- third_party/wayland/include/config.h.orig 2023-11-28 23:10:47 UTC
+++ third_party/wayland/include/config.h
-@@ -9,7 +9,14 @@
-
- #define HAVE_BROKEN_MSG_CMSG_CLOEXEC 0
-
-+#if defined(__FreeBSD__)
-+#include <osreldate.h>
-+#if defined(__FreeBSD_version) && __FreeBSD_version < 1300048
-+#undef HAVE_MEMFD_CREATE
-+#else
- #define HAVE_MEMFD_CREATE
-+#endif
-+#endif
-
- #define HAVE_MKOSTEMP
-
-@@ -25,7 +32,11 @@
+@@ -25,11 +25,14 @@
#undef HAVE_SYS_PROCCTL_H
@@ -27,3 +12,7 @@
#define HAVE_XUCRED_CR_PID 0
+ #define PACKAGE "wayland"
+
+ #define PACKAGE_VERSION "1.21.0"
+-
diff --git a/www/ungoogled-chromium/files/patch-ui_ozone_platform_wayland_host_zwp__text__input__wrapper__v1.cc b/www/ungoogled-chromium/files/patch-ui_ozone_platform_wayland_host_zwp__text__input__wrapper__v1.cc
deleted file mode 100644
index a1493e4809a8..000000000000
--- a/www/ungoogled-chromium/files/patch-ui_ozone_platform_wayland_host_zwp__text__input__wrapper__v1.cc
+++ /dev/null
@@ -1,21 +0,0 @@
---- ui/ozone/platform/wayland/host/zwp_text_input_wrapper_v1.cc.orig 2023-10-13 13:20:35 UTC
-+++ ui/ozone/platform/wayland/host/zwp_text_input_wrapper_v1.cc
-@@ -226,6 +226,10 @@ void ZWPTextInputWrapperV1::SetSurroundingText(
- // so if it exceeds 16 bits, it may be broken.
- static constexpr size_t kSizeLimit = 60000;
- if (HasAdvancedSurroundingTextSupport() && text.length() > kSizeLimit) {
-+#if defined(__FreeBSD_version) && __FreeBSD_version < 1300048
-+ PLOG(ERROR) << "memfd is not supported";
-+ return;
-+#else
- base::ScopedFD memfd(memfd_create("surrounding_text", MFD_CLOEXEC));
- if (!memfd.get()) {
- PLOG(ERROR) << "Failed to create memfd";
-@@ -238,6 +242,7 @@ void ZWPTextInputWrapperV1::SetSurroundingText(
- zcr_extended_text_input_v1_set_large_surrounding_text(
- extended_obj_.get(), memfd.get(), text.length(),
- selection_range.start(), selection_range.end());
-+#endif
- } else {
- zwp_text_input_v1_set_surrounding_text(obj_.get(), text.c_str(),
- selection_range.start(),
diff --git a/www/webkit2-gtk4/files/patch-Source_WTF_wtf_PlatformCPU.h b/www/webkit2-gtk4/files/patch-Source_WTF_wtf_PlatformCPU.h
deleted file mode 100644
index 3ca8ff6ffc9e..000000000000
--- a/www/webkit2-gtk4/files/patch-Source_WTF_wtf_PlatformCPU.h
+++ /dev/null
@@ -1,28 +0,0 @@
-https://bugs.webkit.org/show_bug.cgi?id=129963
-
-Index: Source/WTF/wtf/PlatformCPU.h
---- Source/WTF/wtf/PlatformCPU.h.orig
-+++ Source/WTF/wtf/PlatformCPU.h
-@@ -95,6 +95,13 @@
- #define WTF_CPU_KNOWN 1
- #endif
-
-+/* CPU(SPARC64) - SPARC V9 */
-+#if defined(__sparc64__)
-+#define WTF_CPU_KNOWN 1
-+#define WTF_CPU_SPARC64 1
-+#define WTF_CPU_BIG_ENDIAN 1
-+#endif
-+
- /* CPU(X86) - i386 / x86 32-bit */
- #if defined(__i386__) \
- || defined(i386) \
-@@ -295,7 +302,7 @@
- #define WTF_CPU_UNKNOWN 1
- #endif
-
--#if CPU(ARM) || CPU(MIPS) || CPU(RISCV64) || CPU(UNKNOWN)
-+#if CPU(ARM) || CPU(MIPS) || CPU(RISCV64) || CPU(SPARC64) || CPU(UNKNOWN)
- #define WTF_CPU_NEEDS_ALIGNED_ACCESS 1
- #endif
-
diff --git a/www/webkit2-gtk4/files/patch-Source_WTF_wtf_dtoa_utils.h b/www/webkit2-gtk4/files/patch-Source_WTF_wtf_dtoa_utils.h
deleted file mode 100644
index 2612dca3be93..000000000000
--- a/www/webkit2-gtk4/files/patch-Source_WTF_wtf_dtoa_utils.h
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: Source/WTF/wtf/dtoa/utils.h
---- Source/WTF/wtf/dtoa/utils.h.orig
-+++ Source/WTF/wtf/dtoa/utils.h
-@@ -87,7 +87,7 @@ int main(int argc, char** argv) {
- defined(__powerpc__) || defined(__ppc__) || defined(__ppc64__) || \
- defined(_POWER) || defined(_ARCH_PPC) || defined(_ARCH_PPC64) || \
- defined(__sparc__) || defined(__sparc) || defined(__s390__) || \
-- defined(__SH4__) || defined(__alpha__) || \
-+ defined(__SH4__) || defined(__alpha__) || defined(__sparc64__) || \
- defined(_MIPS_ARCH_MIPS32R2) || \
- defined(__AARCH64EL__) || defined(__aarch64__) || defined(__AARCH64EB__) || \
- defined(__riscv) || \