aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks/catclock/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-clocks/catclock/Makefile')
-rw-r--r--x11-clocks/catclock/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-clocks/catclock/Makefile b/x11-clocks/catclock/Makefile
new file mode 100644
index 000000000000..ee54201a30d5
--- /dev/null
+++ b/x11-clocks/catclock/Makefile
@@ -0,0 +1,37 @@
+PORTNAME= catclock
+PORTVERSION= g20200328
+CATEGORIES= x11-clocks
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Kit-cat xclock
+
+LICENSE= MIT
+
+USES= localbase:ldflags motif xorg
+USE_GITHUB= yes
+GH_ACCOUNT= BarkyTheDog
+GH_TAGNAME= 9de77d05e04bc463bdbd8cfe1f9247042369e3f9
+USE_XORG= x11 xext xt
+
+CFLAGS+= -I${LOCALBASE}/include/X11
+LIBS+= -lX11 ${MOTIFLIB} -lXt -lXext -lm
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/man/man1/${PORTNAME}.1.gz
+PORTDOCS= README.md readme_original
+PORTEXAMPLES= xclock.ad
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} ${LIBS} -o ${PORTNAME} *.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xclock.man ${STAGEDIR}${PREFIX}/share/man/man1/${PORTNAME}.1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/|} ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>